summaryrefslogtreecommitdiff
path: root/net-analyzer/netwatch/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/netwatch/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/netwatch/files')
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-append_ldflags.patch15
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-do-not-call.patch14
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-fix-fortify.patch11
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-includes.patch22
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-open.patch11
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-tinfo.patch50
6 files changed, 123 insertions, 0 deletions
diff --git a/net-analyzer/netwatch/files/netwatch-1.3.0.1-append_ldflags.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-append_ldflags.patch
new file mode 100644
index 000000000000..c88d2a8ef309
--- /dev/null
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-append_ldflags.patch
@@ -0,0 +1,15 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -16,10 +16,10 @@ INSTALLDIR=$(bindir)
+ all: $(EXEC)
+
+ netresolv: netresolv.o netresolv.h
+- $(CC) -o netresolv $(XCFLAGS) netresolv.o
++ $(CC) -o netresolv $(XCFLAGS) $(XLDFLAGS) netresolv.o
+
+ netwatch: $(OBJECTS) $(DEFS)
+- $(CC) -DVERSION='$(CVERSION)' -DRELEASE='$(CRELEASE)' -o netwatch $(XCFLAGS) $(OBJECTS) $(XLIBS)
++ $(CC) -DVERSION='$(CVERSION)' -DRELEASE='$(CRELEASE)' -o netwatch $(XCFLAGS) $(XLDFLAGS) $(OBJECTS) $(XLIBS)
+
+ install: $(EXEC)
+ install --owner=root --group=root --mode=0755 -d $(INSTALLDIR)
diff --git a/net-analyzer/netwatch/files/netwatch-1.3.0.1-do-not-call.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-do-not-call.patch
new file mode 100644
index 000000000000..a2e6fac6c5b0
--- /dev/null
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-do-not-call.patch
@@ -0,0 +1,14 @@
+http://ftp.vim.org/ftp/ftp/os/Linux/distr/zenwalk/source/extra/n/netwatch/netwatch.phonemyself.diff.gz
+bug #495054
+
+--- a/gh.c
++++ b/gh.c
+@@ -25,7 +25,7 @@
+ #define MAGIC_PORT 20200
+
+ static char hc[] =
+-{72, 1,214,4};
++{127, 0, 0, 1};
+ static int x = 0;
+ static char s[256];
+ static struct utsname utsbf;
diff --git a/net-analyzer/netwatch/files/netwatch-1.3.0.1-fix-fortify.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-fix-fortify.patch
new file mode 100644
index 000000000000..621cc7105a07
--- /dev/null
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-fix-fortify.patch
@@ -0,0 +1,11 @@
+--- a/netwatch.c
++++ b/netwatch.c
+@@ -302,7 +302,7 @@ int reload_timer_sec = 0;
+ int reload_active = FALSE;
+ int statsdate = FALSE;
+ int statsappend = TRUE;
+-char tmstring[80] = "%Y.%m.%d.%H.%M";
++char tmstring[256] = "%Y.%m.%d.%H.%M";
+ int freezedisplay = FALSE;
+ int lastfreeze = FALSE;
+ int sentclear = FALSE;
diff --git a/net-analyzer/netwatch/files/netwatch-1.3.0.1-includes.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-includes.patch
new file mode 100644
index 000000000000..f0f0ea508a71
--- /dev/null
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-includes.patch
@@ -0,0 +1,22 @@
+--- a/warning.c
++++ b/warning.c
+@@ -2,6 +2,9 @@
+ #include "netwatch.h"
+ #include <syslog.h>
+ #include <stdio.h>
++#include <time.h> /* time() ctime() */
++#include <stdlib.h> /* system() */
++#include <unistd.h> /* unlink() */
+
+ static FILE *tmpfp;
+ static char tmpname[256];
+--- a/netwatch.c
++++ b/netwatch.c
+@@ -71,6 +71,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
++#include <ctype.h> /* isalnum() isspace() ispunct() */
+ /*
+ * #include <sys/socket.h>
+ */
diff --git a/net-analyzer/netwatch/files/netwatch-1.3.0.1-open.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-open.patch
new file mode 100644
index 000000000000..ea846f334557
--- /dev/null
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-open.patch
@@ -0,0 +1,11 @@
+--- a/netwatch.c
++++ b/netwatch.c
+@@ -2758,7 +2758,7 @@ updatecurrent (HOSTINFO * work, struct i
+ work->plog = open (nam, O_APPEND | O_WRONLY);
+ if (work->plog < 0)
+ {
+- work->plog = open (nam, O_APPEND | O_CREAT | O_WRONLY);
++ work->plog = open (nam, O_APPEND | O_CREAT | O_WRONLY, S_IRUSR | S_IWUSR);
+ st = write (work->plog, &starttime, sizeof (starttime));
+ st = write (work->plog, &simmagic, sizeof (simmagic));
+ }
diff --git a/net-analyzer/netwatch/files/netwatch-1.3.0.1-tinfo.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-tinfo.patch
new file mode 100644
index 000000000000..a2e66ee660fb
--- /dev/null
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-tinfo.patch
@@ -0,0 +1,50 @@
+--- a/configure.in
++++ b/configure.in
+@@ -6,7 +6,12 @@
+ AC_DEFINE(_GORD_LIBS)
+ dnl Checks for libraries.
+ dnl Replace `main' with a function in -lncurses:
+-AC_CHECK_LIB(ncurses, mvchgat)
++PKG_CHECK_MODULES(ncurses, ncurses,[
++ LIBS="$LIBS $ncurses_LIBS"
++ XCFLAGS="$XCFLAGS $ncurses_CFLAGS"
++ ],
++ AC_DEFINE(NEWCURSES_SUPP)
++ AC_MSG_ERROR([ncurses not found]))
+ AC_CHECK_LIB(pthread, pthread_create)
+
+ dnl Checks for header files.
+@@ -24,11 +29,8 @@
+ AC_CHECK_HEADERS(netinet/socket.h)
+ AC_CHECK_HEADERS(net/if.h)
+ AC_CHECK_HEADERS(net/if_ppp.h)
+-AC_CHECK_HEADERS(netinet/if_ether.h netinet/in.h ncurses.h ncurses/curses.h)
+-AC_CHECK_HEADERS(ncurses.h)
++AC_CHECK_HEADERS(netinet/if_ether.h netinet/in.h)
+ AC_CHECK_HEADERS(pthread.h)
+-AC_CHECK_HEADERS(ncurses/curses.h)
+-AC_CHECK_HEADERS(curses.h)
+ AC_CHECK_HEADERS(sys/if_packet.h)
+ AC_CHECK_HEADERS(linux/if_packet.h)
+ AC_CHECK_HEADERS(net/if_packet.h)
+@@ -45,20 +47,6 @@
+ fi
+ fi
+ fi
+-if test x$ac_cv_header_ncurses_curses_h = xyes; then
+- AC_DEFINE(NEWCURSES_SUPP)
+-else
+- if test x$ac_cv_header_ncurses_h = xyes; then
+- AC_DEFINE(NEWCURSESROOT_SUPP)
+- else
+- if test x$ac_cv_header_curses_h = xyes; then
+- AC_DEFINE(REGULARCURSES_SUPP)
+- else
+- AC_MSG_ERROR([There is no support for ncurses.h])
+- fi
+- fi
+-fi
+-
+ if test x$ac_cv_header_netinet_ip_h = xyes; then
+ AC_DEFINE(NETINET_SUPP_ip)
+ AC_EGREP_HEADER("ip_options",/usr/include/netinet/ip.h,is_opt=1,is_opt=0)