summaryrefslogtreecommitdiff
path: root/net-analyzer/ospd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /net-analyzer/ospd
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'net-analyzer/ospd')
-rw-r--r--net-analyzer/ospd/Manifest2
-rw-r--r--net-analyzer/ospd/ospd-20.8.2.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/ospd/Manifest b/net-analyzer/ospd/Manifest
index 9e97cd9d290e..7df2740e5358 100644
--- a/net-analyzer/ospd/Manifest
+++ b/net-analyzer/ospd/Manifest
@@ -1,3 +1,5 @@
DIST ospd-2.0.1.tar.gz 87313 BLAKE2B cf527742246ceb5acaf69900d48f1800ef98153026fa6aae2661e4a3aafad6f69221fa7c7f34a222a0972cf5550a9543696b1e7a4368ef050574ca08f72f0978 SHA512 4aed0e1a22ea6c0db26977e7b0bde9c9c37890422f3480ad83ef23ad193b7ae3dd7352872c4fe377808d2a398317a4c1d38d7ab2ef5a0266c544e0ef55a0365a
+DIST ospd-20.8.2.tar.gz 122686 BLAKE2B 3e05c157e41837af52d54fc4f430da57ad5fb3dff97ed6fef7339844e8b0990977a1ef5e0878a06ca7c3e209f988bdd2e13b0829d47f6d309f183960a8a286b3 SHA512 127ca6fe370faf99c9c2d2b182bb524b279d714635f367a30318acde1d383048e7a2a5e3944e83642d3963304c506fe893763b6ee78404391ead8d751c978873
EBUILD ospd-2.0.1.ebuild 753 BLAKE2B 15b7d6b44a51e4b60f61e198bbe35a4b144a05118ae7ab8dad6eef86af30c86931cd0c4f12015fb1ec0de8494a68ac59970ee0b8122875f91ab8073847ee6de1 SHA512 df7cc56f0c2c32efa25c87c9a6f2914a5a100eda406f145276af2a95a9aadf3aaf280bb6d63e12f921dc2433f84d85776b4706958fd188f9f443aabc8210b98d
+EBUILD ospd-20.8.2.ebuild 986 BLAKE2B 61c5bf375567198475c4ad87c27617fc06a52f0a3e1b8d0aefcfe0c79136b40a9e826450d710f2f6f197aa53a370a15d99deaa42c853284649acbcc4eb8df456 SHA512 2ce99eef5a972d37117bdd3d56ed3edd5ea8920febd91cc95c50de126657bdf920b2b3381882b04a09e76c4030f31099ec2890d1ebe15be70d217b7fb3da7856
MISC metadata.xml 900 BLAKE2B 1e11a5fe50a57eec411e7b01480d484244266c5fab3814e1b860edb878810cabc49e3359888775e3d30778a0713d0e8a2cb2c3a04639eed316d89adac22bdd61 SHA512 1a7e244a466fef29dee6d46f6dc1eff5e7dce401980c704b4f6ca2a81c3da644b7705f2b0085c960c76ae0930dfb09bb84ca28d078ae7e73af7be2c083238f96
diff --git a/net-analyzer/ospd/ospd-20.8.2.ebuild b/net-analyzer/ospd/ospd-20.8.2.ebuild
new file mode 100644
index 000000000000..f7108a886271
--- /dev/null
+++ b/net-analyzer/ospd/ospd-20.8.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Base class for scanner wrappers, communication protocol for GVM"
+HOMEPAGE="https://www.greenbone.net/en/ https://github.com/greenbone/ospd/"
+SRC_URI="https://github.com/greenbone/ospd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="AGPL-3+"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras"
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+ #QA-Fix: do not install test subpackages
+ sed -i "s/tests']/tests*']/g" setup.py || die
+}
+
+python_compile() {
+ if use extras; then
+ bash "${S}"/doc/generate || die
+ HTML_DOCS=( "${S}"/doc/. )
+ fi
+ distutils-r1_python_compile
+}