summaryrefslogtreecommitdiff
path: root/net-analyzer/ostinato/ostinato-0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /net-analyzer/ostinato/ostinato-0.9.ebuild
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'net-analyzer/ostinato/ostinato-0.9.ebuild')
-rw-r--r--net-analyzer/ostinato/ostinato-0.9.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/ostinato/ostinato-0.9.ebuild b/net-analyzer/ostinato/ostinato-0.9.ebuild
new file mode 100644
index 000000000000..fa2db04b283b
--- /dev/null
+++ b/net-analyzer/ostinato/ostinato-0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qmake-utils
+
+DESCRIPTION="A packet generator and analyzer"
+HOMEPAGE="http://ostinato.org/"
+SRC_URI="https://github.com/pstavirs/ostinato/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#https://github.com/pstavirs/ostinato/issues/173
+# libpcap dep is versioned to pull in the fix for #602098
+DEPEND="dev-libs/protobuf:=
+ >=net-libs/libpcap-1.8.1-r2
+ dev-qt/qtscript:4
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ eqmake4 PREFIX="${ED}/usr" ost.pro
+}