summaryrefslogtreecommitdiff
path: root/net-analyzer/ostinato/ostinato-1.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-analyzer/ostinato/ostinato-1.1-r2.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-analyzer/ostinato/ostinato-1.1-r2.ebuild')
-rw-r--r--net-analyzer/ostinato/ostinato-1.1-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-analyzer/ostinato/ostinato-1.1-r2.ebuild b/net-analyzer/ostinato/ostinato-1.1-r2.ebuild
new file mode 100644
index 000000000000..bccd03f406c0
--- /dev/null
+++ b/net-analyzer/ostinato/ostinato-1.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+DESCRIPTION="Packet generator and analyzer"
+HOMEPAGE="https://ostinato.org/"
+SRC_URI="https://github.com/pstavirs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#https://github.com/pstavirs/ostinato/issues/173
+# libpcap dep is versioned to pull in the fix for #602098
+DEPEND="
+ dev-libs/protobuf:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dev-libs/libnl:=
+ >=net-libs/libpcap-1.8.1-r2
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9_p20180522-no-modeltest.patch"
+)
+
+src_configure() {
+ eqmake5 PREFIX="/usr" ost.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+}