summaryrefslogtreecommitdiff
path: root/net-analyzer/pathload
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-29 09:22:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-29 09:22:29 +0100
commitb94ab464dd0d948b7e7eac833b9bb51c03515918 (patch)
tree130d52181c215cd1c3eced88bc503353a99a1fe8 /net-analyzer/pathload
parent62ea91b40c7650011a72ed2443f76b88b06123fe (diff)
gentoo auto-resync : 29:09:2022 - 09:22:29
Diffstat (limited to 'net-analyzer/pathload')
-rw-r--r--net-analyzer/pathload/Manifest3
-rw-r--r--net-analyzer/pathload/files/pathload-1.3.2-clang16.patch10
-rw-r--r--net-analyzer/pathload/pathload-1.3.2-r1.ebuild13
3 files changed, 20 insertions, 6 deletions
diff --git a/net-analyzer/pathload/Manifest b/net-analyzer/pathload/Manifest
index c72e2ccbbfbb..6d52cab4e6b3 100644
--- a/net-analyzer/pathload/Manifest
+++ b/net-analyzer/pathload/Manifest
@@ -1,4 +1,5 @@
+AUX pathload-1.3.2-clang16.patch 194 BLAKE2B f021fdf51f5797f03ac15b8ea43fcdd20428415c92b27c397ae37368ea858ce46bf8ff61a6c55cedcc5fa3b92a6b9e179f3eb9b8d043a5cae5b98b16624e36f4 SHA512 9e28d598611b41bb712ab4e9503bf19b000ac48ba0a3f16e24ab9176eac1d51460ae5fa3f661c4e0e4378cf5a68b3f48d09af5dca688cb5e24c1efcc2b8cf783
AUX pathload-1.3.2-make.patch 509 BLAKE2B 317ae2327725e2405802f08110055c970d430db0710ed82594bea5d1148bdb1f224ee335692d73713f8efcb2032d0efe54fba40a474f2f20f23fbefa76322c7e SHA512 b7e4ae8a952f9d0e8cc1ff038bbecda8164817da0d38a3d73b55cecadc550784731aa2664e2f63322b7a38fe35440d01ad12663409d7b4b67d8c5a25f844a234
DIST pathload-1.3.2.tar.gz 68524 BLAKE2B 0ea27000647c292e4d04c92574dc2d63fcdd9c16be57d9af49df8651e6f8905561c70f48b9854c69a16c4b3d16fc8bec61ffed3cbbdad7e1f18e2209e9b4f199 SHA512 9fef51c86b8aa2c28a33effe5a5bff36eebc0812f6d6744fac93df46ec0cbce8f5977d24b6ac52442386fb263550fe46e639c4a3ff4612fe92ad09d6595e5d7f
-EBUILD pathload-1.3.2-r1.ebuild 624 BLAKE2B ac9f2f8b5e93eafef43766259cdff75e5d456857fefda65fdb99c27e15b42e107ed97dd6add36f6d20e99240d0b551a7d7138be579d957625a0a69d7e825b1e8 SHA512 3b4698669cec7d6ff16c5016ad31f93540a0716b149af04961883c70e1ca2d783a72671080da34f945025f2dcdc181c21f55be807ae845f3981fb02303e9e943
+EBUILD pathload-1.3.2-r1.ebuild 653 BLAKE2B d92989969b257f46c0fa07cd950579a62382355b5deb0beaf832a9f8e5590f5152ed3aa25d0c5a3b735c31bd9635b3663eaa61c14de8a5d839664f34aac9552e SHA512 da73ff5aa3567b3f6fc9badaff64f344e7101683b1aa6f1f4f02c225efcfd504a0c7cf7eb84ee0691c55ba4fd954aa6746dceb38d62286347bc5b3f0c72c54b1
MISC metadata.xml 277 BLAKE2B 57fc90092c4674e5c4dfe38b0d79c983990fce4e8208b70c2ebb218aebb6d2135537f927115f3a7b7eb8c1ddb596461c17e60acb3e6a11b289796f20f3c80a33 SHA512 5ac67e6beabab60f83ac521249c6d1f021988d522fc86ab12ec98fbaa9d47a50157c10c7b9a39554e66a02b141cdc6dc6669e5e7c9c02c8b36ad404aa790d619
diff --git a/net-analyzer/pathload/files/pathload-1.3.2-clang16.patch b/net-analyzer/pathload/files/pathload-1.3.2-clang16.patch
new file mode 100644
index 000000000000..9cce41e48417
--- /dev/null
+++ b/net-analyzer/pathload/files/pathload-1.3.2-clang16.patch
@@ -0,0 +1,10 @@
+configure.ac is missing, so need to edit this manually
+
+https://bugs.gentoo.org/870661
+--- a/configure
++++ b/configure
+@@ -630,3 +630,3 @@
+
+-main(){return(0);}
++int main(void){return(0);}
+ EOF
diff --git a/net-analyzer/pathload/pathload-1.3.2-r1.ebuild b/net-analyzer/pathload/pathload-1.3.2-r1.ebuild
index 47f7848cc5a8..b8e220379490 100644
--- a/net-analyzer/pathload/pathload-1.3.2-r1.ebuild
+++ b/net-analyzer/pathload/pathload-1.3.2-r1.ebuild
@@ -1,24 +1,27 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="Non-intrusive utility for estimation of available bandwidth of Internet paths"
HOMEPAGE="https://www.cc.gatech.edu/fac/constantinos.dovrolis/bw-est/pathload.html"
SRC_URI="https://dev.gentoo.org/~jsmolic/distfiles/${P}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-S=${WORKDIR}/${PN}_${PV}
PATCHES=(
- "${FILESDIR}"/${PN}-1.3.2-make.patch
+ "${FILESDIR}"/${P}-make.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_configure() {
tc-export CC
+
default
}