summaryrefslogtreecommitdiff
path: root/net-analyzer/poink/poink-2.03.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /net-analyzer/poink/poink-2.03.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'net-analyzer/poink/poink-2.03.ebuild')
-rw-r--r--net-analyzer/poink/poink-2.03.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/net-analyzer/poink/poink-2.03.ebuild b/net-analyzer/poink/poink-2.03.ebuild
index 856e7aef3a2b..e9f173afff5a 100644
--- a/net-analyzer/poink/poink-2.03.ebuild
+++ b/net-analyzer/poink/poink-2.03.ebuild
@@ -1,30 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="TCP/IP-based ping implementation"
-HOMEPAGE="http://directory.fsf.org/security/system/poink.html"
-SRC_URI="http://ep09.pld-linux.org/~mmazur/poink/${P}.tar.gz"
-LICENSE="GPL-2"
+HOMEPAGE="https://directory.fsf.org/security/system/poink.html"
+SRC_URI="https://ep09.pld-linux.org/~mmazur/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-DEPEND=""
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-2.03-signed-char-fixup.patch
-}
+PATCHES=( "${FILESDIR}/${PN}-2.03-signed-char-fixup.patch" )
src_compile() {
- emake CFLAGS="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" || die
+ emake \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ CC="$(tc-getCC)"
}
src_install() {
dobin poink poink6
newman ping.1 poink.1
- dodoc README* ChangeLog COPYING
+ dodoc README* ChangeLog
}