summaryrefslogtreecommitdiff
path: root/net-analyzer/python-gvm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-analyzer/python-gvm
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-analyzer/python-gvm')
-rw-r--r--net-analyzer/python-gvm/Manifest3
-rw-r--r--net-analyzer/python-gvm/metadata.xml21
-rw-r--r--net-analyzer/python-gvm/python-gvm-1.1.0.ebuild34
3 files changed, 58 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/Manifest b/net-analyzer/python-gvm/Manifest
new file mode 100644
index 000000000000..fbae40786b1c
--- /dev/null
+++ b/net-analyzer/python-gvm/Manifest
@@ -0,0 +1,3 @@
+DIST python-gvm-1.1.0.tar.gz 160289 BLAKE2B 64dbf79f6749c50cddc2b908c45c6aea6c3793f0ddb10a98a96870636ee351f1a2e66227fbcc1383c63e0e015b4c05bf4c116ac80ef35f73f7e9057f9c8dd9b5 SHA512 dae04d42a14adde274c2148f7bd4b47b0ea02d6e249d6c23dfeb15f217f04ad9ff722f2e98d13e1a7add7b61d9dabfec623ab5b45087aaf5f480447fd31a8071
+EBUILD python-gvm-1.1.0.ebuild 825 BLAKE2B 27fa0bc179da27573a4bacb5e8acd8ca7f55132c5ab1fead87afe52cde97c280e2e2e7fc9c8948ea82c6cdb14ca84858c2833100994cbaa023f28a723137ce13 SHA512 e15f846d2e2c9b30ebf4528dbe5fbf6f0b3b16ea71842c1c4d0979fa9e5f3872d519c6f4be683a6c75326b8f7ddfbcd0a6c386fed3f8c5dba93582cafaa4e786
+MISC metadata.xml 887 BLAKE2B 2027f57f28286aa9a7cd3d258dd8af4790b5bd0a852d0c40f48ded6986b129583f7043b36974d7708eb95d258160d7ea22ff3d468caef949f759e83f13bef77b SHA512 f04cfc43ed1f0efda4134830afdf4e6c6a54edcd3c880de49a9888b4093a3ddb0d898ab38f5d68f8bed4dd34810659ece1ad3074beeff742606a37139131a7c6
diff --git a/net-analyzer/python-gvm/metadata.xml b/net-analyzer/python-gvm/metadata.xml
new file mode 100644
index 000000000000..92109f9a1354
--- /dev/null
+++ b/net-analyzer/python-gvm/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hasan.calisir@psauxit.com</email>
+ <name>Hasan ÇALIŞIR</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Greenbone Vulnerability Management Python API library (python-gvm) is a collection of
+ APIs that help with remote controlling a Greenbone Security Manager (GSM) appliance and its
+ underlying Greenbone Vulnerability Manager (GVM). The library essentially abstracts accessing
+ the communication protocols Greenbone Management Protocol (GMP) and Open Scanner Protocol (OSP).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">greenbone/python-gvm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/python-gvm/python-gvm-1.1.0.ebuild b/net-analyzer/python-gvm/python-gvm-1.1.0.ebuild
new file mode 100644
index 000000000000..9a52388287f5
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net/en/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ # Exlude tests & docs to fix build issue
+ sed \
+ -e "s/packages=find_packages(exclude=.*/packages=find_packages(exclude=['tests*', 'docs']),/g" \
+ -i "$S"/setup.py || die
+}