summaryrefslogtreecommitdiff
path: root/net-analyzer/sec/sec-2.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-07 15:42:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-07 15:42:35 +0100
commita693a49d235bea057923bcbc2ee6a40cce4bb060 (patch)
tree7b927ab3d5df3dce15e8c6a727db1831137f9a00 /net-analyzer/sec/sec-2.9.2.ebuild
parentbba809b22a050e394e6ce550572ee7f6c6e02a6e (diff)
gentoo auto-resync : 07:06:2023 - 15:42:35
Diffstat (limited to 'net-analyzer/sec/sec-2.9.2.ebuild')
-rw-r--r--net-analyzer/sec/sec-2.9.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/sec/sec-2.9.2.ebuild b/net-analyzer/sec/sec-2.9.2.ebuild
new file mode 100644
index 000000000000..e6658bf788e6
--- /dev/null
+++ b/net-analyzer/sec/sec-2.9.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple Event Correlator"
+HOMEPAGE="https://simple-evcorr.github.io/ https://github.com/simple-evcorr/sec"
+SRC_URI="https://github.com/simple-evcorr/sec/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
+
+RDEPEND="
+ >=dev-lang/perl-5.8.0
+ virtual/perl-JSON-PP
+"
+
+src_install() {
+ dobin sec
+
+ dodoc ChangeLog README
+ docinto contrib
+ dodoc contrib/{itostream.c,convert.pl,swatch2sec.pl}
+
+ newman sec.man sec.1
+
+ newinitd "${FILESDIR}"/sec.init.d sec
+ newconfd "${FILESDIR}"/sec.conf.d sec
+}