summaryrefslogtreecommitdiff
path: root/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-08 00:00:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-08 00:00:57 +0100
commit5181ced3f3566a9610b85922b083c8f84f20d78f (patch)
treed7eb288527e8bc248dd17ff874995d8bffe06704 /net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
parent7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (diff)
gentoo auto-resync : 08:05:2024 - 00:00:57
Diffstat (limited to 'net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild')
-rw-r--r--net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild b/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
deleted file mode 100644
index 960612b2f88f..000000000000
--- a/net-analyzer/snortalog/snortalog-2.4.3-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P="${PN}_v${PV}"
-
-inherit edos2unix
-
-DESCRIPTION="A powerful perl script that summarizes snort logs"
-HOMEPAGE="http://jeremy.chartier.free.fr/snortalog/"
-SRC_URI="http://jeremy.chartier.free.fr/snortalog/downloads/${PN}/${MY_P}.tar"
-S="${WORKDIR}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
-IUSE="tk"
-
-RDEPEND="
- dev-lang/perl[ithreads]
- dev-perl/GDGraph
- dev-perl/HTML-HTMLDoc
- virtual/perl-DB_File
- virtual/perl-Getopt-Long
- tk? ( dev-perl/Tk )
-"
-
-src_prepare() {
- default
-
- local convert=$(find conf/ modules/ -type f || die)
- convert+=( ${PN}.* CHANGES )
-
- local item
- for item in ${convert[@]} ; do
- edos2unix "${item}"
- done
-
- # fix paths, erroneous can access message
- sed -i \
- -e "s:\(modules/\):/usr/lib/snortalog/${PV}/\1:g" \
- -e 's:\($domains_file = "\)conf/\(domains\)\(".*\):\1/etc/snortalog/\2\3:' \
- -e 's:\($rules_file = "\)conf/\(rules\)\(".*\):\1/etc/snortalog/\2\3:' \
- -e 's:\($picts_dir ="\)picts\(".*\):\1/etc/snortalog/picts\2:' \
- -e 's:\($hw_file = "\)conf/\(hw\)\(".*\):\1/etc/snortalog/\2\3:' \
- -e 's:\($lang_file ="\)conf/\(lang\)\(".*\):\1/etc/snortalog/\2\3:' \
- -e 's:Can access:Cannot access:' \
- snortalog.pl || die
-}
-
-src_install() {
- dobin snortalog.pl
-
- insinto /etc/snortalog
- doins conf/{domains,hw,lang,rules}
-
- insinto /etc/snortalog/picts
- doins picts/*
-
- insinto /usr/lib/snortalog/${PV}/modules
- doins -r modules/*
-
- dodoc CHANGES doc/snortalog_v2.2.1.pdf
-}