summaryrefslogtreecommitdiff
path: root/net-analyzer/ssh-audit/ssh-audit-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-22 13:48:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-22 13:48:31 +0000
commit9173f73d44f3cbc858477bd71e7680ede7d98e0d (patch)
treeae2808502a372289467a6ce425f580c1473ee15e /net-analyzer/ssh-audit/ssh-audit-3.1.0.ebuild
parent591f45259704c7c0c4289228107c6ee61457420e (diff)
gentoo auto-resync : 22:12:2023 - 13:48:30
Diffstat (limited to 'net-analyzer/ssh-audit/ssh-audit-3.1.0.ebuild')
-rw-r--r--net-analyzer/ssh-audit/ssh-audit-3.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/ssh-audit/ssh-audit-3.1.0.ebuild b/net-analyzer/ssh-audit/ssh-audit-3.1.0.ebuild
new file mode 100644
index 000000000000..f61f9ddb69ed
--- /dev/null
+++ b/net-analyzer/ssh-audit/ssh-audit-3.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=(python3_{10,11,12})
+
+inherit distutils-r1
+
+DESCRIPTION="SSH server auditing (banner, key exchange, encryption, mac, compression, etc)"
+HOMEPAGE="https://github.com/jtesta/ssh-audit"
+SRC_URI="https://github.com/jtesta/ssh-audit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE=""
+
+# Tests require prospector which is not packaged
+RESTRICT="test"
+
+src_install() {
+ distutils-r1_src_install
+
+ doman ssh-audit.1
+}