summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpflow/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /net-analyzer/tcpflow/files
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'net-analyzer/tcpflow/files')
-rw-r--r--net-analyzer/tcpflow/files/tcpflow-1.5.0_alpha-libcapng.patch13
-rw-r--r--net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch64
2 files changed, 77 insertions, 0 deletions
diff --git a/net-analyzer/tcpflow/files/tcpflow-1.5.0_alpha-libcapng.patch b/net-analyzer/tcpflow/files/tcpflow-1.5.0_alpha-libcapng.patch
new file mode 100644
index 000000000000..b56144324c09
--- /dev/null
+++ b/net-analyzer/tcpflow/files/tcpflow-1.5.0_alpha-libcapng.patch
@@ -0,0 +1,13 @@
+--- a/src/tcpflow.cpp
++++ b/src/tcpflow.cpp
+@@ -30,6 +30,10 @@
+ #include <grp.h>
+ #endif
+
++#ifdef HAVE_CAP_NG_H
++#include <cap-ng.h>
++#endif
++
+ /* bring in inet_ntop if it is not present */
+ #define ETH_ALEN 6
+ #ifndef HAVE_INET_NTOP
diff --git a/net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch b/net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch
new file mode 100644
index 000000000000..e6748c019688
--- /dev/null
+++ b/net-analyzer/tcpflow/files/tcpflow-1.5.2-gentoo.patch
@@ -0,0 +1,64 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,7 +30,6 @@
+ AC_PROG_INSTALL
+
+ m4_include([m4/slg_searchdirs.m4])
+-m4_include([m4/slg_gcc_all_warnings.m4])
+
+
+ # use C++11 mode if available; HAVE_CXX11 is defined in config.h if so. Don't
+@@ -402,7 +402,12 @@
+ AC_CHECK_HEADERS(cap-ng.h)
+ fi
+
+-
++################################################################
++# http-parser
++
++AC_CHECK_LIB(http_parser,http_parser_init,,
++ AC_MSG_ERROR([http-parser library not installed]))
++AC_CHECK_HEADERS(http_parser.h)
+
+ ################################################################
+ # Specify our other headers
+--- a/src/scan_http.cpp
++++ b/src/scan_http.cpp
+@@ -11,7 +11,11 @@
+ #include "tcpip.h"
+ #include "tcpdemux.h"
+
++#ifdef HAVE_HTTP_PARSER_H
++#include "http_parser.h"
++#else
+ #include "http-parser/http_parser.h"
++#endif
+
+ #include "mime_map.h"
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 793ec1a..ecac7a9 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -98,8 +98,6 @@ tcpflow_SOURCES = \
+ scan_netviz.cpp \
+ pcap_writer.h \
+ iptree.h \
+- http-parser/http_parser.c \
+- http-parser/http_parser.h \
+ mime_map.cpp \
+ mime_map.h
+
+@@ -110,12 +108,6 @@ tcpflow_SOURCES = \
+ EXTRA_DIST =\
+ inet_ntop.c \
+ inet_ntop.h \
+- http-parser/AUTHORS \
+- http-parser/CONTRIBUTIONS \
+- http-parser/LICENSE-MIT \
+- http-parser/Makefile \
+- http-parser/README.md \
+- http-parser/http_parser.gyp \
+ wifipcap/README.txt \
+ wifipcap/TimeVal.cpp \
+ wifipcap/TimeVal.h \