summaryrefslogtreecommitdiff
path: root/net-analyzer/tcping
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /net-analyzer/tcping
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'net-analyzer/tcping')
-rw-r--r--net-analyzer/tcping/Manifest2
-rw-r--r--net-analyzer/tcping/tcping-2.1.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/tcping/Manifest b/net-analyzer/tcping/Manifest
index e581fb37b656..dc861b1dd025 100644
--- a/net-analyzer/tcping/Manifest
+++ b/net-analyzer/tcping/Manifest
@@ -1,3 +1,5 @@
DIST tcping-1.3.6.tar.gz 3329 BLAKE2B cd69e259d930532810bf3b19d22db981d644051e472d6356e442df2074ebd6fe675b62540190f465127bdcd0c248f329b3e5c167a6c4408acfef029297b5e181 SHA512 74c65f292d6521dfbf8784ae9e1988a12ad224c81f6575ada1cae55b079cf9c13707be52cb9147abe02c8787ebbedb0d9fca1f2c27fb57c32eea5817c7042992
+DIST tcping-2.1.0.tar.gz 6532 BLAKE2B 8d154b36480180ae6fd2a644b98ee0ed569e1d7491a2fe5a5ced9a3ad2470d8a34cbbed499ba93661816075617cdb00f83c1469866f3bf63871fbbc6f67168ca SHA512 d39c30390a7ab7a345f3b8fc2731afa817b104460a65ad47f1e535d1a5242eed7eb5b8c416b898dd4eedc87cf16af7bbb0630c63731b12513fa4f95eb9dfaed0
EBUILD tcping-1.3.6.ebuild 607 BLAKE2B bcae82fc256d7613feb531bf7f4a97c43e5cedd104d0d50818d69cefd26b2d37d591e1f1054d282409d832c58f3a5e7af3fbf13221d575955971d8e244025967 SHA512 459e834f548c0d19a82ea64afc729615c5695c60857941625e8b79f63e442f20506e502477a42334454b1ecf4882a75d250eba0989d3f337f3bdb9c87f109dea
+EBUILD tcping-2.1.0.ebuild 608 BLAKE2B 72dd0c28f7c75da52ebe81f11498484346e7bb156f95594e0423464b07ef47587efce270c236efa0c674bda80046c117d6d2dba51938073bba48869eb4588ae2 SHA512 640aafeb3b1545d7fe9b89dbd2a70a25a088d41def4e1e389173261d1a46023b3f1f856ee55001c61323dd2f68dc6e5585a457c77cf7d7f18fa7f3d499a557fe
MISC metadata.xml 296 BLAKE2B c7a0a02851f1344fd5c9852074f94fb93f966f5f0a091f9c5c0cdfffa60e2b65b29b045fad75ac1658df51d497bbe3855bde55a386ddb828b51649f587176668 SHA512 133f5e79d1244d7ce871cabf1b4ce6bba3909506fe806a89ddec075815fed812978632745d764522f2ea2c538b4230583b4fa23c1e90554a54ef36a42f92c1a2
diff --git a/net-analyzer/tcping/tcping-2.1.0.ebuild b/net-analyzer/tcping/tcping-2.1.0.ebuild
new file mode 100644
index 000000000000..b7f426393c4b
--- /dev/null
+++ b/net-analyzer/tcping/tcping-2.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Check if a desired port is reachable via TCP"
+HOMEPAGE="https://github.com/mkirchner/tcping"
+SRC_URI="https://github.com/mkirchner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -e '/^CC=/s:=:?=:' \
+ -e '/^CCFLAGS/s:=:+=:' \
+ -e 's/$(CCFLAGS)/$(CCFLAGS) $(LDFLAGS)/' \
+ -i Makefile || die
+ tc-export CC
+ export CCFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin tcping
+ dodoc README
+}