summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpreplay/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
commita88eb1d9b7042912d196e255eeb20e0c77f6cf47 (patch)
tree291cc788e33b3de8bf1b5e3f1fdddf315f2f5ee7 /net-analyzer/tcpreplay/files
parentc3d14fe9accdf0b091e42f26a66ed7626ba8c24b (diff)
gentoo auto-resync : 01:05:2023 - 17:20:35
Diffstat (limited to 'net-analyzer/tcpreplay/files')
-rw-r--r--net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch b/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch
deleted file mode 100644
index 81a5a0086958..000000000000
--- a/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-https://github.com/appneta/tcpreplay/pull/757
-
-From 096197e584ebb7d646eef75e5a8654f7192a0af2 Mon Sep 17 00:00:00 2001
-From: Florian Weimer <fweimer@redhat.com>
-Date: Thu, 24 Nov 2022 07:30:28 +0100
-Subject: [PATCH] configure.ac: Avoid implicit int, implicit function
- declarations
-
-Do not call exit without declaring it. Add #include <unistd.h>
-for fork. Add missing int type to the definition of main.
-
-Implicit ints and implicit function declarations were removed from
-C in 1999 and will not be supported by future compilers.
---- a/configure.ac
-+++ b/configure.ac
-@@ -1681,8 +1681,8 @@ int
- main (int argc, char *argv[])
- {
- if (strncmp(PCAPNAV_VERSION, PCAPNAV_TEST, 3) >= 0)
-- exit(0);
-- exit(1);
-+ return 0;
-+ return 1;
- } ]])],[libpcapnav_ver=yes
- AC_MSG_RESULT(>= 0.4)],[libpcapnav_ver=no
- AC_MSG_RESULT(< 0.4)],[libpcapnav_ver=no
-@@ -1726,26 +1726,27 @@ case "$host_os" in
- #include <sys/types.h>
- #include <sys/wait.h>
- #include <stdio.h>
-+ #include <unistd.h>
- unsigned char a[[5]] = { 1, 2, 3, 4, 5 };
-- main() {
-+ int main() {
- unsigned int i;
- pid_t pid;
- int status;
- /* avoid "core dumped" message */
- pid = fork();
- if (pid < 0)
-- exit(2);
-+ return 2;
- if (pid > 0) {
- /* parent */
- pid = waitpid(pid, &status, 0);
- if (pid < 0)
-- exit(3);
-- exit(!WIFEXITED(status));
-+ return 3;
-+ return !WIFEXITED(status);
- }
- /* child */
- i = *(unsigned int *)&a[[1]];
- printf("%d\n", i);
-- exit(0);
-+ return 0;
- }
- EOF
- ${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS \
-