summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpreplay/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
commitc92d0cd2b34d17bce6d5bb4e3a4fc00af4193c99 (patch)
tree517559f918260cf91e7bdd4e484aa6fe9085cb9f /net-analyzer/tcpreplay/files
parenta59ffccce3bf214fae9932cc42400eeeaec25c6c (diff)
gentoo auto-resync : 24:11:2022 - 13:10:39
Diffstat (limited to 'net-analyzer/tcpreplay/files')
-rw-r--r--net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch b/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch
new file mode 100644
index 000000000000..81a5a0086958
--- /dev/null
+++ b/net-analyzer/tcpreplay/files/tcpreplay-4.4.2-configure-clang16.patch
@@ -0,0 +1,60 @@
+https://github.com/appneta/tcpreplay/pull/757
+
+From 096197e584ebb7d646eef75e5a8654f7192a0af2 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 24 Nov 2022 07:30:28 +0100
+Subject: [PATCH] configure.ac: Avoid implicit int, implicit function
+ declarations
+
+Do not call exit without declaring it. Add #include <unistd.h>
+for fork. Add missing int type to the definition of main.
+
+Implicit ints and implicit function declarations were removed from
+C in 1999 and will not be supported by future compilers.
+--- a/configure.ac
++++ b/configure.ac
+@@ -1681,8 +1681,8 @@ int
+ main (int argc, char *argv[])
+ {
+ if (strncmp(PCAPNAV_VERSION, PCAPNAV_TEST, 3) >= 0)
+- exit(0);
+- exit(1);
++ return 0;
++ return 1;
+ } ]])],[libpcapnav_ver=yes
+ AC_MSG_RESULT(>= 0.4)],[libpcapnav_ver=no
+ AC_MSG_RESULT(< 0.4)],[libpcapnav_ver=no
+@@ -1726,26 +1726,27 @@ case "$host_os" in
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <stdio.h>
++ #include <unistd.h>
+ unsigned char a[[5]] = { 1, 2, 3, 4, 5 };
+- main() {
++ int main() {
+ unsigned int i;
+ pid_t pid;
+ int status;
+ /* avoid "core dumped" message */
+ pid = fork();
+ if (pid < 0)
+- exit(2);
++ return 2;
+ if (pid > 0) {
+ /* parent */
+ pid = waitpid(pid, &status, 0);
+ if (pid < 0)
+- exit(3);
+- exit(!WIFEXITED(status));
++ return 3;
++ return !WIFEXITED(status);
+ }
+ /* child */
+ i = *(unsigned int *)&a[[1]];
+ printf("%d\n", i);
+- exit(0);
++ return 0;
+ }
+ EOF
+ ${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS \
+