summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpreplay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /net-analyzer/tcpreplay
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/Manifest2
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.3.4.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index fefde39b6731..948de5aa26fe 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,5 +1,7 @@
AUX tcpreplay-4.3.0-enable-pcap_findalldevs.patch 333 BLAKE2B 1beb39a7263bf8491998760e4a62ac8908300e28c43500812d37d2512f9d63fcd175b93c1b384e03e9570e741dd95dea09ead017a014a4b62b3449833fe9b248 SHA512 3d035736c0656f6ace85b45af595866e06c8464641023e9d1606c288e598cde18eb96b1be8300514f6f31bc83756ae76b436402666036456571201ca38fe5026
DIST tcpreplay-4.3.3.tar.xz 748220 BLAKE2B 2de09f75e6bb6035fc25f34f41d9ce2ccbb961d7464a9a6dae16ec417d629e4819593fd781d95075293ffa3a3db7c4a50ae8667c4e7d07c0b425361027c8df06 SHA512 110d7768a176d2126766829466a209cdd983afcf0c988f7e128baa5057b3ac1dc918fcaeb168a2e6654429100a146afcbdafcda8c3d67adf6b17892a48689a02
+DIST tcpreplay-4.3.4.tar.xz 739280 BLAKE2B 8b680363ee182fc7581f99cc4587d50e36285446d07a5be370e2439b31582ad88c786c11d662e28dadc5b69aee376889b1c0f6a86d61c106426ab6ab2c085012 SHA512 6d19cf492114c68a9fafcf7790c08f31607d2c0112e02fa41eed8747255bbbef85f281f74348e1d51f1d476b88f07d64715224618ec15268688baefaf7cc7124
EBUILD tcpreplay-4.3.3.ebuild 1924 BLAKE2B 0eec7595c24499e9d2dd603d097613f3b1ca59a28c096d7ec8a9231be16ddd1e5d2ce8a56cb41086c6baf3fb08ff56d890b8aec553082e0c7272b49f8dd32285 SHA512 521491bb8e182f93ffa83bc50448e45f178881889af50371f6a770a9815b572d48721ba6b480c64d81fad2f8d2f90e772ea055adc990b98fbd99cc681e86afd9
+EBUILD tcpreplay-4.3.4.ebuild 1927 BLAKE2B 4839c1ba1f6aef0b4f276682b1bcd2d06cb8e95ace072444bfdb4d9943bcc8f59ab7ffb823e99bf535a254f40cb6d0f7a48174c6c0a221840085e1bd5a0a68b6 SHA512 a7c791e86b9fe9a98b8c4496ed48b245a136faaaa2ce60441fae141dac3a5e5363111111c1acb237bebfc3f478cb066fcf22957d090dde9476032fac186978a8
EBUILD tcpreplay-999999.ebuild 1875 BLAKE2B acf0bc3fb3e2d84f598d8ed6e13c42bfc642da1aedf8036362e52ab0bc7709beb81d9e57517d26b2b9507ec1cf89c577b0c40993f8faa63babcfaa2d11dbdc6e SHA512 be4c895b20ee5898dc182fdf8f45de64bb9c28fb4b581c07ad29a1f03d3ed953f6bc2e6b596fac66a6290a83dcdfdab17fb01de0042b82cdae86deefcf6be062
MISC metadata.xml 1116 BLAKE2B 23c8b7009a77b68831affc57432a87a31fde213d7e7ee88f68ced4a4e21a56c55f97497e610fc486a42c699759ef1edf1904fa9b0fe976df4fc9930535f97037 SHA512 58cb13a648ba7b9f9fd8c7a7cdfd37d56f0d7b957824a55d63001a8708f93d529b29e52df051bdce0c87eb672d24c7b2c35ee8a1e94ba062e2a1e12dd0d0ee1b
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.3.4.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.3.4.ebuild
new file mode 100644
index 000000000000..d15c8f13c99e
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-4.3.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Utilities for editing and replaying previously captured network traffic"
+HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
+SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV}/${P}.tar.xz"
+S="${WORKDIR}"/${P/_/-}
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE="debug pcapnav +tcpdump"
+
+# libpcapnav for pcapnav-config
+BDEPEND="
+ net-libs/libpcapnav
+ >=sys-devel/autogen-5.18.4[libopts]
+"
+DEPEND="
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ pcapnav? ( net-libs/libpcapnav )
+ tcpdump? ( net-analyzer/tcpdump )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
+ src/common/sendpacket.c || die
+ sed -i \
+ -e 's|@\([A-Z_]*\)@|$(\1)|g' \
+ -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
+ -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # By default it uses static linking. Avoid that, bug #252940
+ econf \
+ $(use_enable debug) \
+ $(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump) \
+ --enable-dynamic-link \
+ --enable-local-libopts \
+ --enable-shared \
+ --with-libdnet \
+ --with-testnic2=lo \
+ --with-testnic=lo
+}
+
+src_test() {
+ if [[ ! ${EUID} -eq 0 ]]; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ emake -j1 -C test tcpprep
+ else
+ emake -j1 test || {
+ ewarn "Note that some tests require eth0 iface to be up." ;
+ die "self test failed - see ${S}/test/test.log" ; }
+ fi
+}