summaryrefslogtreecommitdiff
path: root/net-analyzer/thc-ipv6/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-18 15:11:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-18 15:11:02 +0000
commit0fb71e0215ed52863e462cccef73c01aff44d43d (patch)
tree428fc3fa92f9c69ed02878e9b6151a9fb810e651 /net-analyzer/thc-ipv6/files
parent9bd54251864651f49e673a08aec9ef79cfe08f04 (diff)
gentoo resync : 18.12.2017
Diffstat (limited to 'net-analyzer/thc-ipv6/files')
-rw-r--r--net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch24
-rw-r--r--net-analyzer/thc-ipv6/files/thc-ipv6-3.2-stdint.patch10
2 files changed, 10 insertions, 24 deletions
diff --git a/net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch b/net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch
deleted file mode 100644
index d7b42147ae1e..000000000000
--- a/net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- thc-ipv6-2.1/Makefile
-+++ thc-ipv6-2.1/Makefile
-@@ -4,7 +4,7 @@
-
- CC=gcc
- #CFLAGS=-g
--CFLAGS=-O2
-+CFLAGS?=-O2
- CFLAGS+=$(if $(HAVE_SSL),-D_HAVE_SSL,)
- LDFLAGS+=-lpcap $(if $(HAVE_SSL),-lssl -lcrypto,)
- PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 flood_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 covert_send6 covert_send6d inject_alive6 firewall6 ndpexhaust26 fake_pim6
-@@ -17,10 +17,10 @@
- all: $(LIBS) $(PROGRAMS) dnssecwalk dnsdict6 thcping6
-
- dnssecwalk: dnssecwalk.c
-- $(CC) $(CFLAGS) -o $@ $^
-+ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
-
- dnsdict6: dnsdict6.c
-- $(CC) $(CFLAGS) -o $@ $^ -lpthread -lresolv
-+ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) -lpthread -lresolv
-
- thcping6: thcping6.c $(LIBS)
- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) -lrt
diff --git a/net-analyzer/thc-ipv6/files/thc-ipv6-3.2-stdint.patch b/net-analyzer/thc-ipv6/files/thc-ipv6-3.2-stdint.patch
new file mode 100644
index 000000000000..7873563b2377
--- /dev/null
+++ b/net-analyzer/thc-ipv6/files/thc-ipv6-3.2-stdint.patch
@@ -0,0 +1,10 @@
+--- thc-ipv6-3.2/dnsrevenum6.c
++++ thc-ipv6-3.2/dnsrevenum6.c
+@@ -17,6 +17,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <stdint.h>
+ #include <string.h>
+ #include <strings.h>
+ #include <string.h>