summaryrefslogtreecommitdiff
path: root/net-analyzer/zmap/zmap-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/zmap/zmap-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/zmap/zmap-9999.ebuild')
-rw-r--r--net-analyzer/zmap/zmap-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/zmap/zmap-9999.ebuild b/net-analyzer/zmap/zmap-9999.ebuild
new file mode 100644
index 000000000000..a229c0000778
--- /dev/null
+++ b/net-analyzer/zmap/zmap-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils fcaps git-r3
+
+DESCRIPTION="Fast network scanner designed for Internet-wide network surveys"
+HOMEPAGE="https://zmap.io/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS=""
+IUSE="mongo redis"
+
+RDEPEND="
+ dev-libs/gmp:0
+ net-libs/libpcap
+ dev-libs/json-c
+ mongo? ( dev-db/mongo )
+ redis? ( dev-libs/hiredis )"
+DEPEND="${RDEPEND}
+ dev-util/gengetopt
+ sys-devel/flex
+ dev-util/byacc
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEVELOPMENT=OFF
+ -DENABLE_HARDENING=OFF
+ -DWITH_WERROR=OFF
+ -DWITH_mongo="$(usex mongo)"
+ -DWITH_redis="$(usex redis)"
+ )
+ cmake-utils_src_configure
+}
+
+FILECAPS=( cap_net_raw=ep usr/sbin/zmap )