summaryrefslogtreecommitdiff
path: root/net-analyzer/zniper/zniper-1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/zniper/zniper-1.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/zniper/zniper-1.0-r1.ebuild')
-rw-r--r--net-analyzer/zniper/zniper-1.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/zniper/zniper-1.0-r1.ebuild b/net-analyzer/zniper/zniper-1.0-r1.ebuild
new file mode 100644
index 000000000000..dae03274def1
--- /dev/null
+++ b/net-analyzer/zniper/zniper-1.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Displays and kill active TCP connections seen by the selected interface"
+HOMEPAGE="http://www.signedness.org/tools/"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/"zniper"
+
+src_prepare() {
+ sed -i \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ -e 's|@make|@$(MAKE)|g' \
+ -e 's|-lncurses|$(shell $(PKG_CONFIG) --libs ncurses)|g' \
+ Makefile || die
+ tc-export PKG_CONFIG
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ linux_x86
+}
+
+src_install() {
+ dobin zniper
+ doman zniper.1
+}