summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-29 01:25:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-29 01:25:46 +0100
commit04ac238703da84168e02b06fb131d1d17d85be23 (patch)
treef32aa3a6b6a6c879a798006535ad544bf888df73 /net-analyzer
parent6405cba4bf18141460bc9fcb8f5580532d4b46f8 (diff)
gentoo auto-resync : 29:09:2024 - 01:25:46
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/Manifest.gzbin43273 -> 43274 bytes
-rw-r--r--net-analyzer/monitoring-plugins/Manifest2
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.4.0.ebuild115
3 files changed, 117 insertions, 0 deletions
diff --git a/net-analyzer/Manifest.gz b/net-analyzer/Manifest.gz
index 3db4316aa738..d2ccd542b547 100644
--- a/net-analyzer/Manifest.gz
+++ b/net-analyzer/Manifest.gz
Binary files differ
diff --git a/net-analyzer/monitoring-plugins/Manifest b/net-analyzer/monitoring-plugins/Manifest
index 7b068c6fc60c..cbf35c84bc6b 100644
--- a/net-analyzer/monitoring-plugins/Manifest
+++ b/net-analyzer/monitoring-plugins/Manifest
@@ -1,3 +1,5 @@
DIST monitoring-plugins-2.3.5.tar.gz 2876130 BLAKE2B 7029f6485ef73d29329bcb36e16cbbaa99c57ae20505f554af154b45cc1af6f623dabb35ee5b7f777d728bcae8eafd795f12aabc199cf1f45c9f2335f74b6d41 SHA512 bb04d547584a4aed82bfd605d129b652b45c7356c0610fb1da53a57b2ab889b67afccdd53998e2612ec06571bdc5fc238ef0d378b96e29ec072f657e74eabd55
+DIST monitoring-plugins-2.4.0.tar.gz 2746382 BLAKE2B 3e062b9392b4e5885a549ca619eee25f29517e83682e0eb76c8780235b48ab26d79994827c1167e981a993ece3f3f339de61874c912e6fcb17b4cb1af22e97d9 SHA512 7e9aae7768ed9fccbaf377fc54a70374f6a41e8e8ef95cf7440e44fca1080eb23e6b3d737214c96d772eb9a32cdfdbf1b88e0eb35eda0690047d5fe1b485a6b2
EBUILD monitoring-plugins-2.3.5.ebuild 3272 BLAKE2B c6d3c789dc96d478d044419f121bcac9dd09f0d697858509f3a2458d74f350be1567a6e118756bc590e9b77adf8dccb69df1daecc3e30233c627674278ddd922 SHA512 49073b7023da748a183a9cb3bad45f84c0840e361595619d8fd8517092478336446725d20756a604f9103f77f67808c1b7e99da5be2b65772d833f2ce299d4e8
+EBUILD monitoring-plugins-2.4.0.ebuild 3275 BLAKE2B bdc3d36692727e58cb6c600c0ac57f8553423812ede2bb6e322f022795f48c90464015d2a46dfeadfd51d5a619470d7e313a9f6be107a735e8a977f5f4cf90a5 SHA512 ba192af72c55ef9a5168e712387cc6ea80b825ea6ee4c7d2407a3ebb7e964b6ba23b977e4cd70c401278ad317e033bde828bd1e4d517a0dee4ae90601df88dd6
MISC metadata.xml 1679 BLAKE2B e99ba6614df951268458260a1b8f02f40408dd2e41b65e77555fe1d1698bf4d5fbb8a35b5d640198c1feb74bdeb78c3efb9c2670c3d87bbadef16be66602d172 SHA512 1b24d36802f5efa30d4c289bbc231761d9a3a1149831ae913eea998d49782c9424e37d270ff2853a91a9d75d65e2991910aab986f7dc78e3a8132ca17be56d8a
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.4.0.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.4.0.ebuild
new file mode 100644
index 000000000000..254d7d52757a
--- /dev/null
+++ b/net-analyzer/monitoring-plugins/monitoring-plugins-2.4.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
+HOMEPAGE="https://www.monitoring-plugins.org/"
+SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
+IUSE="curl gnutls ipv6 ldap mysql dns fping game postgres radius samba snmp ssh +ssl"
+
+# Most of the plugins use automagic dependencies, i.e. the plugin will
+# get built if the binary it uses is installed. For example, check_snmp
+# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
+# installed. End result: most of our runtime dependencies are required
+# at build time as well.
+#
+# REAL_DEPEND contains the dependencies that are actually needed to
+# build. DEPEND contains those plus the automagic dependencies.
+#
+REAL_DEPEND="dev-lang/perl
+ curl? (
+ dev-libs/uriparser
+ net-misc/curl
+ )
+ ldap? ( net-nds/openldap:= )
+ mysql? ( || ( dev-db/mysql-connector-c dev-db/mariadb-connector-c ) )
+ postgres? ( dev-db/postgresql:= )
+ ssl? (
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ gnutls? ( net-libs/gnutls )
+ )
+ radius? ( net-dialup/freeradius-client )"
+
+DEPEND="${REAL_DEPEND}
+ dns? ( net-dns/bind-tools )
+ game? ( games-util/qstat )
+ fping? ( net-analyzer/fping )
+ samba? ( net-fs/samba )
+ ssh? ( virtual/openssh )
+ snmp? ( dev-perl/Net-SNMP
+ net-analyzer/net-snmp[-minimal] )"
+
+# Basically everything collides with nagios-plugins.
+RDEPEND="${DEPEND}
+ acct-group/nagios
+ acct-user/nagios
+ !net-analyzer/nagios-plugins"
+
+# At least one test is interactive.
+RESTRICT="test"
+
+# These all come from gnulib and the ./configure checks are working as
+# intended when the functions aren't present. Bugs 921190 and 936891.
+QA_CONFIG_IMPL_DECL_SKIP=(
+ MIN
+ fpurge
+ static_assert
+ statvfs64
+ alignof
+)
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # Use an array to prevent econf from mangling the ping args.
+ local myconf=()
+
+ if use ssl; then
+ myconf+=( $(use_with !gnutls openssl /usr)
+ $(use_with gnutls gnutls /usr) )
+ else
+ myconf+=( --without-openssl )
+ myconf+=( --without-gnutls )
+ fi
+
+ # The autodetection for these two commands can hang if localhost is
+ # down or ICMP traffic is filtered (bug #468296). But also the path
+ # likes to move around on us (bug #883729).
+ myconf+=( --with-ping-command="$(command -v ping) -4 -n -U -w %d -c %d %s" )
+
+ if use ipv6; then
+ myconf+=( --with-ping6-command="$(command -v ping) -6 -n -U -w %d -c %d %s" )
+ fi
+
+ econf \
+ $(use_with curl libcurl) \
+ $(use_with curl uriparser) \
+ $(use_with mysql) \
+ $(use_with ipv6) \
+ $(use_with ldap) \
+ $(use_with postgres pgsql /usr) \
+ $(use_with radius) \
+ "${myconf[@]}" \
+ --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
+ --sysconfdir="/etc/nagios"
+}
+
+DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
+ NEWS README REQUIREMENTS SUPPORT THANKS )
+
+pkg_postinst() {
+ elog "This ebuild has a number of USE flags that determine what you"
+ elog "are able to monitor. Depending on what you want to monitor, some"
+ elog "or all of these USE flags need to be set."
+ elog
+ elog "The plugins are installed in ${EROOT}/usr/$(get_libdir)/nagios/plugins"
+}