summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-23 21:45:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-23 21:45:48 +0000
commit0530006d7f63d6c158b4ff5ea0c3f7ef3bae9cc4 (patch)
treeb3f2e1932614978a64f3fff0cf39d188bcb8a4d3 /net-analyzer
parent9217a0cce81e89f5648599fcda4e549903c7b9bd (diff)
gentoo auto-resync : 23:02:2023 - 21:45:48
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/Manifest.gzbin43402 -> 43402 bytes
-rw-r--r--net-analyzer/arping/Manifest1
-rw-r--r--net-analyzer/arping/files/arping-tests.patch190
3 files changed, 0 insertions, 191 deletions
diff --git a/net-analyzer/Manifest.gz b/net-analyzer/Manifest.gz
index 573f7f26e71b..3c7b00f939e5 100644
--- a/net-analyzer/Manifest.gz
+++ b/net-analyzer/Manifest.gz
Binary files differ
diff --git a/net-analyzer/arping/Manifest b/net-analyzer/arping/Manifest
index 4bf3e36fc58e..12a1c79bd4ce 100644
--- a/net-analyzer/arping/Manifest
+++ b/net-analyzer/arping/Manifest
@@ -1,5 +1,4 @@
AUX arping-2.23-configure.ac-seccomp-disable.patch 1282 BLAKE2B 8a5a4d2b98ee89c667a33349f327fdd65dfc97aa476376e4a2fa9a92d117dd28d9a4e9a70e8f1b1a5277e6addac3e9fc197edccbc4effe826bef54746b8b5256 SHA512 9bce555c0390bbea73096a0b00fd3eabfb5a9aa78cd3daef63c3c03118a9c7b9295f8c06b33c2a4f86c28b572f1c1422c60c7fb6e4e958271cce9eb4e11bc903
-AUX arping-tests.patch 5643 BLAKE2B 154071667f814ec720a6fce36612d251ab891eb3972bd62e13fbfa233b56cff604a19feb80decaf448c1cd7b73c3c830c2529111372cbb6a81503e1b3a282273 SHA512 9b863431db1ca61ad69827dcf9427ab51bc2072251e358cbc90577e55907dcdb913e8bdef640bf3d77f46e7d6d44c8f69d5eab68d3e8c07af8fbc67df8e15e09
DIST arping-2.22.tar.gz 50152 BLAKE2B 2215773b922219537339550e8034bb6eca82974469ebd0e399c73bd259ef4ff7a4510d9a5ff108cef3dac492477c54fc2517c2dfd4035158d0269f03c0e2a0b5 SHA512 0b36fff2c14c1ff89453ba63eea04de3343fcb19da7dbc1c8749bc926e441c54915cd628d54171d449e66e92663e31f12e057c30a80cd49c4412650e2cd00ef3
DIST arping-2.23.tar.gz 51911 BLAKE2B 8b0d34522957a83d0a66b47576fa0ecbd1e4fc86537df6d2737510bdb1a4ea3d30feb664077790a8f70be9cf2cdcdc30a648261e9a6a30401ce85274c45ccf12 SHA512 45295fd68717379d18fcff4270c70e0d9df3cae175f0c2a9f1e8e88e3046f5109e7a95bb717be329af8d6002c9a2338efd39831a652c0b425b75058287fa35df
EBUILD arping-2.22.ebuild 777 BLAKE2B d928cc259d9f477426d6a0c7dac42d47989437f9956b047f719cbf4a18f24a4556e2c572b14fcfe3bfa156768994c2c58442a9ba0378f1b7b4e6c82aca5a3914 SHA512 461aad71da33b5f278a9c893dccd69b0bafa3998c369f33aac9e8b7e8fd03a489c5c16053fb24f1135a5e6563ed784a7de6f0f3fd334375f4258b2882bc3a90d
diff --git a/net-analyzer/arping/files/arping-tests.patch b/net-analyzer/arping/files/arping-tests.patch
deleted file mode 100644
index fb8592df372f..000000000000
--- a/net-analyzer/arping/files/arping-tests.patch
+++ /dev/null
@@ -1,190 +0,0 @@
-diff --git a/src/arping_test.c b/src/arping_test.c
-index 438670b..0133fe7 100644
---- a/src/arping_test.c
-+++ b/src/arping_test.c
-@@ -40,35 +40,10 @@ extern libnet_t* libnet;
- extern int mock_libnet_lo_ok;
- extern int mock_libnet_null_ok;
-
--struct registered_test {
-- void* fn;
-- const char* name;
--};
--
--static int numtests = 0;
--static struct registered_test test_registry[1024];
--
--static int num_exit_tests = 0;
--static struct registered_test test_exit_registry[1024];
--
- int get_mac_addr(const char *in, char *out);
- void strip_newline(char* s);
-
-
--#define MYTEST(a) static void a(int);__attribute__((constructor)) \
--static void cons_##a() { \
-- test_registry[numtests].fn = a; \
-- test_registry[numtests].name = #a; \
-- numtests++; \
--} START_TEST(a)
--
--#define MY_EXIT_TEST(a) static void a(int);__attribute__((constructor)) \
--static void cons_##a() { \
-- test_exit_registry[num_exit_tests].fn = a; \
-- test_exit_registry[num_exit_tests].name = #a; \
-- num_exit_tests++; \
--} START_TEST(a)
--
- /**
- *
- */
-@@ -236,7 +211,7 @@ dump_packet(uint8_t* packet, int len)
- fprintf(stderr, "\n");
- }
-
--MYTEST(test_mkpacket)
-+START_TEST(test_mkpacket)
- {
- uint8_t correct_packet[] = {
- 0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88, 0x99, 0xaa,
-@@ -261,7 +236,7 @@ MYTEST(test_mkpacket)
-
-
- // Received uninteresting packet, should not record anything.
--MYTEST(pingip_uninteresting_packet)
-+START_TEST(pingip_uninteresting_packet)
- {
- struct pcap_pkthdr pkthdr;
- uint8_t* packet;
-@@ -389,7 +364,7 @@ MYTEST(pingip_uninteresting_packet)
- } END_TEST
-
- // Received reply that actually matches. Things should happen.
--MYTEST(pingip_interesting_packet)
-+START_TEST(pingip_interesting_packet)
- {
- struct pcap_pkthdr pkthdr;
- extern uint8_t srcmac[ETH_ALEN];
-@@ -449,7 +424,7 @@ MYTEST(pingip_interesting_packet)
- "numrecvd not incremented second time");
- } END_TEST
-
--MYTEST(strip_newline_test)
-+START_TEST(strip_newline_test)
- {
- const char *tests[][2] = {
- {"", ""},
-@@ -469,7 +444,7 @@ MYTEST(strip_newline_test)
- }
- } END_TEST
-
--MYTEST(get_mac_addr_success)
-+START_TEST(get_mac_addr_success)
- {
- const char *tests[][2] = {
- // Null.
-@@ -501,7 +476,7 @@ MYTEST(get_mac_addr_success)
- }
- } END_TEST
-
--MYTEST(get_mac_addr_fail)
-+START_TEST(get_mac_addr_fail)
- {
- const char *tests[] = {
- "",
-@@ -517,7 +492,7 @@ MYTEST(get_mac_addr_fail)
- }
- } END_TEST
-
--MY_EXIT_TEST(libnet_init_bad_nolo)
-+START_TEST(libnet_init_bad_nolo)
- {
- // It'll only try lo if named interface fails.
- // So by accepting lo, we make sure it doesn't try lo.
-@@ -525,27 +500,28 @@ MY_EXIT_TEST(libnet_init_bad_nolo)
- do_libnet_init("bad", 0);
- } END_TEST
-
--MY_EXIT_TEST(libnet_init_null_nolo_nonull)
-+START_TEST(libnet_init_null_nolo_nonull)
- {
- mock_libnet_lo_ok = 0;
- mock_libnet_null_ok = 0;
- do_libnet_init(NULL, 0);
- } END_TEST
-
--MYTEST(libnet_init_good)
-+START_TEST(libnet_init_good)
- {
- mock_libnet_lo_ok = 0; // Don't even try falling back to lo.
- do_libnet_init("good", 0);
- fail_if(libnet == NULL);
- } END_TEST
-
--MYTEST(libnet_init_null_nolo)
-+START_TEST(libnet_init_null_nolo)
- {
- mock_libnet_lo_ok = 0;
- mock_libnet_null_ok = 1;
- do_libnet_init(NULL, 0);
- fail_if(libnet == NULL);
--} END_TEST
-+}
-+END_TEST
-
- static Suite*
- arping_suite(void)
-@@ -553,17 +529,34 @@ arping_suite(void)
- int c;
- Suite* s = suite_create("Arping");
-
-- //tcase_add_checked_fixture (tc_core, setup, teardown);
-- for (c = 0; c < numtests; c++) {
-- TCase *tc_core = tcase_create(test_registry[c].name);
-- tcase_add_test(tc_core, test_registry[c].fn);
-- suite_add_tcase(s, tc_core);
-- }
-- for (c = 0; c < num_exit_tests; c++) {
-- TCase *tc_core = tcase_create(test_exit_registry[c].name);
-- tcase_add_exit_test(tc_core, test_exit_registry[c].fn, 1);
-- suite_add_tcase(s, tc_core);
-- }
-+
-+ TCase *tc_core;
-+
-+ // libcheck broke test registries, so have to resort to code duplication. :-(
-+ // https://github.com/libcheck/check/pull/158/files
-+#define SIGH_LIBCHECK(tn) \
-+ tc_core = tcase_create(#tn); \
-+ tcase_add_test(tc_core, tn); \
-+ suite_add_tcase(s, tc_core);
-+
-+ SIGH_LIBCHECK(libnet_init_null_nolo);
-+ SIGH_LIBCHECK(test_mkpacket);
-+ SIGH_LIBCHECK(pingip_uninteresting_packet);
-+ SIGH_LIBCHECK(pingip_interesting_packet);
-+ SIGH_LIBCHECK(strip_newline_test);
-+ SIGH_LIBCHECK(get_mac_addr_success);
-+ SIGH_LIBCHECK(get_mac_addr_fail);
-+ SIGH_LIBCHECK(libnet_init_good);
-+
-+
-+#define SIGH_LIBCHECK_EXIT(tn) \
-+ tc_core = tcase_create(#tn); \
-+ tcase_add_exit_test(tc_core, tn, 1); \
-+ suite_add_tcase(s, tc_core);
-+
-+ SIGH_LIBCHECK_EXIT(libnet_init_bad_nolo);
-+ SIGH_LIBCHECK_EXIT(libnet_init_null_nolo_nonull);
-+
- return s;
- }
-
-@@ -577,6 +570,7 @@ main()
- number_failed = srunner_ntests_failed (sr);
- srunner_free (sr);
- return (number_failed == 0) ? EXIT_SUCCESS : EXIT_FAILURE;
-+ return 0;
- }
- /* ---- Emacs Variables ----
- * Local Variables: