summaryrefslogtreecommitdiff
path: root/net-dns/dnsviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-20 19:17:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-20 19:17:08 +0100
commit1941d371dc945a34f7070c341af1392edb5ca3a9 (patch)
treee827c75ecfe184ed595a64cc562c654341edf373 /net-dns/dnsviz
parent332b9eb4903f99b0e65722058ce481fdc21b93d3 (diff)
gentoo auto-resync : 20:06:2023 - 19:17:08
Diffstat (limited to 'net-dns/dnsviz')
-rw-r--r--net-dns/dnsviz/Manifest2
-rw-r--r--net-dns/dnsviz/dnsviz-0.10.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/net-dns/dnsviz/Manifest b/net-dns/dnsviz/Manifest
index 80fd164c2049..524a89523322 100644
--- a/net-dns/dnsviz/Manifest
+++ b/net-dns/dnsviz/Manifest
@@ -1,3 +1,5 @@
+DIST dnsviz-0.10.0.gh.tar.gz 480916 BLAKE2B 51cdf40d91429447b01470f9356140ed53b488c6831bd06a8352493c0938d995c625024c2a976c2d7408a56085d15dcdbfe70486304a7d0c2168d93033939659 SHA512 0bc07ad6edc25986ca17d5e02bee6e120c2e3f01d3ee015a8ed8d8a6471f3e1b3176bc3194a0b9172cf789bac42548fb64f095fc94264bd8ea97a9b1ed484114
DIST dnsviz-0.9.4.gh.tar.gz 477971 BLAKE2B 3c8bebcea89bc6e78247c45c4266f73be4f9f618bfaa48a47460a43deb4789fe71eaa77eb4ff59c2d8e863cdfdddaf5908279aad93ffd63fdbe16d0966aa943b SHA512 b88d0ddff6279078a5222b4250a404c39db6d896d57bba51c878c8b8d01582deda2fe67b5f6370d7a98389e09ad46bdf3903d77fee91c0291b14a9109f1739e3
+EBUILD dnsviz-0.10.0.ebuild 1489 BLAKE2B 794108a1bf826a2ec25715e09640b00e839e412fe300b75249458e441e7aede42c00aedbfe2cb30763831cbfda0a7eb1012d8cb1ad67d4fb3761c67f317586d4 SHA512 44313b7fb2a146d62be5cfe9f02621c7a61e155bb2eba984c368fa9d3d4ffd6319324bc0b89a6c14052e5e87081bb40650f6654ff140d34c4d6cbdda760e79a8
EBUILD dnsviz-0.9.4-r1.ebuild 1315 BLAKE2B 7ea8e379b0308b0bc69ac9a0e4ddf6c7c9183e9500dac00297d987fc8776a93230ab3d1391cc84300b064e7e58d31aaa8517df91ff38bcb87949b47fc91aef70 SHA512 c9b7df3a15fda9f24d73dcda7d85bfb55047ef24efb3d9a74f21c3ddbf2843e1718a7fc9bf507b3cb59113f2e08dc7aa37dd9f87b12549cf2af6de00ec412c19
MISC metadata.xml 526 BLAKE2B 92a80291c1decfcbca0f153f2512013e9356476115d2b768df4c322179237d210dcf1a1c32e7b2664157788c9e0f3a69ddf45ca7cb7d4ec865168054d6bd1ed2 SHA512 ea5853c78aa415926d72f665fcf408de1185dc0b5ee7b8e1c584b9e325aad5a9df10fb6269866501bc2ac54ed8520ae6ec7a0ff928d56a7f156ec5a6398ff1d8
diff --git a/net-dns/dnsviz/dnsviz-0.10.0.ebuild b/net-dns/dnsviz/dnsviz-0.10.0.ebuild
new file mode 100644
index 000000000000..2638e94461f9
--- /dev/null
+++ b/net-dns/dnsviz/dnsviz-0.10.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Tool suite for analysis and visualization of DNS and DNSSEC"
+HOMEPAGE="
+ https://dnsviz.net/
+ https://github.com/dnsviz/dnsviz/
+ https://pypi.org/project/dnsviz/
+"
+
+# 0.10.0 is untagged, see https://github.com/dnsviz/dnsviz/issues/122
+SRC_URI="
+ https://github.com/dnsviz/dnsviz/archive/86ceba56e8ed23df0ec091b8750025ac374f3916.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+
+S="${WORKDIR}/${PN}-86ceba56e8ed23df0ec091b8750025ac374f3916"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/dnspython-1.13[${PYTHON_USEDEP}]
+ >=dev-python/m2crypto-0.37.0[${PYTHON_USEDEP}]
+ >=dev-python/pygraphviz-1.3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ media-gfx/graphviz
+ test? (
+ ${RDEPEND}
+ net-dns/bind
+ )
+"
+
+python_prepare_all() {
+ # Fix the ebuild to use correct FHS/Gentoo policy paths
+ sed -i \
+ -e "s|share/doc/dnsviz|share/doc/${PF}|g" \
+ "${S}"/setup.py \
+ || die
+
+ # skip online tests
+ rm tests/*_online.py tests/test_dnsviz_probe_options.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ eunittest -s tests -p "*.py" || die
+}
+
+pkg_postinst() {
+ optfeature "Support for pre-deployment testing" net-dns/bind
+ optfeature "Support for DNSSEC signatures using GOST algorithm or digest" dev-libs/ghost-engine
+}