summaryrefslogtreecommitdiff
path: root/net-dns/libidn2/libidn2-2.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 14:48:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 14:48:06 +0100
commit3529f1bf2739399905cd55b27c7609459bfc069f (patch)
tree030ac4ab6cc001de1876af06bc97f8d480c911f1 /net-dns/libidn2/libidn2-2.3.4.ebuild
parent0fcaac21e786bd7911b1e8f436cd885c5e2f6437 (diff)
gentoo auto-resync : 27:10:2023 - 14:48:06
Diffstat (limited to 'net-dns/libidn2/libidn2-2.3.4.ebuild')
-rw-r--r--net-dns/libidn2/libidn2-2.3.4.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/net-dns/libidn2/libidn2-2.3.4.ebuild b/net-dns/libidn2/libidn2-2.3.4.ebuild
deleted file mode 100644
index c4635da58f1d..000000000000
--- a/net-dns/libidn2/libidn2-2.3.4.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic multilib-minimal toolchain-funcs verify-sig
-
-DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
-HOMEPAGE="
- https://www.gnu.org/software/libidn/#libidn2
- https://gitlab.com/libidn/libidn2/
-"
-SRC_URI="
- mirror://gnu/libidn/${P}.tar.gz
- verify-sig? ( mirror://gnu/libidn/${P}.tar.gz.sig )
-"
-S="${WORKDIR}"/${P/a/}
-
-LICENSE="|| ( GPL-2+ LGPL-3+ ) GPL-3+ unicode"
-SLOT="0/2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="nls static-libs"
-
-RDEPEND="
- dev-libs/libunistring:=[${MULTILIB_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-lang/perl
- sys-apps/help2man
- nls? ( sys-devel/gettext )
- verify-sig? ( sec-keys/openpgp-keys-libidn )
-"
-
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libidn.asc
-
-multilib_src_configure() {
- # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
- # https://github.com/gentoo/gentoo/pull/28355
- # mold needs this too but right now tc-ld-is-mold is also not available
- if tc-ld-is-lld; then
- append-ldflags -Wl,--undefined-version
- fi
-
- local myconf=(
- CC_FOR_BUILD="$(tc-getBUILD_CC)"
- $(use_enable static-libs static)
- $(multilib_native_use_enable nls)
- --disable-doc
- --disable-gcc-warnings
- --disable-gtk-doc
- --disable-valgrind-tests
- )
-
- local ECONF_SOURCE=${S}
- econf "${myconf[@]}"
-}
-
-multilib_src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-}