summaryrefslogtreecommitdiff
path: root/net-dns/pdns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /net-dns/pdns
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'net-dns/pdns')
-rw-r--r--net-dns/pdns/Manifest2
-rw-r--r--net-dns/pdns/pdns-4.6.2.ebuild168
2 files changed, 170 insertions, 0 deletions
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index f699d1c27cb4..7cc52e577afb 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,5 +1,7 @@
AUX dnsdomain2.schema 6640 BLAKE2B d3efc6bc16390f35979f1184632e7184cf403453422888e2cb44fa4fed7891241919a39c8c6f539a61de032654650a45ea548a6983777ea1bfe029e817f2c315 SHA512 ac16f8d528d6138d3c2cbf997fd8fbb467d388aa63eb6ed4e7780a3dad11ea885b91252ff0809b1d2cf7d5200814b8963aab890af84741ea86d35b2f5955a7ea
AUX pdns-r1 2815 BLAKE2B cd607cb30a94540eca9cfa2defb7c996f6e151875fcaad8ad3357261937868bc346962f1080ad45a0ef38c2dfc126eb11e41837ee0784f677d1e7c071589a057 SHA512 4c0442d8d92d95268d4971f80782d2772e2a22c43da00566a9328c79a834e4355b2610d133034351d7137ed6cd7fda300f3db8093b09d5852cea44d983de1e39
DIST pdns-4.6.1.tar.bz2 1315530 BLAKE2B 18676fac07667215babce3687d2ed9f108cad56a3a099907feac7eb86ba771bcd6319eb687ff826c5288590e6cdf3babe6c6c867a892d290351017c5bfb10198 SHA512 02ecb4e182ac4976f9d788b351b70988ec56cc034631f482e539ec9c420bba231c4597b2f76a4b511c5aaa58ee097ad9de4e4b29b191af65eaf5033269ae7087
+DIST pdns-4.6.2.tar.bz2 1302527 BLAKE2B ff4e7f5ab0d0cd176e6c714d5bdf0b231ee05f092c91b19309b62b4d638d2fd1149e426ae98e153b1f64aca1f972f69c3475ee672936b85cc810f305ce899f90 SHA512 10e7f4338f99f063ca8d694c148d468e66dd1b9feb2cf8dba04861396addb138b9335908d666e7e2701424d1fdb3c29e40b596098f19b1443643b9e6ab356c0a
EBUILD pdns-4.6.1.ebuild 4420 BLAKE2B 7a85d32f4646c6a91187885184094c155322a8b5ba47954c15ce600b96a9846fe32f3d5fc362d36daee0ed298c185097d5c8ab1a02fd8dedc7dad4e1795d3683 SHA512 12ba08350b8255a395eaebcba671cd6ce70f46069fc1e962033d982691e39d9b995cc53e5a700cafff46bbdd485509afe5e4a72086a357656477c538ed046b4f
+EBUILD pdns-4.6.2.ebuild 4422 BLAKE2B 1da333485731c95bf680dc505b06bac46b30b3272c43787d320d06d4b719833d9a3d16ef7ff2a7dad3747d3077e4f8007da9ad7d19042a6e8a1799783ef24599 SHA512 104150b7752ce66d070155a8e4cd39da453eef34ad7aa6baeaccbbb110a3a995f3b6b9537188afe40a6dab84e50dd31d74098b4b21eb53c467d381118750f0fc
MISC metadata.xml 1033 BLAKE2B 25e9c4711dd3f5113aba4edb7d0b8aeed9fd63344633c0889110899a5e2a8021908c585d2817a88c121eadde0d55b449404ea2b4e83ac7c85b270cd3c34513c0 SHA512 0b8ca219f5246165e35d8c2c43ccf95fc55ebc4df09568941fad377e3fa4c52a7312623c61fc87b72f9841246ee2ccb600317edf5c6514582db2d67272130f22
diff --git a/net-dns/pdns/pdns-4.6.2.ebuild b/net-dns/pdns/pdns-4.6.2.ebuild
new file mode 100644
index 000000000000..6031548b05ba
--- /dev/null
+++ b/net-dns/pdns/pdns-4.6.2.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Daemon"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# other possible flags:
+# db2: we lack the dep
+# oracle: dito (need Oracle Client Libraries)
+# xdb: (almost) dead, surely not supported
+
+IUSE="debug doc geoip ldap lua-records mydns mysql postgres remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ mydns? ( mysql )"
+
+DEPEND="${LUA_DEPS}
+ dev-libs/openssl:=
+ >=dev-libs/boost-1.35:=
+ lua-records? ( >=net-misc/curl-7.21.3 )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:= )
+ ldap? ( >=net-nds/openldap-2.0.27-r4:= app-crypt/mit-krb5 )
+ sqlite? ( dev-db/sqlite:3 )
+ geoip? ( >=dev-cpp/yaml-cpp-0.5.1:= dev-libs/geoip )
+ sodium? ( dev-libs/libsodium:= )
+ tinydns? ( >=dev-db/tinycdb-0.77 )
+ elibc_glibc? ( x86? ( >=sys-libs/glibc-2.34 ) )"
+RDEPEND="${DEPEND}
+ acct-user/pdns
+ acct-group/pdns"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ local dynmodules="pipe bind" # the default backends, always enabled
+
+ #use db2 && dynmodules+=" db2"
+ use ldap && dynmodules+=" ldap"
+ use mydns && dynmodules+=" mydns"
+ use mysql && dynmodules+=" gmysql"
+ #use oracle && dynmodules+=" goracle oracle"
+ use postgres && dynmodules+=" gpgsql"
+ use remote && dynmodules+=" remote"
+ use sqlite && dynmodules+=" gsqlite3"
+ use tinydns && dynmodules+=" tinydns"
+ use geoip && dynmodules+=" geoip"
+ #use xdb && dynmodules+=" xdb"
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/powerdns \
+ --libdir=/usr/$(get_libdir)/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-modules= \
+ --with-dynmodules="${dynmodules}" \
+ --with-mysql-lib=/usr/$(get_libdir) \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable lua-records) \
+ $(use_enable test unit-tests) \
+ $(use_enable tools) \
+ $(use_enable systemd) \
+ $(use_with sodium libsodium) \
+ ${myconf}
+}
+
+src_compile() {
+ default
+ use doc && emake -C codedocs codedocs
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+ fperms 0700 /etc/powerdns
+ fperms 0600 /etc/powerdns/pdns.conf
+
+ # set defaults: setuid=pdns, setgid=pdns
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+ "${D}"/etc/powerdns/pdns.conf
+
+ newinitd "${FILESDIR}"/pdns-r1 pdns
+
+ keepdir /var/empty
+
+ if use doc; then
+ docinto html
+ dodoc -r codedocs/html/.
+ fi
+
+ # Install development headers
+ insinto /usr/include/pdns
+ doins pdns/*.hh
+ insinto /usr/include/pdns/backends/gsql
+ doins pdns/backends/gsql/*.hh
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/dnsdomain2.schema
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "PowerDNS provides multiple instances support. You can create more instances"
+ elog "by symlinking the pdns init script to another name."
+ elog
+ elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
+ elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+
+ local old
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 3.2 || continue
+
+ echo
+ ewarn "To fix a security bug (bug #458018) had the following"
+ ewarn "files/directories the world-readable bit removed (if set):"
+ ewarn " ${EPREFIX}/etc/powerdns"
+ ewarn " ${EPREFIX}/etc/powerdns/pdns.conf"
+ ewarn "Check if this is correct for your setup"
+ ewarn "This is a one-time change and will not happen on subsequent updates."
+ chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
+
+ break
+ done
+
+ if use postgres; then
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.1.11-r1 || continue
+
+ echo
+ ewarn "PowerDNS 4.1.11 contains a security fix for the PostgreSQL backend."
+ ewarn "This security fix needs to be applied manually to the database schema."
+ ewarn "Please refer to the official security advisory for more information:"
+ ewarn
+ ewarn " https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-06.html"
+
+ break
+ done
+ fi
+}