summaryrefslogtreecommitdiff
path: root/net-dns/updatedd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-dns/updatedd/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-dns/updatedd/files')
-rw-r--r--net-dns/updatedd/files/fix-ovh-DYNDNSHOST.patch11
-rw-r--r--net-dns/updatedd/files/respect-docdir.patch33
-rw-r--r--net-dns/updatedd/files/set-socket-timeouts-for-ipserv.patch36
-rw-r--r--net-dns/updatedd/files/updatedd-2.6-options.patch12
4 files changed, 92 insertions, 0 deletions
diff --git a/net-dns/updatedd/files/fix-ovh-DYNDNSHOST.patch b/net-dns/updatedd/files/fix-ovh-DYNDNSHOST.patch
new file mode 100644
index 000000000000..f8f61741ef1e
--- /dev/null
+++ b/net-dns/updatedd/files/fix-ovh-DYNDNSHOST.patch
@@ -0,0 +1,11 @@
+--- a/src/plugins/libovh.h 2006-09-07 22:32:59.000000000 +0200
++++ b/src/plugins/libovh.h 2013-01-20 13:48:37.162920947 +0100
+@@ -21,7 +21,7 @@
+
+ #include <ret_codes.h>
+
+-#define DYNDNSHOST "ovh.com"
++#define DYNDNSHOST "www.ovh.com"
+ #define PORT 80
+
+ #define BUFSIZE 512
diff --git a/net-dns/updatedd/files/respect-docdir.patch b/net-dns/updatedd/files/respect-docdir.patch
new file mode 100644
index 000000000000..504220a4eb8f
--- /dev/null
+++ b/net-dns/updatedd/files/respect-docdir.patch
@@ -0,0 +1,33 @@
+From 8e484c4b0ceac8e7c37492fdf5e5b89f18451277 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sat, 14 Jan 2017 01:06:48 -0500
+Subject: [PATCH 1/1] Use the autotools "docdir" in Documentation/Makefile.in.
+
+---
+ Documentation/Makefile.in | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Documentation/Makefile.in b/Documentation/Makefile.in
+index 8c87281..c213c09 100644
+--- a/Documentation/Makefile.in
++++ b/Documentation/Makefile.in
+@@ -325,12 +325,12 @@ uninstall-am: uninstall-info-am uninstall-local
+
+
+ install-data-local:
+- $(INSTALL) -d $(DESTDIR)$(datadir)/doc/updatedd
+- $(INSTALL) $(srcdir)/updatedd-*.pdf $(DESTDIR)$(datadir)/doc/updatedd
+- $(INSTALL) $(srcdir)/updatedd-pppd-rc $(DESTDIR)$(datadir)/doc/updatedd
++ $(INSTALL) -d $(DESTDIR)$(docdir)
++ $(INSTALL) $(srcdir)/updatedd-*.pdf $(DESTDIR)$(docdir)
++ $(INSTALL) $(srcdir)/updatedd-pppd-rc $(DESTDIR)$(docdir)
+
+ uninstall-local:
+- $(RM) -r $(DESTDIR)$(datadir)/doc/updatedd
++ $(RM) -r $(DESTDIR)$(docdir)
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
+--
+2.10.2
+
diff --git a/net-dns/updatedd/files/set-socket-timeouts-for-ipserv.patch b/net-dns/updatedd/files/set-socket-timeouts-for-ipserv.patch
new file mode 100644
index 000000000000..dbcf4c7c7c79
--- /dev/null
+++ b/net-dns/updatedd/files/set-socket-timeouts-for-ipserv.patch
@@ -0,0 +1,36 @@
+Patch by Maciej S. Szmigiero to prevent ipserv from hanging when the
+other end of the connection goes AWOL.
+
+Gentoo-Bug: 602216
+
+--- a/scripts/ipserv.pl.in 2005-03-06 22:21:36.000000000 +0100
++++ b/scripts/ipserv.pl.in 2017-01-14 19:39:25.583277538 +0100
+@@ -20,6 +20,7 @@
+
+ use strict;
+ use IO::Socket;
++use IO::Socket::Timeout qw(IO::Socket::INET);
+
+ my $ipv4_rex = qr/(?:\d{1,3}\.){3}\d{1,3}/imosx;
+
+@@ -128,7 +129,8 @@
+ $socket = IO::Socket::INET->new(PeerAddr => $target->{url},
+ PeerPort => $target->{port},
+ Proto => "tcp",
+- Type => SOCK_STREAM)
++ Type => SOCK_STREAM,
++ Timeout => 2 * 60)
+ or $retries--;
+
+ } while(!defined($socket) && $retries != 0);
+@@ -137,6 +139,10 @@
+ die "could not connect to $target->{url}: $!";
+ }
+
++ IO::Socket::Timeout->enable_timeouts_on($socket);
++ $socket->read_timeout(2 * 60);
++ $socket->write_timeout(2 * 60);
++
+ if(defined($target->{request})) {
+ print($socket $target->{request});
+ }
diff --git a/net-dns/updatedd/files/updatedd-2.6-options.patch b/net-dns/updatedd/files/updatedd-2.6-options.patch
new file mode 100644
index 000000000000..17fe89b3e49d
--- /dev/null
+++ b/net-dns/updatedd/files/updatedd-2.6-options.patch
@@ -0,0 +1,12 @@
+--- updatedd-2.6/src/updatedd.c.orig 2008-04-01 19:00:30.000000000 +1100
++++ updatedd-2.6/src/updatedd.c 2008-04-01 19:01:17.000000000 +1100
+@@ -272,7 +272,8 @@
+ int c, option_index = 0;
+ static struct option long_options[] = {
+ { "help", 0, 0, 'h' },
+- { "version", 0, 0, 'v' }
++ { "version", 0, 0, 'v' },
++ { 0, 0, 0, 0 }
+ };
+
+ c = getopt_long(argc, argv, "LY",