summaryrefslogtreecommitdiff
path: root/net-firewall/pglinux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /net-firewall/pglinux
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'net-firewall/pglinux')
-rw-r--r--net-firewall/pglinux/Manifest3
-rw-r--r--net-firewall/pglinux/files/pglinux-2.3.1_p20171006-fno-common.patch21
-rw-r--r--net-firewall/pglinux/pglinux-2.3.1_p20171006.ebuild5
3 files changed, 27 insertions, 2 deletions
diff --git a/net-firewall/pglinux/Manifest b/net-firewall/pglinux/Manifest
index 92fb68b24e16..8be7e2f6b34d 100644
--- a/net-firewall/pglinux/Manifest
+++ b/net-firewall/pglinux/Manifest
@@ -1,3 +1,4 @@
+AUX pglinux-2.3.1_p20171006-fno-common.patch 492 BLAKE2B 803ecc1c2089a873ef2df2901c3364ff4e9242c2b6758c0b2e8fee57c7a13e31d6fb2a5f10ee24f8452e453299112af3be4fb1500f472bdd8192ea1b2363f13e SHA512 dbeac2030b38a7e224a0d3221ebbb8b3199f8a7eca3d675c6516121c8a61c6834f25da93bab60fe3216745d6fde12f4342c8f9f94abab6efbdda45e7f0f697a6
DIST pglinux-2.3.1_p20171006.zip 340253 BLAKE2B a39ecad1290dd31b126ed58c22f2de1162a4081e07f576509b5d77adffeb4a74b5aeb489f8f63134b0fc37d174e61b6631bdb350c3277729456092ba0ae3c600 SHA512 ea30076d7a21fa71d5e352c479cb1a463c9f244d675f5c7f9d5d25a33b27f4c7f1a39d173f2fd156e3f2cb0652da0a06c078fc38972275073f38d48f207e42f3
-EBUILD pglinux-2.3.1_p20171006.ebuild 2550 BLAKE2B 94ed616c03210e31a466b06645dcd9aa546d60ad18e3ed7581b2e46b40165b0b2c3cd41f02e7ecff4b211565b33be5e168aff55efa328c38a624557ea43d74f7 SHA512 f307273c75ca8a53849cd8b40cde226d01c2f11809772862b00462f9e4e7a2dc12c15cc22da3801095ec359e390f450791be5510d931d726ea5ce65b2eb48526
+EBUILD pglinux-2.3.1_p20171006.ebuild 2596 BLAKE2B 2b9185dd83a20c85f6a79b92be9f661bca488e84047d9c8ef265370d0251b6668969707e15795fddfa109de811c23bfec1422daac06fa104ad6cab48e7ab6719 SHA512 d732b18ee3e784c868e081b59f31462742b73cf5787a007a3b3df5696983fcff733b822ffad3f46d4ae1dcc2d632f42b917e407b40d85c2b7b66f1b4bfd97728
MISC metadata.xml 877 BLAKE2B 23f3f249945c9c606588fab5cb610e10a5adfa00bb9f9408f5dd373bc76b6a1b4b0cfff72de8b86d2b7de335d1730ee5cf15108b519e148f797ff2855fa16064 SHA512 6b9986e54aa2b6d75acabfc74e080d0e378b79f94178d7dec3c6b870fa90ccbf4840559942d29ce27f017a63b8f8760c21ac09fffb0040f9f624a053c489d8de
diff --git a/net-firewall/pglinux/files/pglinux-2.3.1_p20171006-fno-common.patch b/net-firewall/pglinux/files/pglinux-2.3.1_p20171006-fno-common.patch
new file mode 100644
index 000000000000..d6c80405e86d
--- /dev/null
+++ b/net-firewall/pglinux/files/pglinux-2.3.1_p20171006-fno-common.patch
@@ -0,0 +1,21 @@
+--- a/pgld/src/blocklist.h
++++ b/pgld/src/blocklist.h
+@@ -74,6 +74,6 @@
+ void blocklist_stats(int clearhits);
+ block_entry_t * blocklist_find(uint32_t ip);
+ void blocklist_dump();
+-blocklist_t blocklist;
++extern blocklist_t blocklist;
+
+ #endif /* INC_BLOCKLIST_H */
+--- a/pgld/src/blocklist.c
++++ b/pgld/src/blocklist.c
+@@ -22,6 +22,8 @@
+ #include "blocklist.h"
+ #include "pgld.h"
+
++blocklist_t blocklist;
++
+ void blocklist_init() {
+ blocklist.entries = NULL;
+ blocklist.count = 0;
diff --git a/net-firewall/pglinux/pglinux-2.3.1_p20171006.ebuild b/net-firewall/pglinux/pglinux-2.3.1_p20171006.ebuild
index 8f0826099c32..eafaafe2ee81 100644
--- a/net-firewall/pglinux/pglinux-2.3.1_p20171006.ebuild
+++ b/net-firewall/pglinux/pglinux-2.3.1_p20171006.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -58,6 +58,9 @@ CONFIG_CHECK="~NETFILTER_NETLINK
~IP_NF_IPTABLES
~IP_NF_TARGET_REJECT"
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+)
S="${WORKDIR}/${MY_PN}-code-${COMMIT}"
src_prepare() {