summaryrefslogtreecommitdiff
path: root/net-fs/davfs2/davfs2-1.5.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /net-fs/davfs2/davfs2-1.5.5.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'net-fs/davfs2/davfs2-1.5.5.ebuild')
-rw-r--r--net-fs/davfs2/davfs2-1.5.5.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-fs/davfs2/davfs2-1.5.5.ebuild b/net-fs/davfs2/davfs2-1.5.5.ebuild
new file mode 100644
index 000000000000..3ef5dd25f003
--- /dev/null
+++ b/net-fs/davfs2/davfs2-1.5.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit user
+
+DESCRIPTION="Linux FUSE (or coda) driver that allows you to mount a WebDAV resource"
+HOMEPAGE="https://savannah.nongnu.org/projects/davfs2"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="nls"
+RESTRICT="test"
+
+RDEPEND="dev-libs/libxml2
+ net-libs/neon
+ sys-libs/zlib
+ nls? ( virtual/libintl virtual/libiconv )
+"
+DEPEND="${REPEND}
+ nls? ( sys-devel/gettext )
+"
+
+pkg_setup() {
+ enewgroup davfs2
+}
+
+src_prepare() {
+ # Let the package manager handle man page compression
+ sed -e '/^manual[58]_DATA/ s/\.gz//g' \
+ -i "${S}"/man/Makefile.in || die
+
+ default
+}
+
+src_configure() {
+ econf dav_user=nobody --enable-largefile $(use_enable nls)
+}
+
+pkg_postinst() {
+ elog
+ elog "Quick setup:"
+ elog " (as root)"
+ elog " # gpasswd -a \${your_user} davfs2"
+ elog " # echo 'http://path/to/dav /home/\${your_user}/dav davfs rw,user,noauto 0 0' >> /etc/fstab"
+ elog " (as user)"
+ elog " \$ mkdir -p ~/dav"
+ elog " \$ mount ~/dav"
+ elog
+}