summaryrefslogtreecommitdiff
path: root/net-fs/ncpfs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
commit2f8db31405fac68eea6f7257d58529243815033b (patch)
tree54259cc8988a98a10586fc0496b1f3501cd1e2a1 /net-fs/ncpfs
parenta4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (diff)
gentoo resync : 30.04.2018
Diffstat (limited to 'net-fs/ncpfs')
-rw-r--r--net-fs/ncpfs/Manifest1
-rw-r--r--net-fs/ncpfs/ncpfs-2.2.6-r5.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/net-fs/ncpfs/Manifest b/net-fs/ncpfs/Manifest
index a5fd6937ca3f..3433c5bdd8e8 100644
--- a/net-fs/ncpfs/Manifest
+++ b/net-fs/ncpfs/Manifest
@@ -19,4 +19,5 @@ AUX ncpfs-2.2.6-zend_function_entry.patch 296 BLAKE2B 3bb6db87517e0fb086e95462e9
DIST ncpfs-2.2.6.tar.gz 2100545 BLAKE2B b95c8c0b097227c7b9e526e978efdca2234cdd0833468be99abaa68b0feba09794be26ebcb3a1c3371bc99f6c9d007eee164fa5f918aaee3eca44aeb1420211f SHA512 51f85eaae85deb66cea2ff434974699f6aa45ed1ed75217ef6176ac0b7d0f9f1c4fb186afc64c1b495474d5bad9ac7614033128c0bec39c05de723a9b29c8602
EBUILD ncpfs-2.2.6-r3.ebuild 2604 BLAKE2B 3c768032c5ab48cafa7955330bafccc00816fb07b0d4d06049e590ddb2079a9506df3e0de694e8022cab705a6bdab8c43c5122f4d8bcbd80ceb16cd5ebfe79c5 SHA512 c81d58564071787615b572ed360230ad2fa2d8030a2a8aefa778467b7be7d9726c5556bb7faad3f73e7a92341a33aebc61cb812a951d9f7c2970424ef733b976
EBUILD ncpfs-2.2.6-r4.ebuild 2449 BLAKE2B 02c2bbf4cea12348b64b1c584bee9b0b0e1c5fd688968b17799c8664b676d8e7205d6d33e025a6ec40a2485153649d774a8933196dcf448a76e59416394e4053 SHA512 46cf6f9b1968528649df09596d097b7f775fb2ac61e69ebedce78bb7ae0c7c1622d3febc9d25245278de73c938edf488f99712dac5c7db4aa4a3f150e83830e8
+EBUILD ncpfs-2.2.6-r5.ebuild 2338 BLAKE2B 9b73d48b5adc7f5ef2e6421107160d5c7acc87ef64d47ae2af1012a110eaa6c169df4fec37ba5262772649bee537d7e9e0d9aa2bf30119b94a3a758bb01c8cdd SHA512 258aa32e307f6410b7d3461d0a24a54c86cc275730ef748e3bad54370f1114de7594d37731adb314729bf77ab1b2f470e848374ccc343d8a81382049300feb0d
MISC metadata.xml 376 BLAKE2B 33c2a81c2a97ae39b1f66ae00a81dbc58144f8f264f31235f95852c70dadfd74ae8ab3db92bfed910354598d4f50e1ce0de546eef7fc2db3717158294fdf79e7 SHA512 dacdb06d762397d05a6ba195648173ddd13822bc020fd0c8ed12148003e9ee651636f162860c5aace8e1182111da4082d2c509a20e8523bd8ed05ef04c51afec
diff --git a/net-fs/ncpfs/ncpfs-2.2.6-r5.ebuild b/net-fs/ncpfs/ncpfs-2.2.6-r5.ebuild
new file mode 100644
index 000000000000..14c992bac3a1
--- /dev/null
+++ b/net-fs/ncpfs/ncpfs-2.2.6-r5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit pam
+
+DESCRIPTION="Provides access to Netware services using the NCP protocol"
+HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/ncpfs/"
+SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="nls pam"
+
+DEPEND="
+ nls? ( sys-devel/gettext )
+ pam? ( virtual/pam )"
+
+RDEPEND="${DEPEND}"
+
+MY_PATCHES=(
+ # Build fixes.
+ "${FILESDIR}"/${P}-gcc4.patch
+ "${FILESDIR}"/${P}-missing-includes.patch
+
+ # Add a patch to fix multiple vulnerabilities.
+ # CVE-2010-0788, CVE-2010-0790, & CVE-2010-0791.
+ # http://seclists.org/fulldisclosure/2010/Mar/122
+ "${FILESDIR}"/${P}-multiple-vulns.patch
+
+ # Add a patch that removes the __attribute__((packed)); directive
+ # from several struct members in include/ncp/ncplib.h. This will
+ # cut down on a large number of compile warnings generated by modern
+ # gcc releases.
+ "${FILESDIR}"/${P}-remove-packed-attrib.patch
+
+ # Misc patches borrowed from Mageia.
+ "${FILESDIR}"/${P}-align-fix.patch
+ "${FILESDIR}"/${P}-getuid-fix.patch
+ "${FILESDIR}"/${P}-pam_ncp_auth-fix.patch
+ "${FILESDIR}"/${P}-servername-array-fix.patch
+
+ # Misc patches borrowed from Debian.
+ # Fixes Bug #497278
+ "${FILESDIR}"/${P}-drop-kernel-check.patch
+ "${FILESDIR}"/${P}-drop-mtab-support.patch
+ "${FILESDIR}"/${P}-no-suid-root.patch
+ "${FILESDIR}"/${P}-remove-libncp_atomic-header.patch
+
+ # Support LDFLAGS.
+ "${FILESDIR}"/${P}-ldflags-support.patch
+
+ # Bug 446696. This might need re-diffing if additional Makefile
+ # fixes are added.
+ "${FILESDIR}"/${P}-makefile-fix-soname-link.patch
+)
+
+DOCS=( FAQ README )
+
+src_prepare() {
+ default
+
+ # Bug #273484.
+ sed -i '/ldconfig/d' lib/Makefile.in || die
+
+ epatch "${MY_PATCHES[@]}"
+}
+
+src_configure() {
+ # PHP integration no longer supported in Gentoo, per Bug #582516.
+ econf \
+ $(use_enable nls) \
+ $(use_enable pam pam "$(getpam_mod_dir)") \
+ --disable-php
+}
+
+src_install() {
+ dodir $(getpam_mod_dir) /usr/sbin /sbin
+
+ # Install main software and headers.
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install-dev
+
+ # Install a startup script in /etc/init.d and a conf file in /etc/conf.d
+ newconfd "${FILESDIR}"/ipx.confd ipx
+ newinitd "${FILESDIR}"/ipx.init ipx
+
+ einstalldocs
+}