summaryrefslogtreecommitdiff
path: root/net-ftp/ncftp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-15 06:52:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-15 06:52:13 +0000
commit9f7759b3b1be5a3bc7794010a8ebf9334f017d2f (patch)
treefa4e093c6694ec0590cbbd9a7b86c1edddc43d72 /net-ftp/ncftp
parentac35def7deb4a1eecfad26f0eb5907170b2ee5d7 (diff)
gentoo auto-resync : 15:11:2022 - 06:52:13
Diffstat (limited to 'net-ftp/ncftp')
-rw-r--r--net-ftp/ncftp/Manifest2
-rw-r--r--net-ftp/ncftp/files/ncftp-3.2.6-fix-clang.patch437
-rw-r--r--net-ftp/ncftp/ncftp-3.2.6-r5.ebuild58
3 files changed, 497 insertions, 0 deletions
diff --git a/net-ftp/ncftp/Manifest b/net-ftp/ncftp/Manifest
index 9e47ae20d3ee..0c2d62ce5d79 100644
--- a/net-ftp/ncftp/Manifest
+++ b/net-ftp/ncftp/Manifest
@@ -1,4 +1,6 @@
+AUX ncftp-3.2.6-fix-clang.patch 7325 BLAKE2B 47fd1c348e5b4190ccf6e6d73806230a8c8de59873b5b31623789abe5f758467e19755f9e206a1fc92a89a0dea3611530f86261f2d25365347e6e418def6d13f SHA512 0fdc7554e990a684c447be6d0d613849ea1c1117faa3f287722d5a0c6beae175f51209f10d5b384f1e28f7cf375c075a239dc2e688be2584c3344995762c1cb7
AUX ncftp-3.2.6-fno-common.patch 1818 BLAKE2B 620e3fbc7e297d3186fe9eef8855e2a663a5abcd680269101d5547ab9f6b9addcfe6040ba35e16e8e540784796e34304a9377b1149f7ac00fe0859627a141200 SHA512 c6bf0cc4324583d9aae3f3a57c900437a78d30138d0b9da06fea66cd5fbf57a79ea420afe33536a5bbcf2ace61aaca30ea04155df638daeae125ed9ca90b1c25
DIST ncftp-3.2.6-src.tar.xz 420564 BLAKE2B ce6d8d2bf06761f884e9edfe6d0bb0230f5d515078a787c4e6faf7716b760166acdd0accf3de1e1f5f3d892c8c86348cdbbefeac6be05e6806011a3e8f4c9b02 SHA512 8e6091ce2ea1eb463edea322d1b5dde813475fd22096d67f0bfd2f5101ae09747ff25d38816d0b9b1077e6a5a256078361691f816aa2eefa38638aa523b4b382
EBUILD ncftp-3.2.6-r4.ebuild 1137 BLAKE2B 122bbe66f3611d353bd9f0d3786953f55a1a7be641d746f121fbf6cb8c8da0f9e7ffb5c10aa46547f85ea61e1d50a4c83bc082b2c3dca1769ae1f4253ad36a33 SHA512 a744fd7ac84b8e5cdbaf10cca9955ed19c52318cb1c4cf22bc38476cb06b22098b47e68868c3d53edc66313460398bcbdd65eab1d4abdf230443f9a535a805c2
+EBUILD ncftp-3.2.6-r5.ebuild 1198 BLAKE2B 649cf5017f514339a8e79345a34b0792b1960a0d9883f532a851ab7f3ad0d89ea8e51a94bb2f2485142e1cfdafbbcf2a9b84722f8cefb8a68a59d60f425c2320 SHA512 1f8154ed22ea021b9f58ddc60aee3bfc8f77279d1883458921c5c37f697e81ec9d020051456428c055e8891bac0f207d7e8a80a54e90be8e82eea103b8901695
MISC metadata.xml 747 BLAKE2B eb28ac0c7249544d1519dc534092dc0f8575c3f68cd24d9dc1654e0d9ffaabf8359fd64ee7ec321878b31e4e65a1c3767528a9f91301809e07f187867f52f09a SHA512 2d672c6901cf721df89f79f420f61ad709d3570fa0d762cae4becbb7f2426abf7a2812d9899fdee75daab20aab80fa80f796295dd3bbae588fe4eac93204b1f7
diff --git a/net-ftp/ncftp/files/ncftp-3.2.6-fix-clang.patch b/net-ftp/ncftp/files/ncftp-3.2.6-fix-clang.patch
new file mode 100644
index 000000000000..21b4a5601d36
--- /dev/null
+++ b/net-ftp/ncftp/files/ncftp-3.2.6-fix-clang.patch
@@ -0,0 +1,437 @@
+Fix compilation with clang-16
+
+aclocal.m4 contains code that no longer compiles: missing headers and missing
+return types.
+
+--- a/autoconf_local/aclocal.m4
++++ b/autoconf_local/aclocal.m4
+@@ -192,6 +192,7 @@
+ #include "pchtest.h"
+ #pragma hdrstop
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ int main(int argc, char **argv)
+ {
+@@ -1242,7 +1243,9 @@
+ AC_MSG_CHECKING([if -D__STDC_EXT__ is needed with GCC on HP-UX])
+ AC_TRY_RUN([
+ #include <stdio.h>
++#include <stdlib.h>
+
++int
+ main()
+ {
+ #ifdef __STDC_EXT__
+@@ -1674,7 +1677,9 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
++int
+ main()
+ {
+ int result;
+@@ -1816,6 +1821,7 @@
+ # include <snprintf.h>
+ #endif
+
++int
+ main()
+ {
+ char s[16];
+@@ -1876,6 +1882,7 @@
+ # include <snprintf.h>
+ #endif
+
++int
+ main()
+ {
+ int result;
+@@ -2004,7 +2011,9 @@
+ #ifdef HAVE_SYS_UN_H
+ #include <sys/un.h>
+ #endif
++#include <stdlib.h>
+
++int
+ main()
+ {
+ int sfd;
+@@ -2088,7 +2097,9 @@
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <netdb.h>
++#include <stdlib.h>
+
++int
+ main()
+ {
+ struct hostent *hp1, *hp2;
+@@ -2134,6 +2145,7 @@
+ #endif
+ #include <sys/types.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ /* These are needed if libwrap.a was compiled with
+ * PROCESS_OPTIONS defined.
+@@ -2238,6 +2250,7 @@
+ #include <stdio.h>
+ #include <signal.h>
+ #include <setjmp.h>
++#include <stdlib.h>
+ ],[
+ /* function-body */
+ sigjmp_buf sjb;
+@@ -2265,6 +2278,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <utmp.h>
++#include <stdlib.h>
+ ],[
+ struct utmp u;
+
+@@ -2288,6 +2302,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <utmp.h>
++#include <stdlib.h>
+ ],[
+ struct utmp u;
+
+@@ -2311,6 +2326,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <utmpx.h>
++#include <stdlib.h>
+ ],[
+ struct utmpx u;
+
+@@ -2334,6 +2350,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <utmpx.h>
++#include <stdlib.h>
+ ],[
+ struct utmpx u;
+
+@@ -2357,6 +2374,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <utmpx.h>
++#include <stdlib.h>
+ ],[
+ struct utmpx u;
+
+@@ -2380,6 +2398,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <utmp.h>
++#include <stdlib.h>
+ ],[
+ struct utmp u;
+
+@@ -2403,6 +2422,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <utmp.h>
++#include <stdlib.h>
+ ],[
+ struct utmp u;
+
+@@ -2427,6 +2447,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <utmp.h>
++#include <stdlib.h>
+ ],[
+ struct utmp u;
+
+@@ -2450,6 +2471,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <utmp.h>
++#include <stdlib.h>
+ ],[
+ struct utmp u;
+
+@@ -2482,6 +2504,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ size_t x = 0;
+@@ -2545,6 +2568,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ off_t x = 0;
+@@ -2608,6 +2632,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ struct stat x;
+@@ -2671,6 +2696,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ off64_t x = 0;
+@@ -2732,6 +2758,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ struct stat64 x;
+@@ -2789,6 +2816,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <stdlib.h>
+ ],[
+ struct stat64 st;
+
+@@ -2815,6 +2843,7 @@
+ #include <sys/uio.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
++#include <stdlib.h>
+ ],[
+ struct cmsghdr cm;
+
+@@ -2844,6 +2873,7 @@
+ #include <sys/uio.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
++#include <stdlib.h>
+ ],[
+ struct msghdr m;
+
+@@ -2872,6 +2902,7 @@
+ #include <sys/uio.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
++#include <stdlib.h>
+ ],[
+ struct msghdr m;
+
+@@ -2975,6 +3006,8 @@
+ #include <sys/uio.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
++#include <stdlib.h>
++#include <string.h>
+ ],[
+ struct sockaddr_un uaddr;
+
+@@ -3004,6 +3037,7 @@
+ #elif defined(HAVE_SYS_VFS_H)
+ # include <sys/vfs.h>
+ #endif
++#include <stdlib.h>
+ ],[
+ struct statfs st;
+
+@@ -3027,6 +3061,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/statvfs.h>
++#include <stdlib.h>
+ ],[
+ struct statvfs st;
+
+@@ -3049,7 +3084,9 @@
+ /* program */
+ #include <stdio.h>
+ #include <string.h>
++#include <stdlib.h>
+
++int
+ main()
+ {
+ int result;
+@@ -3108,9 +3145,11 @@
+ #endif
+ #include <stdio.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ extern char *crypt(const char *key, const char *salt);
+
++int
+ main()
+ {
+ char cleartext[256];
+@@ -3182,6 +3221,7 @@
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <netinet/in.h>
++#include <string.h>
+ #ifdef HAVE_ARPA_NAMESER_H
+ # include <arpa/nameser.h>
+ #endif
+@@ -3327,9 +3367,11 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ extern char *rl_library_version;
+
++int
+ main()
+ {
+ FILE *fp;
+@@ -3446,9 +3488,11 @@
+ #endif
+ #include <sys/types.h>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ long long hugeNumvar = 1;
+
++int
+ main()
+ {
+ long long hugeNumtoo = 2;
+@@ -3495,6 +3539,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ char s[80];
+@@ -3536,6 +3581,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ char s[80];
+@@ -3585,6 +3631,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ long long hugeNum, justAsHugeNum;
+@@ -3629,6 +3676,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ long long hugeNum, justAsHugeNum;
+@@ -4076,7 +4124,7 @@
+ #include <sys/select.h>
+ #endif
+ #include <sys/socket.h> /* MG: always incl */
+-extern select ($ac_cv_func_select_arg1,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg5);],,dnl
++extern int select ($ac_cv_func_select_arg1,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg5);],,dnl
+ [ac_not_found=no ; break 3],ac_not_found=yes)
+ done
+ done
+@@ -4226,7 +4274,9 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
++#include <stdlib.h>
+
++int
+ main()
+ {
+ exit(0);
+@@ -5023,6 +5073,7 @@
+ /* includes */
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #ifdef HAVE_NCURSES_H
+ # define NCURSES_OPAQUE 0
+@@ -5054,6 +5105,7 @@
+ #endif
+
+
++int
+ main(int argc, char **argv)
+ {
+ /* Note: don't actually call curses, since it may block;
+@@ -5142,6 +5194,7 @@
+ # include <curses.h>
+ #endif
+
++int
+ main()
+ {
+ exit(0);
+@@ -5809,7 +5862,9 @@
+ cat <<EOF > "$vertest.c"
+ #include <stdio.h>
+ #include <gnu/libc-version.h>
++#include <stdlib.h>
+
++int
+ main()
+ {
+ const char *ver = gnu_get_libc_version();
+@@ -5957,6 +6012,7 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+
++int
+ main()
+ {
+ char line[256], *cp, *cp2;
+@@ -6109,6 +6165,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ FILE *fp;
+@@ -6166,6 +6223,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ struct stat x;
+@@ -6224,6 +6282,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+
++int
+ main()
+ {
+ struct stat64 x;
+@@ -6457,7 +6516,8 @@
+ ac_cv_func_setvbuf_reversed,
+ [AC_TRY_RUN([#include <stdio.h>
+ /* If setvbuf has the reversed format, exit 0. */
+- main () {
++ #include <stdlib.h>
++ int main () {
+ /* This call has the arguments reversed.
+ A reversed system may check and see that the address of main
+ is not _IOLBF, _IONBF, or _IOFBF, and return nonzero. */
diff --git a/net-ftp/ncftp/ncftp-3.2.6-r5.ebuild b/net-ftp/ncftp/ncftp-3.2.6-r5.ebuild
new file mode 100644
index 000000000000..c0eb310662c3
--- /dev/null
+++ b/net-ftp/ncftp/ncftp-3.2.6-r5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An extremely configurable ftp client"
+HOMEPAGE="https://www.ncftp.com/"
+SRC_URI="
+ https://ftp.mirrorservice.org/sites/ftp.${PN}.com/${PN}/${P}-src.tar.xz
+"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="pch"
+
+DEPEND="
+ sys-libs/ncurses:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.6-fno-common.patch
+ "${FILESDIR}"/${PN}-3.2.6-fix-clang.patch # 875458
+)
+
+src_prepare() {
+ default
+
+ sed -i -e '/^AR=/d' autoconf_local/aclocal.m4 || die
+ # 727774
+ sed -i -e 's/STRIP=".*"/STRIP=":"/' autoconf_local/aclocal.m4 || die
+
+ AT_M4DIR=autoconf_local/ eautoreconf
+}
+
+src_configure() {
+ tc-export AR CC
+ LC_ALL="C" \
+ LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses)" \
+ econf \
+ $(use_enable pch precomp) \
+ --disable-ccdv \
+ --disable-universal
+}
+
+src_install() {
+ default
+ dodoc README.txt doc/*.txt
+ docinto html
+ dodoc doc/html/*.html
+}