summaryrefslogtreecommitdiff
path: root/net-im/gitter-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 19:18:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 19:18:10 +0100
commit07b0c0005f55e652101816d9f4cfe73403bf0906 (patch)
treeb29108de370177e8ce7c0d0d60e1e4319851d99b /net-im/gitter-bin
parent78754950ffa3aaba0f48b1ca1d505caa4a3dfbfa (diff)
gentoo auto-resync : 04:10:2022 - 19:18:10
Diffstat (limited to 'net-im/gitter-bin')
-rw-r--r--net-im/gitter-bin/Manifest1
-rw-r--r--net-im/gitter-bin/gitter-bin-5.0.1-r1.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/net-im/gitter-bin/Manifest b/net-im/gitter-bin/Manifest
index 4757b15b702d..9a8af82c9095 100644
--- a/net-im/gitter-bin/Manifest
+++ b/net-im/gitter-bin/Manifest
@@ -3,5 +3,6 @@ DIST gitter_4.1.0_i386.deb 101820112 BLAKE2B 3d1ab270389da9c82440dc7a204d1973402
DIST gitter_5.0.1_amd64.deb 136453344 BLAKE2B 6e057fb04872f89961a8970d079b14fbaf416db126ac0596485936a069a85fb5e783b052e20af7fbce40bc4805313ad793873c6ad3cadf87fc2662fef39604f1 SHA512 9bca96a2e312e7893ea7e5faca4a6a3e343d0d3bf96b86e0353437517fc006eb917787cb872f305d1c843978cfd80f729474bd485070ec26d99d67d24ffbf4d1
DIST gitter_5.0.1_i386.deb 141585750 BLAKE2B 464e3416085717702df605fefade3a5aabafbdbfa9274eb9da03832b9a5e442d0a92eacd5c4d757e64709b3ba39bfdc5a87d689bb24db1ede3aca43b187550ce SHA512 b340b161728530e6c397ad6d5fbd591393a893c73b29056094514514d3e0f3a30ebdab94bb19f6c78cf1c73a30c6cd145476e34db5eaea06ba061f8a410579f7
EBUILD gitter-bin-4.1.0-r1.ebuild 2981 BLAKE2B 23fe433dfe977f02e6c8045242fb222e3506a6ad88616370bf6ec04de7488c5ee0ad8ab6f200d0ef2fa983656787fce2743313b0e50808b457a30f4c4e936120 SHA512 5689cf43a4486f5cc174e31116790b8249fe46629646bc1cebbcd41035b7ed45cbbb7356c6747dcb529fe328d408011abce63e831161c6bc21c9fb112162d663
+EBUILD gitter-bin-5.0.1-r1.ebuild 3270 BLAKE2B 941e2e8de637b56b7693a66f1c50bb753b88373cd17483fcf584d243c56e8b173874500ccb919839b1cea9c1f93f1fe4cf07f5aa43ea088a8222edb459173641 SHA512 6dba00d384ca73060cd0049aa6d4308f132009f1b4d0bb4b04a12a07226bbdc71395d357cf02882c9cd0be14952cf1ce6b8313c6fbb1cd33ee704d9d3db6652e
EBUILD gitter-bin-5.0.1.ebuild 3149 BLAKE2B 8627a0810af923aa7247461ccec0487104dbff37a83d872a42d7c28953d8c1320fb2a9fc9fe7ced56bac856bd5241ea17b6c85451de16884c042a3e5148e7b39 SHA512 938cf82609ef0bac5b9d54f42073ecda56b530efbb2cd28334872421d704f66ab90c15f55f7c520b8541b0325c9b89c28e85277af39a62be14a0aa4d6b6bdccf
MISC metadata.xml 657 BLAKE2B 8e15817139a56837429f2b35c5f768048913ce811433ff0571e362115b74ab93949d5a30a21e5ccdfa4fe905c02701a31238b0324dcc259a586cd20cab86fcd4 SHA512 49259e0e2e11923bd4567e4e5a723ec5c9a22da0c33c87b3b0e80eff011fee98d37f5cee551c71bec0796c69a9a66fd5341afda20c55b1bb1a524572518e0206
diff --git a/net-im/gitter-bin/gitter-bin-5.0.1-r1.ebuild b/net-im/gitter-bin/gitter-bin-5.0.1-r1.ebuild
new file mode 100644
index 000000000000..e4dd3c659d02
--- /dev/null
+++ b/net-im/gitter-bin/gitter-bin-5.0.1-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit desktop multilib-build pax-utils unpacker xdg
+
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="Chat and network platform"
+HOMEPAGE="https://gitter.im"
+SRC_URI="amd64? ( https://update.gitter.im/linux64/${MY_PN}_${PV}_amd64.deb )
+ x86? ( https://update.gitter.im/linux32/${MY_PN}_${PV}_i386.deb )"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="abi_x86_32 +abi_x86_64"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="app-accessibility/at-spi2-core:2[${MULTILIB_USEDEP}]
+ dev-libs/atk:0[${MULTILIB_USEDEP}]
+ dev-libs/expat:0[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr:0[${MULTILIB_USEDEP}]
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib:0[${MULTILIB_USEDEP}]
+ net-print/cups:0[${MULTILIB_USEDEP}]
+ sys-apps/dbus:0[${MULTILIB_USEDEP}]
+ x11-libs/cairo:0[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libdrm:0[${MULTILIB_USEDEP}]
+ x11-libs/libX11:0[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:0/1.12[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite:0[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor:0[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage:0[${MULTILIB_USEDEP}]
+ x11-libs/libXext:0[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:0[${MULTILIB_USEDEP}]
+ x11-libs/libXi:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrender:0[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver:0[${MULTILIB_USEDEP}]
+ x11-libs/libXtst:0[${MULTILIB_USEDEP}]
+ x11-libs/pango:0[${MULTILIB_USEDEP}]"
+
+S="${WORKDIR}"
+
+QA_EXECSTACK="opt/gitter/pnacl/pnacl_public_x86_64_libcrt_platform_a*"
+QA_PREBUILT="opt/gitter/pnacl/pnacl_public_x86_64_pnacl_llc_nexe
+ opt/gitter/pnacl/pnacl_public_x86_64_ld_nexe
+ opt/gitter/pnacl/pnacl_public_x86_64_pnacl_sz_nexe
+ opt/gitter/payload
+ opt/gitter/swiftshader/libEGL.so
+ opt/gitter/swiftshader/libGLESv2.so
+ opt/gitter/chromedriver
+ opt/gitter/lib/libnw.so
+ opt/gitter/lib/libnode.so
+ opt/gitter/lib/libffmpeg.so
+ opt/gitter/nacl_helper
+ opt/gitter/nwjc
+ opt/gitter/nacl_irt_x86_64.nexe
+ opt/gitter/Gitter"
+QA_FLAGS_IGNORED="opt/gitter/minidump_stackwalk
+ opt/gitter/nacl_helper_bootstrap
+ opt/gitter/crashpad_handler
+ opt/gitter/lib/libEGL.so
+ opt/gitter/lib/libGLESv2.so"
+
+src_prepare() {
+ default
+
+ local arch
+ multilib_get_enabled_abis
+ arch="$(usex amd64 "64" "32")"
+
+ # Remove hardcoded paths
+ sed -i \
+ -e '/Exec/s/=.*/=gitter/' \
+ -e '/Icon/s/=.*/=gitter/' \
+ opt/Gitter/linux"${arch}"/gitter.desktop || die "sed failed"
+}
+
+src_install() {
+ local arch
+ arch="$(usex amd64 "64" "32")"
+
+ newicon opt/Gitter/linux"${arch}"/logo.png gitter.png
+ newicon -s 256 opt/Gitter/linux"${arch}"/logo.png gitter.png
+ domenu opt/Gitter/linux"${arch}"/gitter.desktop
+
+ insinto /opt/gitter
+ doins -r opt/Gitter/linux"${arch}"/.
+ fperms -R +x /opt/gitter/lib/ /opt/gitter/swiftshader/ \
+ /opt/gitter/pnacl/pnacl_public_x86_64_{ld_nexe,pnacl_llc_nexe,pnacl_sz_nexe} \
+ /opt/gitter/{Gitter,chromedriver,crashpad_handler,minidump_stackwalk,nwjc,payload} \
+ /opt/gitter/nacl_{helper,helper_bootstrap,irt_x86_64.nexe}
+
+ dosym ../../opt/gitter/Gitter /usr/bin/gitter
+
+ pax-mark -m "${ED}"/opt/gitter/Gitter
+}