summaryrefslogtreecommitdiff
path: root/net-im/libcommuni
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /net-im/libcommuni
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'net-im/libcommuni')
-rw-r--r--net-im/libcommuni/Manifest2
-rw-r--r--net-im/libcommuni/libcommuni-3.6.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/net-im/libcommuni/Manifest b/net-im/libcommuni/Manifest
index 328c4d4eb908..857e3bba379a 100644
--- a/net-im/libcommuni/Manifest
+++ b/net-im/libcommuni/Manifest
@@ -1,3 +1,5 @@
DIST libcommuni-3.5.0_p20200711.tar.gz 471839 BLAKE2B 37a02c473496a0fe9394a8b019678afa96b07b9272556fd538d42d9ec296b34ad4c76b3110ff96732bccbed59f2faeedf80bd7782e7a6e395252c6430cb88fa7 SHA512 578e2f70bdfa0e62eb3acac4e8deb2f6f0c1cd5f0a5e559dae79d2a808b27d3cf63ede146a65026e156d988097a5b7903793acadcd7e9ac567f65c59e6738ed3
+DIST libcommuni-3.6.0.tar.gz 472634 BLAKE2B 0d3d68e27f75cd59ebd61532261e2d3d2c0c2d61d6e08e5b4ed2b21bbf75572f4ce1763fbc4f66c8d5f7c8f9859240ddff5daceeb548d82e2efe936a265031b7 SHA512 cf872d0cdc281a452129a05f5a903eeec3661a4d0d56bdc61bdf95ea969c7b1bcb68534d3d8999fb85ef2b81f17c067b5cd3437351d4635efae3c714567518c0
EBUILD libcommuni-3.5.0_p20200711.ebuild 2172 BLAKE2B d1a3f1511e296fb7d16374b83acf3126e46bf58afc939f29809445b098d72b42e27f608fed49d323402cd4f23c33bbb90ce386f44e54503284d69afc131ebd94 SHA512 291f0e0486da2b005962a24650982951016c7326a19a8bf04d655f650f735833ab0e8ead5a4e247148d1d501904738aaab7fad3fe50edf9eae5b7a6743c2e49e
+EBUILD libcommuni-3.6.0.ebuild 2073 BLAKE2B 6dcebcdac49c2c456745f92051abafd5b3fb872decae6b5476c5ddf45ec63c60bd580726eb87a9e91cf077cc040345982be255641bd0aeeaac79bc27b2fac9c0 SHA512 a7554ffb26a7d439bd70abca6264266d225c1d148641fc00ab5606b16bb34e4b56328d43e0e43d21291e0c29c6f883a13cd7936626d672c69c17abb2e4bc5ee0
MISC metadata.xml 678 BLAKE2B febd32dfdcd5f0513d47d2ada5600344bde61be84b436910a984d6bffe83b76e211bb1e58412a93e54a1e3ca63e226991a8ea89a68b9c0ff0902c416c9193159 SHA512 20b149d2d59a8b8b119d8144f80d28b5d02797b3b3bb6ab09412085b7aafffe9bb6fb46bd79d0951ab5c7fca8987dc3b6fd973e57179c3cac162da9601eb631b
diff --git a/net-im/libcommuni/libcommuni-3.6.0.ebuild b/net-im/libcommuni/libcommuni-3.6.0.ebuild
new file mode 100644
index 000000000000..2b9e4f1c6d9d
--- /dev/null
+++ b/net-im/libcommuni/libcommuni-3.6.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="A cross-platform IRC framework written with Qt"
+HOMEPAGE="https://communi.github.io/"
+SRC_URI="https://github.com/communi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples qml test +uchardet"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ examples? ( || (
+ dev-qt/qtgui:5[X(-)]
+ dev-qt/qtgui:5[xcb(-)]
+ ) )
+ uchardet? ( app-i18n/uchardet )
+ !uchardet? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+src_configure() {
+ local myqmakeargs=( libcommuni.pro
+ # Disables compile run-time benchmarks, as they don't make any sense
+ -config no_benchmarks
+ # Is needed for fixing the QA Notice: The following files contain insecure RUNPATHs
+ -config no_rpath
+ # Compile libcommuni always in Release mode, as Debug seems to do nothing
+ -config release
+ # Don't silence all compile messages
+ -config verbose
+ -config $(usex examples '' 'no_')examples
+ -config $(usex qml '' 'no_')qml
+ -config $(usex test '' 'no_')tests
+ -config $(usex uchardet 'no_' '')icu
+ -config $(usex uchardet '' 'no_')uchardet )
+
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_test() {
+ # This is a hack to delete the existing LD_LIBRARY_PATH and set a new one,
+ # otherwise a test will fail, because it uses the system installed lib instead of the new compiled lib.
+ # The test will fail, when libcommuni is emerged with USE="uchardet" and
+ # libcommuni is already installed with USE="-uchardat", or the other way around.
+ find "${S}" -type f -name 'target_wrapper.sh' -exec sed -i -e "/.*LD_LIBRARY_PATH.*/d" {} \; || die
+ local -x LD_LIBRARY_PATH="${S}/lib"
+
+ default
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ if use examples; then
+ local examples=( "bot" "client" "minimal" "qmlbot" "quick" )
+ for example in ${examples[@]}; do
+ newbin examples/"${example}"/"${example}" libcommuni."${example}"
+ done
+ fi
+
+ einstalldocs
+}