summaryrefslogtreecommitdiff
path: root/net-im/libcommuni
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-11 16:02:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-11 16:02:49 +0100
commit88ebe56470c37b02a044e1091cad6b2df0f3be8f (patch)
treed80b2d9337c01c4a0fe11a2ef9691fc3153ed6d3 /net-im/libcommuni
parent4645b6f17f0da81e9fe84081fb126a37102ba153 (diff)
gentoo resync : 11.05.2018
Diffstat (limited to 'net-im/libcommuni')
-rw-r--r--net-im/libcommuni/Manifest4
-rw-r--r--net-im/libcommuni/files/uchardet.pri17
-rw-r--r--net-im/libcommuni/libcommuni-3.5.0.ebuild74
-rw-r--r--net-im/libcommuni/metadata.xml21
4 files changed, 116 insertions, 0 deletions
diff --git a/net-im/libcommuni/Manifest b/net-im/libcommuni/Manifest
new file mode 100644
index 000000000000..080dbb792f77
--- /dev/null
+++ b/net-im/libcommuni/Manifest
@@ -0,0 +1,4 @@
+AUX uchardet.pri 473 BLAKE2B 811ea967aa76d8c59b4077042819aa952d2b35364fc3d8f7d9b4922839f05c8f31a9a9d33d01a23d8de7b0d0f0c4273c0f60dd27458be120c53aa229c5292917 SHA512 9661b94e66ea1223a3b76927ff88f7d50710706f9183bce2a2f3b612c280e300a9e92fa5e16b3296c26c4ce365f6c93d650c0d2e96ddbfa0159f46b819f111b1
+DIST libcommuni-3.5.0.tar.gz 646734 BLAKE2B 81e2c783625a0befe2d364423e862967bc76e8a66e9b5d7f2f94f46f46530d54b030bfd3a48d7877532092c607295cff5a77ecd8bb669112d53507a1ea18c5b0 SHA512 4d62f7e5edd32b9121f2b69d15a4022ad5d6cf7136dc48d0a1ca4bd413b3334533d7734d6939906fa3426f8db9bc255696107ecada19875c60ce59990b54dee4
+EBUILD libcommuni-3.5.0.ebuild 2246 BLAKE2B 7b32a7bdc00b5e2e0423da7c8d12e040615d9be2ed73dbac4d42c03f0805b3d050eaf65ce98bf4a312911463fdbce5f91b2b41e3fb0ea7e86a888dc7be2cb901 SHA512 008c8942a62a2eeafa66b4d983875d51be1fbdaa42fcc648d120634cc35cae91cce359df08f74012de09c81cd3477ed60fab8b2addbbd29bc2f0a9d4de254f02
+MISC metadata.xml 797 BLAKE2B 9dc5a8109d9b5421c2ae2b8fa49bef5012107e5356975fe3ec2879bf02395d0762b370400c19a9bcefb90583b985c91bfcc42b934849b964496b2857640bccc2 SHA512 61814cbb96bb1a263bdecdba5adf4620dd35d9444065499af20523674573c9297ea39f52b740e7bf19cabf6cb63a116209f95a9a6edc4d25fe7d2966c9e36d7e
diff --git a/net-im/libcommuni/files/uchardet.pri b/net-im/libcommuni/files/uchardet.pri
new file mode 100644
index 000000000000..d22393b76d26
--- /dev/null
+++ b/net-im/libcommuni/files/uchardet.pri
@@ -0,0 +1,17 @@
+######################################################################
+# Communi
+######################################################################
+
+include(../pkg.pri)
+
+pkgExists(uchardet) {
+ CONFIG += link_pkgconfig
+ PKGCONFIG += uchardet
+}
+
+isEmpty(PKGCONFIG) {
+ error("UChardet support has been enabled, but the UChardet installation has not been found. Did you emerged app-i18n/uchardet?")
+} else {
+ LIBS += -luchardet
+ INCPATH += -isystem /usr/include/uchardet
+}
diff --git a/net-im/libcommuni/libcommuni-3.5.0.ebuild b/net-im/libcommuni/libcommuni-3.5.0.ebuild
new file mode 100644
index 000000000000..166369b11ab3
--- /dev/null
+++ b/net-im/libcommuni/libcommuni-3.5.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="A cross-platform IRC framework written with Qt"
+HOMEPAGE="http://communi.github.io/"
+SRC_URI="https://github.com/communi/libcommuni/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qml test +uchardet"
+
+# Compiling with USE="test" is currently broken with dev-libs/icu
+# See: https://github.com/communi/libcommuni/issues/60
+REQUIRED_USE="test? ( uchardet )"
+
+RDEPEND="dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ uchardet? ( app-i18n/uchardet )
+ !uchardet? ( dev-libs/icu:= )"
+
+DEPEND="test? ( dev-qt/qttest:5 )
+ ${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+
+ # Don't use bundled uchardet, use instead app-i18n/uchardet
+ rm -rf src/3rdparty/uchardet-0.0.1/* || die
+ cp "${FILESDIR}"/uchardet.pri src/3rdparty/uchardet-0.0.1/uchardet.pri || die
+}
+
+src_configure() {
+ local myqmakeargs=( libcommuni.pro
+ # Disables compile run-time benchmarks, as they don't make any sense
+ -config no_benchmarks
+ # Disables examples, as no new files are installed
+ -config no_examples
+ # Is needed for fixing the QA Notice: The following files contain insecure RUNPATHs
+ -config no_rpath
+ # Compile libcommuni always in Release mode, as Debug seems to do nothing
+ -config release
+ # Don't silence all compile messages
+ -config verbose
+ -config $(usex qml '' 'no_')install_imports
+ -config $(usex qml '' 'no_')install_qml
+ -config $(usex test '' 'no_')tests
+ -config $(usex uchardet 'no_' '')icu
+ -config $(usex uchardet '' 'no_')uchardet )
+
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_test() {
+ # This is a hack to delete the existing LD_LIBRARY_PATH and set a new one,
+ # otherwise a test will fail, because it uses the system installed lib instead of the new compiled lib.
+ # The test will fail, when libcommuni is emerged with USE="uchardet" and
+ # libcommuni is already installed with USE="-uchardat", or the other way around.
+ find "${S}" -type f -name 'target_wrapper.sh' -exec sed -i -e "/.*LD_LIBRARY_PATH.*/d" {} \; || die
+ local -x LD_LIBRARY_PATH="${S}/lib"
+
+ default
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+ einstalldocs
+}
diff --git a/net-im/libcommuni/metadata.xml b/net-im/libcommuni/metadata.xml
new file mode 100644
index 000000000000..40dcff97d647
--- /dev/null
+++ b/net-im/libcommuni/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ A cross-platform IRC framework written with Qt.
+ Communi provides a set of tools for enabling
+ IRC connectivity in Qt-based C++ and QML applications.
+ </longdescription>
+ <use>
+ <flag name="qml">Install optional qml files.</flag>
+ <flag name="uchardet">Use <pkg>app-i18n/uchardet</pkg>, which is upstreams default, instead of <pkg>dev-libs/icu</pkg>, which makes impossible to run tests.</flag>
+ </use>
+</pkgmetadata>