summaryrefslogtreecommitdiff
path: root/net-im/poezio/poezio-0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /net-im/poezio/poezio-0.14.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'net-im/poezio/poezio-0.14.ebuild')
-rw-r--r--net-im/poezio/poezio-0.14.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/net-im/poezio/poezio-0.14.ebuild b/net-im/poezio/poezio-0.14.ebuild
new file mode 100644
index 000000000000..81e2f3ab9a0b
--- /dev/null
+++ b/net-im/poezio/poezio-0.14.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature xdg
+
+DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
+HOMEPAGE="https://poez.io/"
+LICENSE="GPL-3+"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/${PN}/${PN}.git"
+ inherit git-r3
+
+ # We build the html documentation using sphinx.
+ BDEPEND="dev-python/sphinx"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/slixmpp-1.8.2[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/Do-not-install-man-pages-and-files-in-usr-share-poez.patch"
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+ # Delete unmaintained plugin which requires an excessive external dep
+ rm plugins/mpd_client.py || die
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if [[ -n "${EGIT_REPO_URI}" ]]; then
+ emake -C doc html
+ fi
+}
+
+# Poezio provides its own Python C extension 'poopt', which needs to be
+# correctly discovered to run the tests. See
+# https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions
+python_test() {
+ cd "${T}" || die
+ epytest "${S}"/test
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman data/poezio.1 data/poezio_logs.1
+
+ if [[ -n "${EGIT_REPO_URI}" ]]; then
+ docinto html
+ dodoc -r doc/build/html/*
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "screen autoaway support" dev-python/pyinotify
+}