summaryrefslogtreecommitdiff
path: root/net-im/poezio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /net-im/poezio
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'net-im/poezio')
-rw-r--r--net-im/poezio/Manifest4
-rw-r--r--net-im/poezio/poezio-0.13.1.ebuild51
-rw-r--r--net-im/poezio/poezio-9999.ebuild6
3 files changed, 57 insertions, 4 deletions
diff --git a/net-im/poezio/Manifest b/net-im/poezio/Manifest
index ce2f0b4ec1f2..d0605767ee89 100644
--- a/net-im/poezio/Manifest
+++ b/net-im/poezio/Manifest
@@ -1,4 +1,6 @@
DIST poezio-0.12.tar.gz 585750 BLAKE2B d79cab965b39a9ea191c763e1560bedbf46e3107e1b301a651103caf8f9e63b8465925ea01ac4e2e6b747b66cf5d4be8cabd8be80a069fe4eafcf331c7daada8 SHA512 6249daf23c6f4c1b25a9de686abaa62076e1eac7566da0a174ae3a82e3a53b7f2a86145d20d587a7ee43c8b679d90cb381d5afbfc7860459c5a497e97af32ff4
+DIST poezio-0.13.1.tar.gz 632572 BLAKE2B e8d3d34c5ca8d236a5a434b4b339cab5ea7286c60db3ef5a6012d406848537b587e834b86f7b6049ee8e637a82e883b2d874134bc1f7d64106e0b0f81aab218f SHA512 6c211ef0fa2fc4bd4cce6ab896166eec6bcdc16ad9e774f4d6bf261b404c9ef68b18d934097da0e165b0cce9bd7779da520ac9c3eac30ccf8280f98ef6aa19c6
EBUILD poezio-0.12.ebuild 1153 BLAKE2B 0720504412ee0fad379247625cc32805f856c6094e644d15038ef6bfe58384c6275594942da07f72b4f40f0af0d087b20dfd03965cec31fa0e9583af4886d082 SHA512 579f39195c6178f5e15979ecdb4b6264422d2e75c336831291ced8c9dff27d34384b9a235bc7206ad30958da27d06d2b638e21e0a8ff3ae7bca704ff10c03f8d
-EBUILD poezio-9999.ebuild 1161 BLAKE2B 95320d9a8c8731c724c36a581626fdf854c856a178d1a49827101743828448c0a5e371fed06da0b48cc173e6300ddf0016e9992ebaadd1a89d376b1f96309222 SHA512 f868225e1840dfd954d57367cff5c03a907b9ad909519e615ea984e3bd20fe2bf27278b6341c07a8e7ce8eb485c7bca4be4af419808c5641004ed8a22ff434b4
+EBUILD poezio-0.13.1.ebuild 1128 BLAKE2B 131412633aeb89905e905d262862b4a9f65afb3f80f8e7106fccabe9dd26c82f8376f124b921df216191969e705173b0fdf972d7604f1b906aa846abe020cc10 SHA512 695f47cbdf6b889bf7ef6587f12cf7c06288a880f338d82fdf3a2de76637a7a5c5345a74f3ca0a505b2c0d48f5bafc4d75b2baddc1a28e48227295136baa968f
+EBUILD poezio-9999.ebuild 1128 BLAKE2B 75eaacdb00ee15c4bd4a9dce465b512cfcace63ecdabc94e8c1e9b5f8032a8b4c1af14f52caaff419f02bbf822dc162251510ad833f5878c450506beb7ded9ad SHA512 71fa612dfe17c2c6a390269391b9761753899154d38b7534f8dae4d8c9b0d5621cb425d580e6baec3ec45c3e3f7254625d2fc1686e613e696edb2537d1019781
MISC metadata.xml 320 BLAKE2B 38b85fd661f7ca7a79c83a1070753f1049b7de9049f2d233f32d77ddd2a8cf72cfc8e3b7b27065a5583d6c631a6af0aa3ca70b907ca9c2a2e92f85471da542b2 SHA512 874c300be76a1b931ddebfb8867563696884267891a09e0879e1ceb0f581536ab9acacccb104e9609aef5c61c55e05ebd87d867d332141be9d52cea246dad09c
diff --git a/net-im/poezio/poezio-0.13.1.ebuild b/net-im/poezio/poezio-0.13.1.ebuild
new file mode 100644
index 000000000000..21339aa6804b
--- /dev/null
+++ b/net-im/poezio/poezio-0.13.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
+HOMEPAGE="https://poez.io/"
+LICENSE="ZLIB"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/slixmpp-1.5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DOC_CONTENTS="
+Install these optional runtime dependencies for additional features.
+* dev-python/pyinotify for screen autoaway plugin support.
+"
+DISABLE_AUTOFORMATTING=true
+
+src_prepare() {
+ default
+ # Delete unmaintained plugin which requires an excessive external dep
+ rm plugins/mpd_client.py || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/net-im/poezio/poezio-9999.ebuild b/net-im/poezio/poezio-9999.ebuild
index 2946371c46b8..89a6ccb69f4d 100644
--- a/net-im/poezio/poezio-9999.ebuild
+++ b/net-im/poezio/poezio-9999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1 readme.gentoo-r1
@@ -23,14 +24,13 @@ RDEPEND="
dev-python/aiodns[${PYTHON_USEDEP}]
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/slixmpp[${PYTHON_USEDEP}]
+ >=dev-python/slixmpp-1.5.2[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
DOC_CONTENTS="
Install these optional runtime dependencies for additional features.
-* dev-python/potr for OTR encryption support.
* dev-python/pyinotify for screen autoaway plugin support.
"
DISABLE_AUTOFORMATTING=true