summaryrefslogtreecommitdiff
path: root/net-im/synapse/synapse-1.66.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 15:03:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 15:03:33 +0000
commitc9388864702fdd7b0b56c049eddb41bdb9054dcb (patch)
tree3595822471cd11e6f9f92565ab81ab9c5ee39c3f /net-im/synapse/synapse-1.66.0.ebuild
parenta41f630aea0b4b71a6c9a088571f1eaaf8413d53 (diff)
gentoo auto-resync : 30:10:2022 - 15:03:33
Diffstat (limited to 'net-im/synapse/synapse-1.66.0.ebuild')
-rw-r--r--net-im/synapse/synapse-1.66.0.ebuild126
1 files changed, 0 insertions, 126 deletions
diff --git a/net-im/synapse/synapse-1.66.0.ebuild b/net-im/synapse/synapse-1.66.0.ebuild
deleted file mode 100644
index e63f6f0fdf2c..000000000000
--- a/net-im/synapse/synapse-1.66.0.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=poetry
-
-inherit distutils-r1 multiprocessing optfeature systemd
-
-DESCRIPTION="Reference implementation of Matrix homeserver"
-HOMEPAGE="
- https://matrix.org/
- https://github.com/matrix-org/synapse/
-"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/matrix-org/${PN}.git"
-else
- MY_PV="${PV/_rc/rc}"
- SRC_URI="https://github.com/matrix-org/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
- S="${WORKDIR}/${PN}-${MY_PV}"
- KEYWORDS="amd64 ~ppc64"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="postgres systemd test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- acct-user/synapse
- acct-group/synapse
-"
-RDEPEND="${DEPEND}
- $(python_gen_cond_dep '
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/bcrypt[${PYTHON_USEDEP}]
- dev-python/bleach[${PYTHON_USEDEP}]
- dev-python/canonicaljson[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/frozendict[${PYTHON_USEDEP}]
- dev-python/ijson[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- >=dev-python/matrix-common-1.2.1[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/phonenumbers[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP},webp]
- dev-python/prometheus_client[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pydantic[${PYTHON_USEDEP}]
- dev-python/pymacaroons[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/service_identity[${PYTHON_USEDEP}]
- dev-python/signedjson[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
- dev-python/treq[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- dev-python/unpaddedbase64[${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- systemd? ( dev-python/python-systemd[${PYTHON_USEDEP}] )
- ')
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- ')
- postgres? ( dev-db/postgresql[server] )
- )
-"
-
-src_test() {
- if use postgres; then
- initdb -D "${T}/pgsql" || die
- pg_ctl -w -D "${T}/pgsql" start \
- -o "-h '' -k '${T}'" || die
- createdb -h "${T}" synapse_test || die
-
- local -x SYNAPSE_POSTGRES=1
- local -x SYNAPSE_POSTGRES_HOST="${T}"
- fi
-
- distutils-r1_src_test
-
- if use postgres; then
- pg_ctl -w -D "${T}/pgsql" stop || die
- fi
-}
-
-python_test() {
- "${EPYTHON}" -m twisted.trial -j "$(makeopts_jobs)" tests || die "Tests failed with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
- keepdir /var/{lib,log}/synapse /etc/synapse
- fowners synapse:synapse /var/{lib,log}/synapse /etc/synapse
- fperms 0750 /var/{lib,log}/synapse /etc/synapse
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- systemd_dounit "${FILESDIR}/synapse.service"
-}
-
-pkg_postinst() {
- optfeature "VoIP relaying on your homeserver with turn" net-im/coturn
-
- einfo "In order to generate initial configuration run:"
- einfo "sudo -u synapse synapse_homeserver \\"
- einfo " --server-name matrix.domain.tld \\"
- einfo " --config-path /etc/synapse/homeserver.yaml \\"
- einfo " --generate-config \\"
- einfo " --data-directory /var/lib/synapse \\"
- einfo " --report-stats=no"
- einfo
- einfo "See also upgrade notes:"
- einfo "https://github.com/matrix-org/synapse/blob/develop/docs/upgrade.md"
-}