summaryrefslogtreecommitdiff
path: root/net-irc/anope
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-09 15:48:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-09 15:48:37 +0100
commit60010a4cd6d7c12aaa62f00b5e8a158ed24efba6 (patch)
treea961dd82d2d2719fe5bede9343e9e83cce856d9f /net-irc/anope
parent65a4d80ebaba5d4d407b3d09320b337e0ca20f0a (diff)
gentoo auto-resync : 09:06:2023 - 15:48:36
Diffstat (limited to 'net-irc/anope')
-rw-r--r--net-irc/anope/Manifest2
-rw-r--r--net-irc/anope/anope-2.0.13.ebuild154
2 files changed, 156 insertions, 0 deletions
diff --git a/net-irc/anope/Manifest b/net-irc/anope/Manifest
index 7c78aed48dd6..a1303de5e77d 100644
--- a/net-irc/anope/Manifest
+++ b/net-irc/anope/Manifest
@@ -3,5 +3,7 @@ AUX anope-2.0.7-example.conf-user.patch 391 BLAKE2B 781e413ef79a7ca601710957b519
AUX anope-conf.d-v2 344 BLAKE2B 8817bba9938aa03abf79e61b86ddde537c6ec68b6584074e1f9bc50fe8334c5d0135ca17551390618f60b26d93f0209789b9337879dbecdcb4fced3d2bb88b3b SHA512 ae1851ccaa128404f3a721c92571ae3c4e0efd18c318485594f87da565b2de505ee9ace580b5d1c4ce4a7b53a4eba8338874195ca3a2cbc415ab6facdb3c9d7a
AUX anope-init.d 724 BLAKE2B afe0abfaebf66408ecc1a3c99fdb5795898559551700073078f9352f2ada8ba5bc90fc1a8b5e4779bd132606d9297c19fd418db02d8a26b6629da675f6fc0d8c SHA512 e058ccfb4a44238cd1540704f130207236be71799d0a5f4678638d313d958b10dfc5de9cd515f18ccdd9faf41dc93eaf33b5f4013f534efec00adc401a2cb97c
DIST anope-2.0.11.tar.gz 1812305 BLAKE2B cb1579f5483df1207482458d63d5293375310f8a54ed528b749f8355f122a1a71a0c17b9ef82477bd429f0c672746f5d5c28d51e12d8695c8c1c8368fd651307 SHA512 120588a815600abb93b77d3e9cb18527a61e955e9dbc947e4e62c97bac871325863f519d20535882f3eff136743454c08af62fd3cd4825e5a956fd1a4ac4d728
+DIST anope-2.0.13.tar.gz 1639815 BLAKE2B 922ee06b10140bb7b55942020847ad9aa77333a3d28c1b45c1c601714166d75eba4eae4cb0689d9c31801688b1aacfc132321358d76a1518062462fd904343a0 SHA512 5e6803af1bc1c18e4640920e888e8586be6ce116e80c5d90f48b8490baf4490731a4f896ccfa17ec4b6f47dabb29b05c90ba9b4b2c19907a41850079d3f315b6
EBUILD anope-2.0.11.ebuild 4188 BLAKE2B 403349a823279d2b44c95f747c6ac6bda078b35baa9896d41a9cc4511b5d17d591acc5f0add365d5fa2c310af7d824eed39d3f3c6c7be3592e98e97af34738e6 SHA512 1c6c108109becd0ad68f5419321639d085c5471866d2b73888c445a5f9a4c9302237c17e8924766ea5471ea19627aaf6cab6f67f28ddab72bb04212e367d0280
+EBUILD anope-2.0.13.ebuild 4379 BLAKE2B 4083686f3824d18debbe0f5fb1e02554f0e0fa451c4af64546e408a32e81363775d99390fda30c173d2bbff03ebdd7fdcfc8a429164331bdc9deba2f53b34b1a SHA512 94931f8daa27e4bc2db833ee2cf3260f8ea6fb6131e5b4f9eddb092aef08984eea1c8a79a9b1599d81e9d5007f9ea42230381cc83ecc2289d4802a088ae692e5
MISC metadata.xml 902 BLAKE2B 4208986846c1165a25f7461e3c996107c1d178827f2d5e8d5ab6d4f6970182b42fb130ed976de90027368bd3d845dcadab00df0b430e404333db0f9d538af0f5 SHA512 8be8f6dc110e8943af544916bcae9fb71f74b40d8930c6496a257e386336b18da16c2cf83f2253e0ac925c9884d4e63bf2995ab907d2e8f1b792809f66b3bdd6
diff --git a/net-irc/anope/anope-2.0.13.ebuild b/net-irc/anope/anope-2.0.13.ebuild
new file mode 100644
index 000000000000..5481ad49d61a
--- /dev/null
+++ b/net-irc/anope/anope-2.0.13.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Anope IRC Services"
+HOMEPAGE="https://anope.org/ https://github.com/anope/anope/"
+SRC_URI="https://github.com/anope/anope/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="gnutls ldap mysql pcre sql sqlite ssl tre"
+REQUIRED_USE="sql? ( || ( mysql sqlite ) )"
+
+DEPEND="
+ acct-group/anope
+ acct-user/anope
+ mysql? ( dev-db/mysql-connector-c:= )
+ ssl? ( dev-libs/openssl:= )
+ gnutls? (
+ net-libs/gnutls:=
+ dev-libs/libgcrypt:=
+ )
+ ldap? ( net-nds/openldap:= )
+ pcre? ( dev-libs/libpcre2 )
+ sqlite? ( dev-db/sqlite:3 )
+ tre? ( dev-libs/tre )
+ virtual/libintl
+"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.6-example.conf-pid-path.patch"
+ "${FILESDIR}/${PN}-2.0.7-example.conf-user.patch"
+)
+
+src_prepare() {
+ anope_enable_mod() {
+ local modulefile=${1}
+ ln -s "extra/${modulefile}" "modules/" || \
+ die "Failed to use ${modulefile}"
+ }
+
+ # These all require MySQL specifically
+ if use mysql ; then
+ anope_enable_mod "m_mysql.cpp"
+ anope_enable_mod "stats/irc2sql/irc2sql.cpp"
+ anope_enable_mod "stats/irc2sql/irc2sql.h"
+ anope_enable_mod "stats/irc2sql/tables.cpp"
+ anope_enable_mod "stats/irc2sql/utils.cpp"
+ anope_enable_mod "stats/m_chanstats.cpp"
+ anope_enable_mod "stats/cs_fantasy_top.cpp"
+ anope_enable_mod "stats/cs_fantasy_stats.cpp"
+ anope_enable_mod "m_sql_log.cpp"
+ anope_enable_mod "m_sql_oper.cpp"
+ fi
+
+ use sqlite && anope_enable_mod "m_sqlite.cpp"
+
+ # Any SQL implementation
+ if use sql ; then
+ anope_enable_mod "m_sql_authentication.cpp"
+ fi
+
+ if use ldap ; then
+ anope_enable_mod "m_ldap.cpp"
+ anope_enable_mod "m_ldap_authentication.cpp"
+ anope_enable_mod "m_ldap_oper.cpp"
+ fi
+
+ use gnutls && anope_enable_mod "m_ssl_gnutls.cpp"
+ use pcre && anope_enable_mod "m_regex_pcre2.cpp"
+ use ssl && anope_enable_mod "m_ssl_openssl.cpp"
+ use tre && anope_enable_mod "m_regex_tre.cpp"
+
+ # Unconditional modules
+ anope_enable_mod "m_regex_posix.cpp"
+
+ # Avoid a silly sandbox error - tries to delete /usr/lib/modules
+ sed -i '/install.*REMOVE_RECURSE.*/d' CMakeLists.txt || die
+
+ # Copy anope.conf for fixup to comply w/ prefix
+ cp "${FILESDIR}"/anope-conf.d-v2 "${T}" || die
+
+ # Look in the right place for modules
+ sed -i "s~%LIBDIR%~${EPREFIX}/usr/$(get_libdir)/anope/~" \
+ "${T}"/anope-conf.d-v2 || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBIN_DIR="libexec/anope"
+ -DDB_DIR="../var/lib/anope"
+ -DDOC_DIR="share/doc/${PF}"
+ -DLIB_DIR="$(get_libdir)/anope"
+ -DLOCALE_DIR="share/locale"
+ -DCONF_DIR="/etc/anope"
+ -DLOGS_DIR="../var/log/anope/"
+ )
+
+ # https://gitlab.kitware.com/cmake/cmake/-/issues/24237
+ # https://bugs.anope.org/view.php?id=1753
+ unset CLICOLOR CLICOLOR_FORCE CMAKE_COMPILER_COLOR_DIAGNOSTICS CMAKE_COLOR_DIAGNOSTICS
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ newinitd "${FILESDIR}"/anope-init.d ${PN}
+ newconfd "${T}"/anope-conf.d-v2 ${PN}
+
+ dosym ../libexec/anope/services /usr/bin/services
+ dosym ../libexec/anope/anopesmtp /usr/bin/anopesmtp
+
+ keepdir /var/log/anope /var/lib/anope/backups
+ fowners anope:anope /var/{lib,log}/anope /var/lib/anope/backups
+
+ dodoc -r docs/* data/example.conf
+
+ insinto /etc/anope
+ newins data/example.conf services.conf
+
+ fowners anope:anope /var/log/anope
+ fowners anope:anope /var/lib/anope/backups/
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ # Only tell them about this on a fresh install.
+ ewarn "Anope won't run out of the box, you still have to configure it to match your IRCd's configuration."
+ ewarn "Edit /etc/anope/services.conf to configure Anope."
+ else
+ # We're replacing some versions. Find out which.
+ local ver
+ for ver in ${REPLACING_VERSIONS} ; do
+ if ver_test ${ver} -lt 2.0.7 ; then
+ # In this version, we introduced correct FHS structure
+ # We need the users to make some changes to their services.conf
+ ewarn "Please modify your services.conf to include the following directive:"
+ ewarn "in options{}, please include user=\"anope\" and group=\"anope\""
+ ewarn "This is needed because Anope now starts as root and drops down."
+ ewarn "Reference: https://wiki.anope.org/index.php/2.0/Configuration#Services_Process_Options"
+ fi
+ done
+ fi
+}