summaryrefslogtreecommitdiff
path: root/net-irc/epic4/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-irc/epic4/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-irc/epic4/files')
-rw-r--r--net-irc/epic4/files/epic-defaultserver.patch12
-rw-r--r--net-irc/epic4/files/epic4-2.10.1-make-recursion.patch10
-rw-r--r--net-irc/epic4/files/epic4-2.10.1-perl.patch54
3 files changed, 76 insertions, 0 deletions
diff --git a/net-irc/epic4/files/epic-defaultserver.patch b/net-irc/epic4/files/epic-defaultserver.patch
new file mode 100644
index 000000000000..1dbc2087cce9
--- /dev/null
+++ b/net-irc/epic4/files/epic-defaultserver.patch
@@ -0,0 +1,12 @@
+diff -Naur epic4-1.1.14.orig/include/config.h epic4-1.1.14/include/config.h
+--- epic4-1.1.14.orig/include/config.h 2003-10-28 05:53:57.000000000 +0000
++++ epic4-1.1.14/include/config.h 2004-01-03 13:49:53.083473288 +0000
+@@ -42,7 +42,7 @@
+ * the client will NOT compile and work properly! Use the default here if
+ * you dont have other servers to use.
+ */
+-#define DEFAULT_SERVER "localhost irc.efnet.net irc.undernet.org irc.dal.net"
++#define DEFAULT_SERVER "localhost irc.freenode.net irc.efnet.net irc.undernet.org irc.dal.net"
+
+ /*
+ * The left and right brace characters ('{', '}') are special characters in
diff --git a/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch b/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch
new file mode 100644
index 000000000000..68d7e4c460b6
--- /dev/null
+++ b/net-irc/epic4/files/epic4-2.10.1-make-recursion.patch
@@ -0,0 +1,10 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -210,6 +210,6 @@
+ $(RM) Makefile source/Makefile include/sig.inc config.status config.cache config.log include/defs.h source/info.c.sh
+
+ depend:
+- (cd source;make depend)
++ (cd source;$(MAKE) depend)
+
+ # This is the end of the file.
diff --git a/net-irc/epic4/files/epic4-2.10.1-perl.patch b/net-irc/epic4/files/epic4-2.10.1-perl.patch
new file mode 100644
index 000000000000..ce41d153abc6
--- /dev/null
+++ b/net-irc/epic4/files/epic4-2.10.1-perl.patch
@@ -0,0 +1,54 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Fix broken perl detection somewhat.
+
+--- a/configure.in
++++ b/configure.in
+@@ -636,25 +636,27 @@
+ dnl
+
+ AC_MSG_CHECKING(whether to support Perl)
+-AC_ARG_WITH(perl,
+-[ --with-perl[=PATH] Compile with perl support.],
+-[ test -z "$withval" && withval=yes ],
+-)
+-test "xno" != "x$withval" && for base in $withval /usr/local /usr /
+-do
+- FOUND=
+- for ext in so a dll ; do
+- test -r $base/lib/libperl.$ext && FOUND=1
+- test -r $base/libperl.$ext && FOUND=1
+- done
+- test -n "$FOUND" || continue
+- AC_MSG_RESULT(yes)
+- LIBS="$LIBS `perl -MExtUtils::Embed -e ldopts`"
+- PERLDOTOH="perl.o"
+- AC_DEFINE(PERL)
+- break
+-done
+-test -z "$PERLDOTOH" && AC_MSG_RESULT(no)
++AC_ARG_WITH([perl],
++ [AS_HELP_STRING([--with-perl[=PATH]], [Compile with perl support.])],
++ [],
++ [with_perl=maybe])
++AS_IF([test "xno" != "x$with_perl"],
++ [
++ PERL_LIBS="`perl -MExtUtils::Embed -e ldopts`"
++ AS_IF([test -n "$PERL_LIBS"],
++ [
++ AC_MSG_RESULT([yes])
++ LIBS="$LIBS $PERL_LIBS"
++ AC_DEFINE([PERL], [], [Define if perl support should be compiled])
++ PERLDOTOH="perl.o"
++ ],
++ [
++ AC_MSG_RESULT([no])
++ AS_IF([test "x$with_perl" != "xmaybe"],
++ [AC_MSG_ERROR([You specified --with-perl, but I was unable to find libperl])])
++ ])
++ ])
++
+ withval=''
+
+ dnl ----------------------------------------------------------
+
+Diff finished. Thu Jun 30 22:15:26 2011