summaryrefslogtreecommitdiff
path: root/net-irc/ii/ii-1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /net-irc/ii/ii-1.8.ebuild
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'net-irc/ii/ii-1.8.ebuild')
-rw-r--r--net-irc/ii/ii-1.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/ii/ii-1.8.ebuild b/net-irc/ii/ii-1.8.ebuild
new file mode 100644
index 000000000000..0a4bb49da753
--- /dev/null
+++ b/net-irc/ii/ii-1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="A minimalist FIFO and filesystem-based IRC client"
+HOMEPAGE="https://tools.suckless.org/ii/"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CFLAGS/{s: -Os::g; s:= :+= :g}' \
+ -e '/^CC/d' \
+ -e '/^LDFLAGS/{s:-s::g; s:= :+= :g}' \
+ config.mk || die
+ sed -i \
+ -e 's|@${CC}|$(CC)|g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ii
+ dodoc CHANGES FAQ README
+ doman *.1
+}