summaryrefslogtreecommitdiff
path: root/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210619.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210619.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210619.ebuild')
-rw-r--r--net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210619.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210619.ebuild b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210619.ebuild
new file mode 100644
index 000000000000..b1b787904b84
--- /dev/null
+++ b/net-irc/limnoria-plugins-chantracker/limnoria-plugins-chantracker-1.5_p20210619.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vcs-snapshot
+
+COMMIT="a3d25c44b7a56e3af7b3d8b48ee68a311deed5df"
+
+DESCRIPTION="supybot ban management and channel flood/spam/repeat protections plugin"
+HOMEPAGE="https://github.com/ncoevoet/ChanTracker"
+SRC_URI="https://github.com/ncoevoet/ChanTracker/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+
+RDEPEND="net-irc/limnoria"
+
+DOCS="README.md"
+
+src_install() {
+ default
+ insinto /usr/share/limnoria-extra-plugins/ncoevoet/ChanTracker
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "Before this plugin can be used, your bot will need to be told where to"
+ elog "load it from. To do this, add /usr/share/limnoria-extra-plugins/ncoevoet when"
+ elog "prompted during the bot creation wizard, or add it to a running bots config"
+ elog "with the command"
+ elog
+ elog " config directories.plugins [config directories.plugins], /usr/share/limnoria-extra-plugins/ncoevoet"
+}