summaryrefslogtreecommitdiff
path: root/net-irc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-26 01:25:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-26 01:25:46 +0100
commit21dea977c89ba487b57c7856a4924950e667f209 (patch)
treeea817bd899b4d1759c030d6439f307b28e51588d /net-irc
parentc25088d4fc442a7d6dc3a8d0498b43024888318d (diff)
gentoo auto-resync : 26:09:2024 - 01:25:46
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/Manifest.gzbin8065 -> 8071 bytes
-rw-r--r--net-irc/ircii/Manifest2
-rw-r--r--net-irc/ircii/ircii-20240918.ebuild39
3 files changed, 41 insertions, 0 deletions
diff --git a/net-irc/Manifest.gz b/net-irc/Manifest.gz
index a1dca5884817..7543e66ec36a 100644
--- a/net-irc/Manifest.gz
+++ b/net-irc/Manifest.gz
Binary files differ
diff --git a/net-irc/ircii/Manifest b/net-irc/ircii/Manifest
index 8bbdfb8e91ee..5e3b9b08b244 100644
--- a/net-irc/ircii/Manifest
+++ b/net-irc/ircii/Manifest
@@ -1,4 +1,6 @@
AUX ircii-manpage-path.patch 514 BLAKE2B 09723e9e2d80654c9ca05535b8e14e833af7ed423bad9a32cc8b8200b3263129d85cc614db4a2f77d5778464fc28d2663675a909b7e2b16e570128cb7264cbdf SHA512 ef19be0ac1b5794da5d761131100b85d5d928f6a204fbce1c32b2deedf638cdaf8fe3a92cd06ac9ca0ddcb0b4f918b56ab298731201d54b94550287cddb4d693
DIST ircii-20240111.tar.bz2 576700 BLAKE2B 785177e30dbe3b417aec9fb348574e4f539adcfef41534743c050d39aa0e0ba00ea52accc20b785a836f7496e66975549b85fa17a58c280d893f5c0927e1bb1b SHA512 4705b851671f89d1b4903539eb7e701913748138d460572bfeb7e6d565e760b9782aecb55d82c691f6f182864b12e78e13a7b5a1e3abcd535e5bc24c9815e1aa
+DIST ircii-20240918.tar.bz2 578232 BLAKE2B a636de6900805b040df834fa29e49da608693192ae1e5cfaa0cec00f1d95527401ff529bfb754f9c3a447ee85202bc22a6fc667d748a392ba1a959f4643fe0b6 SHA512 9aadafd2bf56e7d18ed78563553143113374830c8b072d125212a7e94a7057512f2ee8a77412749d9eb345596d0c054e18ec2f3d3e569c54e97db71d4c5b77f1
EBUILD ircii-20240111.ebuild 987 BLAKE2B 78136c777701296927ff867bdbdc470bb32f8ada772fc7e47cf47f91718c69b6d73da0dbaed15b79f143c290d5deb53763373c2d9f686a25f827e85db748424b SHA512 497ce55003e2840e5efbaacec1af748d8c34ebafc72349d2352e61bf86eb7b6f370278e392459c64ac9541631b23521db0b61232b0ead5f1f2eae2562adeca17
+EBUILD ircii-20240918.ebuild 989 BLAKE2B 88fa08a956b941df5834e7892cd7055b0b058b2993ed46fcb1bc2569cf9c9657368b9fbf3b7fbaa101b2b9210211763668ccf96ec5a3978536ef70db3042d410 SHA512 6a3e9035dbd0e62ea1e8d9d7bf4515ac12123943da10bd28321912c050ef60194408620afce3cead3c19b45ab0d31579ef8f7adc092fe910574fc0bc6d80c1ff
MISC metadata.xml 245 BLAKE2B 4988fa1366a9b8a3769e503545339cdd493a0bdc362ca9237b158b94549de1f061477546b00fd3b21dc9325812423f7207071e22e3234d5c0b88c755197557d2 SHA512 e00be68ab9ad3acfce3d2d48721c47cf50e2c6358c9ceb45a2a23fc5303826ea26b9205ce4f230121c2e40c9c467367f2dc57863680899b21e8005034aa9118c
diff --git a/net-irc/ircii/ircii-20240918.ebuild b/net-irc/ircii/ircii-20240918.ebuild
new file mode 100644
index 000000000000..42b05199fb52
--- /dev/null
+++ b/net-irc/ircii/ircii-20240918.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+HOMEPAGE="http://eterna23.net/ircii/"
+SRC_URI="https://ircii.warped.com/${P}.tar.bz2
+ https://ircii.warped.com/old/${P}.tar.bz2
+ https://dev.gentoo.org/~bkohler/dist/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="dev-libs/openssl:0=
+ sys-libs/ncurses:0=
+ virtual/libcrypt:=
+ virtual/libiconv"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-manpage-path.patch" )
+DOCS=( ChangeLog INSTALL NEWS README doc/Copyright doc/crypto doc/VERSIONS
+ doc/ctcp )
+
+src_configure() {
+ tc-export CC
+ # --with-lto only appends -flto (so does --without-lto, sigh)
+ econf
+}
+
+src_install() {
+ # Still needed as of 20221016, otherwise man dirs don't exist
+ # at the right time.
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+}