summaryrefslogtreecommitdiff
path: root/net-libs/NativeThread/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/NativeThread/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/NativeThread/files')
-rw-r--r--net-libs/NativeThread/files/Makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-libs/NativeThread/files/Makefile.patch b/net-libs/NativeThread/files/Makefile.patch
new file mode 100644
index 000000000000..e1f0209a6f3f
--- /dev/null
+++ b/net-libs/NativeThread/files/Makefile.patch
@@ -0,0 +1,22 @@
+--- Makefile 2008-03-03 13:59:06.000000000 +0100
++++ Makefile.new 2008-03-30 16:27:12.000000000 +0200
+@@ -1,14 +1,14 @@
+-CC = gcc
+ INC = $(JAVA_HOME)/include
+-CFLAGS = -Wall -O3 -fPIC
+-LDFLAGS = -shared -Wl,-soname,libnative.so -I$(INC) -I$(INC)/linux
++CFLAGS += -Wall
++LDFLAGS += -shared -Wl,-soname,libnative.so -I$(INC) -I$(INC)/linux
+ LIBS = -lc
+
+ all: clean libNativeThread.so
+
+ NativeThread.class:
+- javac java/NativeThread.java
+- mv java/NativeThread.class freenet/support/io/
++ javac -classpath /usr/share/freenet/lib/freenet.jar NativeThread.java
++ mkdir -p freenet/support/io
++ mv NativeThread.class freenet/support/io/
+
+ libNativeThread.so: NativeThread.c NativeThread.h
+ $(CC) $(CFLAGS) -o libNativeThread.so $(LDFLAGS) NativeThread.c $(LIBS)