summaryrefslogtreecommitdiff
path: root/net-libs/c-client/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-06 09:19:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-06 09:19:42 +0000
commitc8fb42216b10862e8178f91831e4c51fb2c55ac4 (patch)
tree9f469cb5c01b2df6f8591e65242eb65ee749c506 /net-libs/c-client/files
parenta2f130f3156ea1d203e99a781424790176b9b2b5 (diff)
gentoo auto-resync : 06:02:2023 - 09:19:42
Diffstat (limited to 'net-libs/c-client/files')
-rw-r--r--net-libs/c-client/files/c-client-2007f_GENTOO_amd64-so-fix.patch12
-rw-r--r--net-libs/c-client/files/c-client-2007f_p7-implicit-declaration-fix.patch46
-rw-r--r--net-libs/c-client/files/c-client-2007f_p7-ldflags.patch33
3 files changed, 91 insertions, 0 deletions
diff --git a/net-libs/c-client/files/c-client-2007f_GENTOO_amd64-so-fix.patch b/net-libs/c-client/files/c-client-2007f_GENTOO_amd64-so-fix.patch
new file mode 100644
index 000000000000..3a3be7221185
--- /dev/null
+++ b/net-libs/c-client/files/c-client-2007f_GENTOO_amd64-so-fix.patch
@@ -0,0 +1,12 @@
+--- a/src/osdep/unix/Makefile
++++ b/src/osdep/unix/Makefile
+@@ -990,6 +990,9 @@ onceenv:
+ -DLOCKPGM3=\"$(LOCKPGM3)\" > OSCFLAGS
+ echo $(BASELDFLAGS) $(EXTRALDFLAGS) > LDFLAGS
+ echo "$(ARRC) $(ARCHIVE) $(BINARIES) $(LIBRARIES);$(RANLIB) $(ARCHIVE)" > ARCHIVE
++ echo "`$(CAT) CCTYPE` `$(CAT) CFLAGS` `$(CAT) OSFLAGS` -shared \
++ -Wl,-soname,libc-client.so.1 -o libc-client.so.1.0.0 $(BINARIES)" \
++ >> ARCHIVE
+ echo $(ARCHIVE) > ARCHIVENAME
+ echo $(OS) > OSTYPE
+ ./drivers $(EXTRADRIVERS) $(DEFAULTDRIVERS) dummy
diff --git a/net-libs/c-client/files/c-client-2007f_p7-implicit-declaration-fix.patch b/net-libs/c-client/files/c-client-2007f_p7-implicit-declaration-fix.patch
new file mode 100644
index 000000000000..413ddbf43869
--- /dev/null
+++ b/net-libs/c-client/files/c-client-2007f_p7-implicit-declaration-fix.patch
@@ -0,0 +1,46 @@
+This patch solves build issues with -Werror=implicit-function-declaration
+enabled.
+
+- safe_flock is a function from flocklnx.c but header file for consumers
+ is missing, the simplest was to add function prototype to other
+ header file.
+- utime.h is needed also in multiple places but os_slx.h header file is
+ used in all of them
+
+Bug: https://bugs.gentoo.org/870478
+--- a/src/osdep/unix/os_lnx.h
++++ b/src/osdep/unix/os_lnx.h
+@@ -46,6 +46,7 @@
+ #include <sys/types.h>
+ #include <dirent.h>
+ #include <time.h> /* for struct tm */
++#include <utime.h>
+ #include <fcntl.h>
+ #include <syslog.h>
+ #include <sys/file.h>
+@@ -57,6 +58,7 @@
+
+ #define direct dirent
+
++int safe_flock(int, int);
+ #define flock safe_flock
+
+
+--- a/src/osdep/unix/os_slx.h
++++ b/src/osdep/unix/os_slx.h
+@@ -46,6 +46,7 @@
+ #include <sys/types.h>
+ #include <dirent.h>
+ #include <time.h> /* for struct tm */
++#include <utime.h>
+ #include <fcntl.h>
+ #include <syslog.h>
+ #include <sys/file.h>
+@@ -57,6 +58,7 @@
+
+ #define direct dirent
+
++int safe_flock(int, int);
+ #define flock safe_flock
+
+
diff --git a/net-libs/c-client/files/c-client-2007f_p7-ldflags.patch b/net-libs/c-client/files/c-client-2007f_p7-ldflags.patch
new file mode 100644
index 000000000000..8a273355c2f9
--- /dev/null
+++ b/net-libs/c-client/files/c-client-2007f_p7-ldflags.patch
@@ -0,0 +1,33 @@
+--- a/src/osdep/unix/Makefile
++++ b/src/osdep/unix/Makefile
+@@ -975,23 +975,24 @@ os_sol.h:
+
+ # Once-only environment setup
+
+-once: onceenv ckp$(PASSWDTYPE) ssl$(SSLTYPE) osdep.c
++once: ssl$(SSLTYPE) onceenv ckp$(PASSWDTYPE) osdep.c
+
+ onceenv:
+ @echo Once-only environment setup...
+ echo $(CC) > CCTYPE
+- echo $(BASECFLAGS) '$(EXTRACFLAGS)' -DCHUNKSIZE=$(CHUNKSIZE) > CFLAGS
+- echo -DCREATEPROTO=$(CREATEPROTO) -DEMPTYPROTO=$(EMPTYPROTO) \
++ echo `$(CAT) CFLAGS` $(BASECFLAGS) '$(EXTRACFLAGS)' -DCHUNKSIZE=$(CHUNKSIZE) > CFLAGS
++ echo `$(CAT) OSCFLAGS` -DCREATEPROTO=$(CREATEPROTO) -DEMPTYPROTO=$(EMPTYPROTO) \
+ -DMD5ENABLE=\"$(MD5PWD)\" -DMAILSPOOL=\"$(MAILSPOOL)\" \
+ -DANONYMOUSHOME=\"$(MAILSPOOL)/anonymous\" \
+ -DACTIVEFILE=\"$(ACTIVEFILE)\" -DNEWSSPOOL=\"$(NEWSSPOOL)\" \
+ -DLOCKPGM=\"$(LOCKPGM)\" \
+ -DLOCKPGM1=\"$(LOCKPGM1)\" -DLOCKPGM2=\"$(LOCKPGM2)\" \
+ -DLOCKPGM3=\"$(LOCKPGM3)\" > OSCFLAGS
+- echo $(BASELDFLAGS) $(EXTRALDFLAGS) > LDFLAGS
++ echo $(EXTRALIBS) `$(CAT) LDFLAGS` > LIBS
++ echo $(EXTRALDFLAGS) `$(CAT) LDFLAGS` -lcrypt $(BASELDFLAGS) > LDFLAGS
+ echo "$(ARRC) $(ARCHIVE) $(BINARIES) $(LIBRARIES);$(RANLIB) $(ARCHIVE)" > ARCHIVE
+- echo "`$(CAT) CCTYPE` `$(CAT) CFLAGS` `$(CAT) OSFLAGS` -shared \
+- -Wl,-soname,libc-client.so.1 -o libc-client.so.1.0.0 $(BINARIES)" \
++ echo "`$(CAT) CCTYPE` `$(CAT) CFLAGS` $(EXTRALDFLAGS) `$(CAT) OSFLAGS` -shared \
++ -Wl,-soname,libc-client.so.1 -o libc-client.so.1.0.0 $(BINARIES)" `$(CAT) LIBS` $(BASELDFLAGS) \
+ >> ARCHIVE
+ echo $(ARCHIVE) > ARCHIVENAME
+ echo $(OS) > OSTYPE