summaryrefslogtreecommitdiff
path: root/net-libs/canlock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-20 00:15:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-20 00:15:26 +0000
commit1534d50aaf24272ec425fa439389ef7e1f7bf174 (patch)
treec48ca34f49e5c335c0d06b96d9f09d4a74e144d5 /net-libs/canlock
parent2e512e4e32285f8c4eb19586d014cb9d31454ec9 (diff)
gentoo auto-resync : 20:02:2025 - 00:15:26
Diffstat (limited to 'net-libs/canlock')
-rw-r--r--net-libs/canlock/Manifest3
-rw-r--r--net-libs/canlock/canlock-3.3.1.ebuild63
-rw-r--r--net-libs/canlock/files/canlock-3.3.1-disable-shatest.patch24
3 files changed, 90 insertions, 0 deletions
diff --git a/net-libs/canlock/Manifest b/net-libs/canlock/Manifest
index b09b59f6fd5a..aa89a3ae88f5 100644
--- a/net-libs/canlock/Manifest
+++ b/net-libs/canlock/Manifest
@@ -1,3 +1,6 @@
+AUX canlock-3.3.1-disable-shatest.patch 928 BLAKE2B da5b90f496874aab7bd9eef697bcbb7e6129b34ad763085d788a5b10d3bcf99399e6715c099af5f10ee413936e775011c860c23f9755745d9567d7d8f2ffa8f2 SHA512 7044a29b43d96b853f052a1b3e194b4b2b4d66a3a3f2f8601f7efb343377dd7817928af9534dc4b4342aa412f753e4f639609a55848a068e52035608851dc9c8
DIST libcanlock-3.3.0.tar.bz2 625796 BLAKE2B 001512a6d2d226aed93882de8d8f4f02a066cc67e6f21b411b8e1ee2ff0d4580732c90a6fc2756a79f992629cd18fbc319510960c39f33284c86bebfed3d4216 SHA512 100d2b4bf3eadedb7da230317cd37b2c1b259bbd783099a74e0d75fdc6ecddb8a6fd854a2b272bda3629bcf1ac1ae2b3d5657fca9137c17e38aad88f30e4c81c
+DIST libcanlock-3.3.1.tar.bz2 636161 BLAKE2B dc0f58eb3f4b745aeff4e495f58f7821b0b3580dad53c6c7d77a9cfe8042ec757aade0938db3a05713c9a646922890c2a0130c579df110b632179a8a1c043864 SHA512 31ce1b46d38ab673607952fa6885da5a5b6a324e1ca791ae54cdd180c5e8809562c72443073f8a0cbdce6dc0f54742fd0845e46f7b58f0ef63a9207b51b2b2cc
EBUILD canlock-3.3.0.ebuild 1147 BLAKE2B 03bc98ebd93b7f38e1f807382a4aa27dcd8212d7f01bfb68473309d937b936f942ad1bea8eaed5354ba8edf67e5937654408e25df23c12492c5a1eb83dc262e9 SHA512 675acd68c9e4bb3337718f3712ffd73e1b6943974a68c34a3a481264327e9ef8c2504b8999498eaa02f53e95d1aaae2400b90b7f0a6755b7ad77504acedb3e61
+EBUILD canlock-3.3.1.ebuild 1312 BLAKE2B 5d67f244b806ea8a8ec23483b9984c67f3016d16fc54c75269ef370d6419e47261f9e75dbe62edd75d7c325b6167624309661c9c5fc56a160a0362a22466c559 SHA512 4ed448a7c5f8ea1667b27afa69ef3447924e70c236bd243b1587705e9251a8ba22e5a6a93cd048079f793375566ed10823791e088fb9ffbf5cdbc41ec10fbee7
MISC metadata.xml 431 BLAKE2B 970ec8fdb542889d3df72c7520f3b9f1c1c46e75b9cecb85c383c1abaaff42bf5bba5eb3fd1601449355c248c88215420cd799a7c5d53f2f4c5cc22facf1b4e6 SHA512 b53c2d9d53d5b045018923898fe93c181e178f4184beec546919b5d9ce0ba9ae8807d11d26f6291457b75ac96793566a985ee1876c8900518f776ccdf6aa91ab
diff --git a/net-libs/canlock/canlock-3.3.1.ebuild b/net-libs/canlock/canlock-3.3.1.ebuild
new file mode 100644
index 000000000000..fab41df475c8
--- /dev/null
+++ b/net-libs/canlock/canlock-3.3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A library for creating and verifying Usenet cancel locks"
+HOMEPAGE="https://micha.freeshell.org/libcanlock/"
+SRC_URI="https://micha.freeshell.org/lib${PN}/src/lib${P}.tar.bz2"
+S="${WORKDIR}/lib${P}"
+
+LICENSE="BSD MIT"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="header-parser +legacy"
+
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+DOCS=( ChangeLog{,_V{0..2}} README TODO doc/sec_review.txt )
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # Annex K functions, bug #900086
+ # optional, not implemented anywhere we care about
+ memset_s
+ explicit_memset
+)
+
+PATCHES=( "${FILESDIR}/${P}-disable-shatest.patch" )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local econf_args=(
+ --enable-pc-files
+ $(use_enable header-parser hp)
+ $(use_enable legacy legacy-api)
+ )
+
+ econf "${econf_args[@]}"
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ # keep old header location for compability with canlock v2
+ use legacy && dosym ./libcanlock-3/canlock.h /usr/include/canlock.h
+
+ # required for =net-nntp/tin-2.6.0
+ dosym ./libcanlock-3.pc /usr/$(get_libdir)/pkgconfig/libcanlock3.pc
+}
diff --git a/net-libs/canlock/files/canlock-3.3.1-disable-shatest.patch b/net-libs/canlock/files/canlock-3.3.1-disable-shatest.patch
new file mode 100644
index 000000000000..c9b1d425b870
--- /dev/null
+++ b/net-libs/canlock/files/canlock-3.3.1-disable-shatest.patch
@@ -0,0 +1,24 @@
+shatest depends on static library, we don't build this package static
+Transformed from sed
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -41,10 +41,10 @@
+ # ==============================================================================
+ # Rules to build test programs
+
+-check_PROGRAMS = shatest canlocktest canlocktest_multi canlocktest_legacy
++check_PROGRAMS = canlocktest canlocktest_multi canlocktest_legacy
+ CLEANFILES = shatest_check.sh
+
+ # This is required because shatest always return 0 status (even if tests failed)
+ check_SCRIPTS = shatest_check.sh
+
+ # Attention: Linking against the static library is intended here!
+@@ -72,6 +72,6 @@
+ # ==============================================================================
+ # Executables to run for "make check"
+
+-TESTS = shatest shatest_check.sh canlocktest canlocktest_multi \
++TESTS = shatest_check.sh canlocktest canlocktest_multi \
+ canlocktest_legacy
+