summaryrefslogtreecommitdiff
path: root/net-libs/ccrtp/ccrtp-2.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/ccrtp/ccrtp-2.1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/ccrtp/ccrtp-2.1.2.ebuild')
-rw-r--r--net-libs/ccrtp/ccrtp-2.1.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-libs/ccrtp/ccrtp-2.1.2.ebuild b/net-libs/ccrtp/ccrtp-2.1.2.ebuild
new file mode 100644
index 000000000000..02cf6d4014df
--- /dev/null
+++ b/net-libs/ccrtp/ccrtp-2.1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="GNU ccRTP - Implementation of the IETF real-time transport protocol"
+HOMEPAGE="https://www.gnu.org/software/ccrtp/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2"
+IUSE="doc"
+SLOT="0/2"
+
+RDEPEND=">=dev-cpp/commoncpp2-1.3.0:0=
+ dev-libs/libgcrypt:0=
+ >=dev-libs/ucommon-5.0.0:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+ use doc && dohtml -r doc/html/*
+}
+
+pkg_postinst() {
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.4.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.4.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.5.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.5.so.0"
+ fi
+ if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.6.so.0 ]] ; then
+ elog "Please run: revdep-rebuild --library libccrtp1-1.6.so.0"
+ fi
+}