summaryrefslogtreecommitdiff
path: root/net-libs/courier-authlib/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/courier-authlib/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/courier-authlib/files')
-rw-r--r--net-libs/courier-authlib/files/courier-authlib-0.65.0-sqlite.patch35
-rw-r--r--net-libs/courier-authlib/files/courier-authlib-r140
2 files changed, 75 insertions, 0 deletions
diff --git a/net-libs/courier-authlib/files/courier-authlib-0.65.0-sqlite.patch b/net-libs/courier-authlib/files/courier-authlib-0.65.0-sqlite.patch
new file mode 100644
index 000000000000..d6c6480a38b2
--- /dev/null
+++ b/net-libs/courier-authlib/files/courier-authlib-0.65.0-sqlite.patch
@@ -0,0 +1,35 @@
+--- configure.in 2012-10-17 08:50:00.387963153 +0000
++++ configure.in 2012-10-17 08:50:21.121706830 +0000
+@@ -635,7 +635,7 @@
+ LIBS="$saveLIBS"
+ fi
+
+-if test "$doauthmysql" != "yes"
++if test "$doauthsqlite" != "yes"
+ then
+ SQLITE_LIBS=""
+ SQLITE_CFLAGS=""
+--- authsqlite.h 2012-10-03 19:54:10.000000000 +0300
++++ authsqlite.h 2013-03-01 12:03:16.834315060 +0200
+@@ -6,7 +6,9 @@
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sqlite3.h>
++/*
+ #include <errmsg.h>
++*/
+
+ struct authsqliteuserinfo {
+ char *username;
+--- authsqlitelib.c 2012-10-04 05:48:21.000000000 +0300
++++ authsqlitelib.c 2013-03-01 12:03:00.801437111 +0200
+@@ -10,7 +10,9 @@
+ #include <ctype.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++/*
+ #include <mysql.h>
++*/
+ #include <time.h>
+
+ #include "authsqlite.h"
diff --git a/net-libs/courier-authlib/files/courier-authlib-r1 b/net-libs/courier-authlib/files/courier-authlib-r1
new file mode 100644
index 000000000000..5730139a02af
--- /dev/null
+++ b/net-libs/courier-authlib/files/courier-authlib-r1
@@ -0,0 +1,40 @@
+#!/sbin/openrc-run
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+ provide authdaemond
+}
+
+checkconfig() {
+ if [ ! -e /etc/courier/authlib/authdaemonrc ] ; then
+ eerror "You need an /etc/courier/authlib/authdaemonrc file to run authdaemon"
+ return 1
+ fi
+}
+
+setauth() {
+ . /etc/courier/authlib/authdaemonrc
+ AUTHLIB="/usr/lib/courier/courier-authlib"
+ AUTHDAEMOND="authdaemond"
+ pidfile="/var/run/authdaemon.pid"
+ logger="/usr/sbin/courierlogger"
+ export DEBUG_LOGIN DEFAULTOPTIONS LOGGEROPTS
+}
+
+start() {
+ checkconfig || return 1
+ setauth
+ ebegin "Starting courier-authlib: ${AUTHDAEMOND}"
+ start-stop-daemon --quiet --start --pidfile "${pidfile}" --exec \
+ /usr/bin/env ${logger} -- ${LOGGEROPTS} -pid="${pidfile}" -start "${AUTHLIB}/${AUTHDAEMOND}"
+ eend $?
+}
+
+stop() {
+ setauth
+ ebegin "Stopping courier-authlib: ${AUTHDAEMOND}"
+ start-stop-daemon --quiet --stop --pidfile "${pidfile}"
+ eend $?
+}