summaryrefslogtreecommitdiff
path: root/net-libs/davix/davix-0.7.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-libs/davix/davix-0.7.6.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-libs/davix/davix-0.7.6.ebuild')
-rw-r--r--net-libs/davix/davix-0.7.6.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-libs/davix/davix-0.7.6.ebuild b/net-libs/davix/davix-0.7.6.ebuild
index d667decd21ad..cd414ce3d7eb 100644
--- a/net-libs/davix/davix-0.7.6.ebuild
+++ b/net-libs/davix/davix-0.7.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="High-performance file management over WebDAV/HTTP"
HOMEPAGE="https://dmc.web.cern.ch/projects/davix"
@@ -11,7 +11,7 @@ SRC_URI="http://grid-deployment.web.cern.ch/grid-deployment/dms/lcgutil/tar/${PN
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="doc ipv6 kernel_linux test tools"
RESTRICT="!test? ( test )"
@@ -35,7 +35,7 @@ RDEPEND="${CDEPEND}"
REQUIRED_USE="test? ( tools )"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
for x in doc test; do
if ! use $x; then
@@ -58,18 +58,18 @@ src_configure() {
-DSYSCONF_INSTALL_DIR="${EPREFIX}/etc"
-DBUILD_TESTING=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use doc; then
- cmake-utils_src_compile doc
+ cmake_src_compile doc
fi
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if ! use tools; then
rm -rf "${ED}/usr/share/man/man1"