summaryrefslogtreecommitdiff
path: root/net-libs/dleyna/dleyna-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-29 10:01:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-29 10:01:01 +0100
commit8ba401288d74259a5fd8e9de5241dd57a0a73b1f (patch)
treee49dac129b06e1a0a410f4c1b91581ea02d582ff /net-libs/dleyna/dleyna-0.8.1.ebuild
parent746652e918ce7328c0cc5ffef8a79146b91ba21b (diff)
gentoo auto-resync : 29:10:2022 - 10:01:00
Diffstat (limited to 'net-libs/dleyna/dleyna-0.8.1.ebuild')
-rw-r--r--net-libs/dleyna/dleyna-0.8.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/dleyna/dleyna-0.8.1.ebuild b/net-libs/dleyna/dleyna-0.8.1.ebuild
new file mode 100644
index 000000000000..215ae41f05bc
--- /dev/null
+++ b/net-libs/dleyna/dleyna-0.8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A set of services and D-Bus APIs to simplify access to UPnP/DLNA media devices"
+HOMEPAGE="https://gitlab.gnome.org/World/dLeyna"
+SRC_URI="https://gitlab.gnome.org/World/dLeyna/-/archive/v${PV}/dLeyna-v${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0/6" # soname of libdleyna-core-1.0.so
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/gssdp-1.6.0:1.6=
+ >=net-libs/gupnp-1.6.0:1.6=
+ >=net-libs/gupnp-av-0.12.9:0=
+ >=media-libs/gupnp-dlna-0.9.4:2.0=
+ >=net-libs/libsoup-3.0:3.0
+ dev-libs/libxml2
+
+ !net-libs/dleyna-connector-dbus
+ !net-libs/dleyna-core
+ !net-libs/dleyna-renderer
+ !net-misc/dleyna-server
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/docutils
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}"/dLeyna-v${PV}
+
+src_configure() {
+ local emesonargs=(
+ -Ddbus_service_dir="${EPREFIX}/usr/share/dbus-1/services"
+ -Dman_pages=true
+ -Ddocs=false
+ )
+ meson_src_configure
+}