summaryrefslogtreecommitdiff
path: root/net-libs/farstream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /net-libs/farstream
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'net-libs/farstream')
-rw-r--r--net-libs/farstream/Manifest1
-rw-r--r--net-libs/farstream/farstream-0.2.8-r2.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-libs/farstream/Manifest b/net-libs/farstream/Manifest
index e3de73076544..eec03479d868 100644
--- a/net-libs/farstream/Manifest
+++ b/net-libs/farstream/Manifest
@@ -3,4 +3,5 @@ DIST farstream-0.1.2.tar.gz 1265972 BLAKE2B 239deea639f3456170aee1633d0ec0856917
DIST farstream-0.2.8.tar.gz 1315548 BLAKE2B 3f90e6150fd13d02369837b019ad3b935165130b8396133697d0819861f5a5ed79c6eab3efdc3bcc5a6887807285bece21f188bc756ec3cd64a57f5682f5b348 SHA512 7ec5c57f8778f4107cb628dbf411e38b726152cf78920127dff4423239ff7e4980b6b4f938abba2aa21ab984b1e3053e7e648611322a0ce94df0af576df99a7e
EBUILD farstream-0.1.2-r2.ebuild 2374 BLAKE2B c4832a241cce39990bc5a396503cb29090a67799edb33018d2f25a8fee56eb77b9ffa17a04b05ec608dc28cc90382fd7f2620924bd1b506ffd8273f9a5c0bf15 SHA512 1222e9257b9ac280dd94b1e2f75f12369db67ae8efbce4ab6403404b37e60b63de9c06c797eb716ea8150c642cf323153e7ee4a1e246ff51b9a5de69e76ca56c
EBUILD farstream-0.2.8-r1.ebuild 1805 BLAKE2B 60c9a9e789c6cbf48ff33e53b1a4bb7d0e59d88f7f3b8a71254d3b18809fa79667836c60f55a756c7d271ef09e40b173c7c573e6ebb530aaa97bd992d382da45 SHA512 99f415b8069ebfe61bcd65d7679d61d7c12188e3c95955bef8ec0fcff71a2ec9cb3ee5d3bed6db3b0411080c1bf625e210530d855a2f9abee716029128316ab8
+EBUILD farstream-0.2.8-r2.ebuild 1812 BLAKE2B a4f39f68e2b3533b512d50545037642f1d733180aa494b0a62abcc4254c39c8d03939b7082ce2036cf9dfc9ec82d69fb300c1817ddfe118b5af3971961f12378 SHA512 07604f2af4787b842aee1c9f6c8c72b38cf9234cb1dcd833ce97cceb5134f71b7c9b9b23da7d11dbfb306fac444ad9a132b7439099978aeec381892b04df919f
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/net-libs/farstream/farstream-0.2.8-r2.ebuild b/net-libs/farstream/farstream-0.2.8-r2.ebuild
new file mode 100644
index 000000000000..e199f1c8e300
--- /dev/null
+++ b/net-libs/farstream/farstream-0.2.8-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="https://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+introspection test upnp"
+SLOT="0.2/5" # .so version
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+# FIXME: do an out-of-tree build for tests if USE=-msn
+RESTRICT="test"
+
+COMMONDEPEND="
+ >=media-libs/gstreamer-1.4:1.0
+ >=media-libs/gst-plugins-base-1.4:1.0
+ >=dev-libs/glib-2.32:2
+ >=net-libs/libnice-0.1.8
+ introspection? ( >=dev-libs/gobject-introspection-0.10.11:= )
+ upnp? ( >=net-libs/gupnp-igd-0.2:= )
+"
+RDEPEND="${COMMONDEPEND}
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+ media-plugins/gst-plugins-srtp:1.0
+ media-plugins/gst-plugins-libnice:1.0
+"
+DEPEND="${COMMONDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.18
+ virtual/pkgconfig
+ test? (
+ media-libs/gst-plugins-base:1.0[vorbis]
+ media-libs/gst-plugins-good:1.0 )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ plugins="fsrawconference,fsrtpconference,fsmsnconference,fsrtpxdata,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable upnp gupnp) \
+ --with-plugins=${plugins}
+}
+
+src_compile() {
+ # Prevent sandbox violations, bug #539224
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ addpredict /dev
+ gnome2_src_compile
+}