summaryrefslogtreecommitdiff
path: root/net-libs/gloox/gloox-1.0.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /net-libs/gloox/gloox-1.0.22.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'net-libs/gloox/gloox-1.0.22.ebuild')
-rw-r--r--net-libs/gloox/gloox-1.0.22.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/net-libs/gloox/gloox-1.0.22.ebuild b/net-libs/gloox/gloox-1.0.22.ebuild
deleted file mode 100644
index 683420569f62..000000000000
--- a/net-libs/gloox/gloox-1.0.22.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P="${P/_/-}"
-DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
-HOMEPAGE="https://camaya.net/gloox/"
-SRC_URI="https://camaya.net/download/${MY_P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0/17"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug gnutls idn libressl ssl static-libs test zlib"
-
-DEPEND="idn? ( net-dns/libidn:= )
- gnutls? ( net-libs/gnutls )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- zlib? ( sys-libs/zlib )"
-
-RDEPEND="${DEPEND}"
-
-# GnuTLS checks hang forever
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- # Examples are not installed anyway, so - why should we build them?
- local myeconfargs=(
- --without-examples
- $(usex debug "--enable-debug" '')
- $(use_enable static-libs static)
- $(use_with idn libidn)
- $(use_with gnutls)
- $(use_with ssl openssl)
- $(use_with test tests)
- $(use_with zlib)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${ED}" -name "*.la" -delete || die
-}