summaryrefslogtreecommitdiff
path: root/net-libs/gnutls
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 09:06:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 09:06:52 +0100
commit23fb10c075a74a6504647a16c3e06a6378e208c8 (patch)
treeb465c5421ab9289b4ae5f2af17cb3e239d42d8c5 /net-libs/gnutls
parent66cd90d4284850abdf808a598a77040bcda88bd8 (diff)
gentoo auto-resync : 29:07:2022 - 09:06:52
Diffstat (limited to 'net-libs/gnutls')
-rw-r--r--net-libs/gnutls/Manifest3
-rw-r--r--net-libs/gnutls/gnutls-3.7.7.ebuild144
2 files changed, 147 insertions, 0 deletions
diff --git a/net-libs/gnutls/Manifest b/net-libs/gnutls/Manifest
index 8ce3b471c817..585e7a8106fb 100644
--- a/net-libs/gnutls/Manifest
+++ b/net-libs/gnutls/Manifest
@@ -1,4 +1,7 @@
DIST gnutls-3.7.6.tar.xz 6338276 BLAKE2B 9f3cce8dfc0b88f2c42d1d2633417dac649a265407b620b6d15967e5210debb99d287ef31d2b9dc37a527ac1e5b9db4c240b98a63293078fbd2e26ac694bf3d3 SHA512 f872339df80ec31d292821ff00eaafbe50e0bd4cdbb86e21e4f78541cd0a26d843596d5e69c91de4db8ce7d027fc639ae6462b57d89fb116162ae63c5a97486a
DIST gnutls-3.7.6.tar.xz.sig 685 BLAKE2B eae022d6cb0d772e465257411381afd97f3dfd19d6f794a1c3e0f8c3c1232a8a1b91269ca7252a5662782183b11ca393c31efe3f88171a526884400fd0534528 SHA512 c969da9a938b9d29a70cea3b00cce337f9a4c4304aae7f501ef6263894f81a420395ddbe1b005f35dff2e900d3fac75e288f10bbfde0ebea034f7e257bb16d0e
+DIST gnutls-3.7.7.tar.xz 6351664 BLAKE2B a66037ecc6da660ff12949f50012840263c2e0b174079e41b62a2d884f060cee56f0c64a2815d07321a54b08cce016d2b4c8f0e059636c1ab5f7db9c8d64c7c6 SHA512 ba00b20126379ec7e96c6bfa606cfb7bb0d9a5853318b29b5278a42a85ae40d39d8442778938e1f165debcdb1adaf9c63bcec59a4eb3387dd1ac99b08bcc5c08
+DIST gnutls-3.7.7.tar.xz.sig 685 BLAKE2B 53d76a06ed5a74664d6c193459eb310f06e87dd3db97aca9e9fa78837677df58d8de66f187c182b9375786ee0308c5da55f08414183c959c7acb4527c38cd7c7 SHA512 6463bc4661e20051ff9f31c1a557cece34d06b748f4e24f98e807ddc72a3daa9348aa9f0afa83a0f9cd226421c575210eec1936fbeb9a55849e2c397ace9d03d
EBUILD gnutls-3.7.6.ebuild 4767 BLAKE2B 06efaab9ed7e1fac0b84daf3c4c2574ec727e4dc4c3a8a1285db286d5e47e094f5ce22f57753362b9565bfd0b75a63cddffc7257127aeab6663bd75cbf4917e2 SHA512 2e882b0a30a000abbe1297ef1d48239ee59c7a97782d085418d39fa7ebab33fb2035e12aa555da57ce251399b0289ed8c3555b849e5b0e0ddbbb85bf597691bd
+EBUILD gnutls-3.7.7.ebuild 4776 BLAKE2B 0b9faccfc562c88bbadbd1909219fd75b3e298a7414d97a6e32b5b3fdf5256be10665f137efff740c29cf08afed2c6b02b8b725a903842c54a1cc0564154c0d0 SHA512 8fecdeccac71a720962c47f671aae5eb2c6fe7b0ff31c2b5371f6e5378453922c5fa4043a84b40b4de9a4b4fce84e046e7bd8ec9be54d960f7ec8569a750405c
MISC metadata.xml 1336 BLAKE2B 9278a179b80a8613198cba0c9e03c3be3135aab13a85da638d4db582d93235177e46c02b1b71b9e3ee1dbbedc204c0393085147d0b15aa0d6a3fb5716a7ca834 SHA512 66564b03a0a39797c34945308b94065e66b1cc662ebeec80207bf4131f9fc62bf34d010ec22811acb2c98776f0f7cbebb29eaa8fd49351becab9901d46df6249
diff --git a/net-libs/gnutls/gnutls-3.7.7.ebuild b/net-libs/gnutls/gnutls-3.7.7.ebuild
new file mode 100644
index 000000000000..2257a4122b73
--- /dev/null
+++ b/net-libs/gnutls/gnutls-3.7.7.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/gnutls.asc
+inherit libtool multilib-minimal verify-sig
+
+DESCRIPTION="A secure communications library implementing the SSL, TLS and DTLS protocols"
+HOMEPAGE="https://www.gnutls.org/"
+SRC_URI="mirror://gnupg/gnutls/v$(ver_cut 1-2)/${P}.tar.xz"
+SRC_URI+=" verify-sig? ( mirror://gnupg/gnutls/v$(ver_cut 1-2)/${P}.tar.xz.sig )"
+
+LICENSE="GPL-3 LGPL-2.1+"
+SLOT="0/30.30" # <libgnutls.so number>.<libgnutlsxx.so number>
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="brotli +cxx dane doc examples guile +idn nls +openssl pkcs11 seccomp sslv2 sslv3 static-libs test test-full +tls-heartbeat tools valgrind zlib zstd"
+
+REQUIRED_USE="test-full? ( cxx dane doc examples guile idn nls openssl pkcs11 seccomp tls-heartbeat tools )"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-libs/libtasn1-4.9:=[${MULTILIB_USEDEP}]
+ dev-libs/libunistring:=[${MULTILIB_USEDEP}]
+ >=dev-libs/nettle-3.6:=[gmp,${MULTILIB_USEDEP}]
+ >=dev-libs/gmp-5.1.3-r1:=[${MULTILIB_USEDEP}]
+ brotli? ( >=app-arch/brotli-1.0.0:=[${MULTILIB_USEDEP}] )
+ dane? ( >=net-dns/unbound-1.4.20:=[${MULTILIB_USEDEP}] )
+ guile? ( >=dev-scheme/guile-2:=[networking] )
+ nls? ( >=virtual/libintl-0-r1:=[${MULTILIB_USEDEP}] )
+ pkcs11? ( >=app-crypt/p11-kit-0.23.1[${MULTILIB_USEDEP}] )
+ idn? ( >=net-dns/libidn2-0.16-r1:=[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ zstd? ( >=app-arch/zstd-1.3.0:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? (
+ seccomp? ( sys-libs/libseccomp )
+ )"
+BDEPEND="
+ dev-util/gtk-doc-am
+ >=virtual/pkgconfig-0-r1
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )
+ valgrind? ( dev-util/valgrind )
+ test-full? (
+ app-crypt/dieharder
+ >=app-misc/datefudge-1.22
+ dev-libs/softhsm:2[-bindist(-)]
+ net-dialup/ppp
+ net-misc/socat
+ )
+ verify-sig? ( >=sec-keys/openpgp-keys-gnutls-20220320 )"
+
+DOCS=( README.md doc/certtool.cfg )
+
+HTML_DOCS=()
+
+pkg_setup() {
+ # bug #520818
+ export TZ=UTC
+
+ use doc && HTML_DOCS+=(
+ doc/gnutls.html
+ )
+}
+
+src_prepare() {
+ default
+
+ # don't try to use system certificate store on macOS, it is
+ # confusingly ignoring our ca-certificates and more importantly
+ # fails to compile in certain configurations
+ sed -i -e 's/__APPLE__/__NO_APPLE__/' lib/system/certs.c || die
+
+ # Use sane .so versioning on FreeBSD.
+ elibtoolize
+}
+
+multilib_src_configure() {
+ LINGUAS="${LINGUAS//en/en@boldquot en@quot}"
+
+ local libconf=()
+
+ # TPM needs to be tested before being enabled
+ # Note that this may add a libltdl dep when enabled. Check configure.ac.
+ libconf+=(
+ --without-tpm
+ --without-tpm2
+ )
+
+ # hardware-accel is disabled on OSX because the asm files force
+ # GNU-stack (as doesn't support that) and when that's removed ld
+ # complains about duplicate symbols
+ [[ ${CHOST} == *-darwin* ]] && libconf+=( --disable-hardware-acceleration )
+
+ # Cygwin as does not understand these asm files at all
+ [[ ${CHOST} == *-cygwin* ]] && libconf+=( --disable-hardware-acceleration )
+
+ # -fanalyzer substantially slows down the build and isn't useful for
+ # us. It's useful for upstream as it's static analysis, but it's not
+ # useful when just getting something built.
+ export gl_cv_warn_c__fanalyzer=no
+
+ local myeconfargs=(
+ $(multilib_native_enable manpages)
+ $(multilib_native_use_enable doc gtk-doc)
+ $(multilib_native_use_enable doc)
+ $(multilib_native_use_enable guile)
+ $(multilib_native_use_enable seccomp seccomp-tests)
+ $(multilib_native_use_enable test tests)
+ $(multilib_native_use_enable test-full full-test-suite)
+ $(multilib_native_use_enable tools)
+ $(multilib_native_use_enable valgrind valgrind-tests)
+ $(use_enable cxx)
+ $(use_enable dane libdane)
+ $(use_enable nls)
+ $(use_enable openssl openssl-compatibility)
+ $(use_enable sslv2 ssl2-support)
+ $(use_enable sslv3 ssl3-support)
+ $(use_enable static-libs static)
+ $(use_enable tls-heartbeat heartbeat-support)
+ $(use_with brotli)
+ $(use_with idn)
+ $(use_with pkcs11 p11-kit)
+ $(use_with zlib)
+ $(use_with zstd)
+ --disable-rpath
+ --with-default-trust-store-file="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
+ --with-unbound-root-key-file="${EPREFIX}"/etc/dnssec/root-anchors.txt
+ --without-included-libtasn1
+ $("${S}/configure" --help | grep -o -- '--without-.*-prefix')
+ )
+
+ ECONF_SOURCE="${S}" econf "${libconf[@]}" "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}