summaryrefslogtreecommitdiff
path: root/net-libs/grpc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /net-libs/grpc/files
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'net-libs/grpc/files')
-rw-r--r--net-libs/grpc/files/grpc-1.13.0-fix-host-ar-handling.patch47
-rw-r--r--net-libs/grpc/files/grpc-1.15.0-fix-cpp-so-version.patch70
-rw-r--r--net-libs/grpc/files/grpc-1.16.0-Prevent-shell-calls-longer-than-ARG_MAX.patch70
-rw-r--r--net-libs/grpc/files/grpc-1.16.0-gcc8-fixes.patch46
4 files changed, 0 insertions, 233 deletions
diff --git a/net-libs/grpc/files/grpc-1.13.0-fix-host-ar-handling.patch b/net-libs/grpc/files/grpc-1.13.0-fix-host-ar-handling.patch
deleted file mode 100644
index 926952f47f2a..000000000000
--- a/net-libs/grpc/files/grpc-1.13.0-fix-host-ar-handling.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 7e2d98df390787797fa494b26c72896f16f6e2a6 Mon Sep 17 00:00:00 2001
-From: Georgy Yakovlev <gyakovlev@gentoo.org>
-Date: Sat, 30 Jun 2018 00:21:53 -0700
-Subject: [PATCH] Makefile: fix host ar handling
-
-Cherry picked lines from
-https://github.com/grpc/grpc/pull/11476
----
- Makefile | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 8333858588..b5a44b7096 100644
---- a/Makefile
-+++ b/Makefile
-@@ -328,6 +328,7 @@ HOST_CC ?= $(CC)
- HOST_CXX ?= $(CXX)
- HOST_LD ?= $(LD)
- HOST_LDXX ?= $(LDXX)
-+HOST_AR ?= $(AR)
-
- CFLAGS += -std=c99 -Wsign-conversion -Wconversion $(W_SHADOW) $(W_EXTRA_SEMI)
- CXXFLAGS += -std=c++11
-@@ -444,6 +445,7 @@ HOST_CFLAGS = $(CFLAGS)
- HOST_CXXFLAGS = $(CXXFLAGS)
- HOST_LDFLAGS = $(LDFLAGS)
- HOST_LDLIBS = $(LDLIBS)
-+HOST_AROPTS = $(AROPTS)
-
- # These are automatically computed variables.
- # There shouldn't be any need to change anything from now on.
-@@ -6886,10 +6888,10 @@ $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a: protobuf_dep_error
- else
-
- $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a: $(ZLIB_DEP) $(CARES_DEP) $(ADDRESS_SORTING_DEP) $(PROTOBUF_DEP) $(LIBGRPC_PLUGIN_SUPPORT_OBJS)
-- $(E) "[AR] Creating $@"
-+ $(E) "[HOSTAR] Creating $@"
- $(Q) mkdir -p `dirname $@`
- $(Q) rm -f $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a
-- $(Q) $(AR) $(AROPTS) $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a $(LIBGRPC_PLUGIN_SUPPORT_OBJS)
-+ $(Q) $(HOST_AR) $(HOST_AROPTS) $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a $(LIBGRPC_PLUGIN_SUPPORT_OBJS)
- ifeq ($(SYSTEM),Darwin)
- $(Q) ranlib -no_warning_for_no_symbols $(LIBDIR)/$(CONFIG)/libgrpc_plugin_support.a
- endif
---
-2.18.0
-
diff --git a/net-libs/grpc/files/grpc-1.15.0-fix-cpp-so-version.patch b/net-libs/grpc/files/grpc-1.15.0-fix-cpp-so-version.patch
deleted file mode 100644
index ba2ca651f0c3..000000000000
--- a/net-libs/grpc/files/grpc-1.15.0-fix-cpp-so-version.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From a443abbdbbd402951138bb8fcb2a4f159b920fcd Mon Sep 17 00:00:00 2001
-From: Georgy Yakovlev <gyakovlev@gentoo.org>
-Date: Wed, 12 Sep 2018 11:22:48 -0700
-Subject: [PATCH] Fix cpp soname symlinks
-
----
- Makefile | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 4e993782ee..09bd52e8ad 100644
---- a/Makefile
-+++ b/Makefile
-@@ -3050,7 +3050,7 @@ install-shared_cxx: shared_cxx strip-shared_cxx install-shared_c install-pkg-con
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpc++$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpc++.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpc++$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpc++$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpc++$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++.so
- endif
- $(E) "[INSTALL] Installing $(SHARED_PREFIX)grpc++_cronet$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP)"
-@@ -3059,7 +3059,7 @@ endif
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpc++_cronet$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_cronet.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpc++_cronet$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_cronet.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpc++_cronet$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_cronet.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpc++_cronet$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_cronet.so
- endif
- $(E) "[INSTALL] Installing $(SHARED_PREFIX)grpc++_error_details$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP)"
-@@ -3068,7 +3068,7 @@ endif
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpc++_error_details$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_error_details.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpc++_error_details$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_error_details.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpc++_error_details$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_error_details.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpc++_error_details$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_error_details.so
- endif
- $(E) "[INSTALL] Installing $(SHARED_PREFIX)grpc++_reflection$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP)"
-@@ -3077,7 +3077,7 @@ endif
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpc++_reflection$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_reflection.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpc++_reflection$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_reflection.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpc++_reflection$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_reflection.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpc++_reflection$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_reflection.so
- endif
- $(E) "[INSTALL] Installing $(SHARED_PREFIX)grpc++_unsecure$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP)"
-@@ -3086,7 +3086,7 @@ endif
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpc++_unsecure$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_unsecure.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpc++_unsecure$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_unsecure.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpc++_unsecure$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_unsecure.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpc++_unsecure$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpc++_unsecure.so
- endif
- $(E) "[INSTALL] Installing $(SHARED_PREFIX)grpcpp_channelz$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP)"
-@@ -3095,7 +3095,7 @@ endif
- ifeq ($(SYSTEM),MINGW32)
- $(Q) $(INSTALL) $(LIBDIR)/$(CONFIG)/libgrpcpp_channelz$(SHARED_VERSION_CPP)-dll.a $(prefix)/$(INSTALL_LIBDIR)/libgrpcpp_channelz.a
- else ifneq ($(SYSTEM),Darwin)
-- $(Q) ln -sf $(SHARED_PREFIX)grpcpp_channelz$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpcpp_channelz.so.6
-+ $(Q) ln -sf $(SHARED_PREFIX)grpcpp_channelz$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpcpp_channelz.so.1
- $(Q) ln -sf $(SHARED_PREFIX)grpcpp_channelz$(SHARED_VERSION_CPP).$(SHARED_EXT_CPP) $(prefix)/$(INSTALL_LIBDIR)/libgrpcpp_channelz.so
- endif
- ifneq ($(SYSTEM),MINGW32)
---
-2.18.0
-
diff --git a/net-libs/grpc/files/grpc-1.16.0-Prevent-shell-calls-longer-than-ARG_MAX.patch b/net-libs/grpc/files/grpc-1.16.0-Prevent-shell-calls-longer-than-ARG_MAX.patch
deleted file mode 100644
index fd9f91419542..000000000000
--- a/net-libs/grpc/files/grpc-1.16.0-Prevent-shell-calls-longer-than-ARG_MAX.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 0892788776d60d92a0cddcd22078779166b736db Mon Sep 17 00:00:00 2001
-From: Dario Berzano <dario.berzano@cern.ch>
-Date: Thu, 5 Jul 2018 11:27:20 +0200
-Subject: [PATCH] Prevent shell calls longer than ARG_MAX
-
-This patch we breaks the relevant paths array into multiple shorter arrays in
-order to make the shell calls succeed.
-
-See grpc/grpc#14844.
----
- Makefile | 16 ++++++++++++++++
- 1 file changed, 16 insertions(+)
-
-diff --git a/Makefile b/Makefile
-index 54823a31167..25eb092d996 100644
---- a/Makefile
-+++ b/Makefile
-@@ -2946,8 +2946,14 @@ install-headers_c:
-
- install-headers_cxx:
- $(E) "[INSTALL] Installing public C++ headers"
-- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
-- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
-+ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX1), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
-+ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX1), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
-+ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX2), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
-+ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX2), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
-+ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX3), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
-+ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX3), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
-+ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX4), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
-+ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX4), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
-
- install-static: install-static_c install-static_cxx
-
-@@ -5278,6 +5284,8 @@ PUBLIC_HEADERS_CXX += \
- include/grpc++/support/stub_options.h \
- include/grpc++/support/sync_stream.h \
- include/grpc++/support/time.h \
-+
-+PUBLIC_HEADERS_CXX1 += \
- include/grpcpp/alarm.h \
- include/grpcpp/channel.h \
- include/grpcpp/client_context.h \
-@@ -5325,6 +5333,8 @@ PUBLIC_HEADERS_CXX += \
- include/grpcpp/support/stub_options.h \
- include/grpcpp/support/sync_stream.h \
- include/grpcpp/support/time.h \
-+
-+PUBLIC_HEADERS_CXX2 += \
- include/grpc/support/alloc.h \
- include/grpc/support/atm.h \
- include/grpc/support/atm_gcc_atomic.h \
-@@ -5376,6 +5386,8 @@ PUBLIC_HEADERS_CXX += \
- include/grpc/impl/codegen/propagation_bits.h \
- include/grpc/impl/codegen/slice.h \
- include/grpc/impl/codegen/status.h \
-+
-+PUBLIC_HEADERS_CXX3 += \
- include/grpc++/impl/codegen/async_stream.h \
- include/grpc++/impl/codegen/async_unary_call.h \
- include/grpc++/impl/codegen/byte_buffer.h \
-@@ -5406,6 +5418,8 @@ PUBLIC_HEADERS_CXX += \
- include/grpc++/impl/codegen/stub_options.h \
- include/grpc++/impl/codegen/sync_stream.h \
- include/grpc++/impl/codegen/time.h \
-+
-+PUBLIC_HEADERS_CXX4 += \
- include/grpcpp/impl/codegen/async_generic_service.h \
- include/grpcpp/impl/codegen/async_stream.h \
- include/grpcpp/impl/codegen/async_unary_call.h \
diff --git a/net-libs/grpc/files/grpc-1.16.0-gcc8-fixes.patch b/net-libs/grpc/files/grpc-1.16.0-gcc8-fixes.patch
deleted file mode 100644
index 0afd8254dec0..000000000000
--- a/net-libs/grpc/files/grpc-1.16.0-gcc8-fixes.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 807a938a576ec52bc8c971100b2da26b059d9347 Mon Sep 17 00:00:00 2001
-From: Tobias Jungel <tobias.jungel@gmail.com>
-Date: Wed, 22 Aug 2018 21:14:46 +0200
-Subject: [PATCH 1/2] mitigate gcc8 -Werror=ignored-qualifiers
-
----
- src/core/ext/transport/chttp2/transport/flow_control.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/core/ext/transport/chttp2/transport/flow_control.cc b/src/core/ext/transport/chttp2/transport/flow_control.cc
-index 53932bcb7f5..4b1862735d6 100644
---- a/src/core/ext/transport/chttp2/transport/flow_control.cc
-+++ b/src/core/ext/transport/chttp2/transport/flow_control.cc
-@@ -190,7 +190,7 @@ TransportFlowControl::TransportFlowControl(const grpc_chttp2_transport* t,
- uint32_t TransportFlowControl::MaybeSendUpdate(bool writing_anyway) {
- FlowControlTrace trace("t updt sent", this, nullptr);
- const uint32_t target_announced_window =
-- static_cast<const uint32_t>(target_window());
-+ static_cast<uint32_t>(target_window());
- if ((writing_anyway || announced_window_ <= target_announced_window / 2) &&
- announced_window_ != target_announced_window) {
- const uint32_t announce = static_cast<uint32_t> GPR_CLAMP(
-
-From 5a03e7f10145c6591f313055907a9cf26ccb9234 Mon Sep 17 00:00:00 2001
-From: Tobias Jungel <tobias.jungel@gmail.com>
-Date: Wed, 22 Aug 2018 21:17:01 +0200
-Subject: [PATCH 2/2] mitigate gcc8 -Werror=stringop-truncation
-
----
- .../client_channel/lb_policy/grpclb/load_balancer_api.cc | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc b/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc
-index f24281a5bfb..8c064214729 100644
---- a/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc
-+++ b/src/core/ext/filters/client_channel/lb_policy/grpclb/load_balancer_api.cc
-@@ -68,7 +68,8 @@ grpc_grpclb_request* grpc_grpclb_request_create(const char* lb_service_name) {
- req->has_initial_request = true;
- req->initial_request.has_name = true;
- strncpy(req->initial_request.name, lb_service_name,
-- GRPC_GRPCLB_SERVICE_NAME_MAX_LENGTH);
-+ GRPC_GRPCLB_SERVICE_NAME_MAX_LENGTH - 1);
-+ req->initial_request.name[GRPC_GRPCLB_SERVICE_NAME_MAX_LENGTH - 1] = '\0';
- return req;
- }
-